mkisofs doesn't properly convert lower case filenames to upper case

Bug #70098 reported by Forest Bond on 2006-11-03
4
Affects Status Importance Assigned to Milestone
cdrkit (Ubuntu)
Undecided
Unassigned

Bug Description

The end result is that DOS is unable to fully utilize the file system. (Using "dir" gives me a listing, but I am unable to switch to any directories). If I rename files prior to running mkisofs, everything goes according to plan. I am using the same exact options that still work fine under Dapper / Sarge:

mkisofs -r -b boot/win98sec.img -c boot/boot.catalog -o build/bootcd.iso src

I tried using -input-charset and -output-charset to fix the problem, but that did not seem to help.

enyc (enyc) wrote :

I have noticed exactly the same problem, when making CD images to use in dos/windoze-9x in qemu. As far as I can tell, the mkisofs in dapper works fine. I have been successful in using the dapper mkisofs binary (installed as /usr/local/bin/mkisofs.dapper) on an edgy system as a workaround for now.
All the same, edgy mkisofs in definitely broken -- almost as if it has -relaxed-filenames enabled when this has not been specified. I also notice that setting iso level 1 explicitly still does not fix the problem.

enyc (enyc) wrote :

marking as confirmed

Changed in cdrtools:
status: Unconfirmed → Confirmed
enyc (enyc) wrote :

As far as I can see this is indeed a regression somewhere (e.g. with one of the patches that has been applied or some associated library).

In the manpage supplied with mkisofs in edgy:-
    -allow-lowercase This options allows lower case characters to appear in iso9660 filenames. This violates the ISO9660 standard, but it happens to work on some systems. Use with caution.
In the --help for mkisofs in edgy:-
    -allow-lowercase Allow lower case characters in addition to the current character set (violates ISO9660)

The problem being that somehow or other mkisofs acts as if -allow-lowercase has been specified, even though this is not the case!

How should this be debugged?
Should edgy version be tested on dapper somehow?
Should mkisofs-edgy be built without some of the unofficial patches applied?

Debugging suggestions wanted please ;-).

enyc (enyc) wrote :

On further investigation, the Ubuntu-Feisty version of genisoimage (9:1.1.0-1) running on edgy also does not have this problem!
I understand genisoimage is a fork of mkisofs now used in preference to mkisofs in etch and edgy.

I.e. This problem is edgy specific as far as I can tell!

Wow, I spent the better part of today trying to figure out why my disks didn't work in DOS systems, not very promising that this bug is almost 2 months old and no fix for edgy yet.

On Tue, Jan 02, 2007 at 12:07:47AM -0000, Jason Straight (LeeJunFan) wrote:
> Wow, I spent the better part of today trying to figure out why my disks
> didn't work in DOS systems, not very promising that this bug is almost 2
> months old and no fix for edgy yet.

There probably won't be a fix released for Edgy. I understand this will be
fixed in Feisty, and it's not, for most people, a critical bug.

You may, of course, request a backport of the Feisty version to Edgy. That
would probably fix the issue (but may not ...).

-Forest

Schily (schilling-fokus) wrote :

Unfortunately the description of the problem is not
sufficient to understand the problem.

But in order to make sure that your problem is not caused
by a defective fork (you may not be using original software),
I encourage you to upgrade to a recent original

http://cdrecord.berlios.de/

and test again.

Forest Bond (forest-bond) wrote :

Schily,

Debian and Ubuntu now provide genisoimage instead of mkisofs. While the original bug, as posted, may have been due to a Debian/Ubuntu-specific patch, this has become a non-issue for people that have moved on to Ubuntu 7.04.

-Forest

Schily (schilling-fokus) wrote :

Does that mean that ubuntu is a non-free Linux distribution?

http://cdrecord.berlios.de/old/private/linux-dist.html

Forest Bond (forest-bond) wrote :

On Fri, Jul 27, 2007 at 12:56:59PM -0000, Schily wrote:
> Does that mean that ubuntu is a non-free Linux distribution?
>
> http://cdrecord.berlios.de/old/private/linux-dist.html

No, I am free to compile from source if I so choose. My freedom is in now way
harmed by my distribution's preference for a software package you don't approve
of.

Please don't use a poorly thought out ideological argument to mask your spite
for a fork of your project. I understand there may be hard feelings, but this
doesn't seem productive to me.

-Forest
--
Forest Bond
http://www.alittletooquiet.net

Schily (schilling-fokus) wrote :

Ubuntu now has again a true mkisofs. Please test again with the original cdrtools package.

There is no known problem with mkisofs that looks similar to yours.

Please try the mkisofs version from gutsy/multiverse

Note that you may need to uninstall cdrkit packages before as these packages may include files they do not own.

Schily (schilling-fokus) wrote :

Reassigning to cdrkit as "enyc" confirmed in December 2006 that this is a genisoimage specific bug.

The fix is to install mkisofs from gutsy/multiverse

enyc (enyc) wrote :

> Reassigning to cdrkit as "enyc" confirmed in December 2006 that this is
> a genisoimage specific bug.
> The fix is to install mkisofs from gutsy/multiverse
Error Error, [incorrect!!]

This is a problem in Mkisofs in Edgy6.10. This bug does not affect
   Dapper6.06 "mkisofs" or Feisty7.04 "genisoimage" or Gutsy7.10
   "genisoimage" (at least on 20070916).

You can run this test on any version of mkisofs/genisoimage:-
$ mkdir test
$ cd test
$ echo test > filea
$ echo test > fileB
$ echo test > FILEc
$ echo test > FILED
$ genisoimage -o test.iso *
$ hexdump -C test.iso | less
Look for FILEA FILEB FILEC FILED in there (good)
   [if-bad you will see lowercase letters].
You can also do the above test on "mkisofs" too.

I have found that:-
mkisofs_2.01+01a01-4ubuntu6_i386.deb (dapper6.06) = ok
mkisofs_2.01+01a03-5ubuntu2_i386.deb (edgy6.10) = AFFECTED
genisoimage_1.1.2-1_i386.deb (feisty7.04) = ok
genisoimage_1.1.6-1ubuntu2_i386.deb (gutsy7.10) = ok

Therefore, this is NOT genisoimage or mkisofs-specific.

Rather, this is specific to the edgy6.10 debian+ubuntu
   patched version of mkisofs for some reason there.

--enyc <email address hidden>

enyc (enyc) wrote :

This bug ought to be closed now, as it only affects known-buggy-release edgy6.10, which is not-too-long to be unsupported anyway. However, I cannot see howto close the bug ;-) [maybe I cannot do that anyway]. Please close the bug, whomever can do this unless there is any problem with this ;-). Thanks, enyc.

Schily (schilling-fokus) wrote :

Trying to close the bug as Enyc explained that the bug no longer exists

Changed in cdrkit:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers