wodim reports "Errno: 5 ..." and cdrw keeps spinning

Bug #645050 reported by mkluwe on 2010-09-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cdrkit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wodim

I'm using wodim 1.1.10 from Ubuntu 10.04.1 LTS.

Wodim fails to burn a CD for me, output attached. Given some minimal context, the output is

Sending CUE sheet...
SAO startsec: -12508
Writing lead-in...
Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
CDB: 2A 00 FF FF FE 40 00 01 2A 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 72 0B 00 00 00 00 00 0E 09 0C 00 34 00 03 00 00
Sense Key: 0x0 No Additional Sense, Segment 11
Sense Code: 0x00 Qual 0x03 (setmark detected) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 148.840s timeout 200s
write CD-Text data: error after 1157760 bytes
wodim: Could not write Lead-in.
Errno: 5 (Input/output error), prevent/allow medium removal scsi sendcmd: fatal error

I attached the full output.

This occurs when running with -dummy and without. As a further mishap, the cd drive keeps spinning and I cannot eject the media (I tried eject in nautilus, the eject (1) command and the button on the physical drive). The only working option is a reboot.

Strange enough, burning the image to a cdrw media works as expected.

Solely running my private hardware on linux since 1996 its quite funny to see that cd burning keeps to be the only unreliable thing (for me) in all these years...

In my desperation (and because this problem occured when I _really_ needed this burned cd) I installed nero from http://www.nero.com/enu/linux4.html, which did the job. At least I'm sure now that the device (a Samsung SH-S223C) basically works.

mkluwe (mkluwe) wrote :
Schily (schilling-fokus) wrote :

I recommend to try recent original software (cdrtools-3.00).

Wodim is known to have many bugs and it is unmaintained.

If cdrecord fails also, then you are a victim of hald.

mkluwe (mkluwe) wrote :

I knew this would be the answer if I had asked you...

But thank you for answering here. In fact, I installed cdrecord from https://launchpad.net/~brandonsnider/+archive/cdrtools to try it.

Running

cdrecord -audio -dao -pad *.wav

on some files worked without error but: The burned CD does not work in any of my drives. Trying to mount it via nautilus results in the message that the disc does not contain audio data. hald does not run on my system.

mkluwe (mkluwe) wrote :

Small addendum:

Burning with -tao worked.

Currently, I've run out cdr media, so I have to suspend further experiments for the moment.

Schily (schilling-fokus) wrote :

So you are a victim of hald or a more recent replacement of hald.

It would be better to write in RAW mode in your case and writing in
RAW mode also prevents hald or similar to disturb the write process.

BTW: I did just put out a newer version of cdrtools that fixes a problem
that is seen when using k3b (which uses -sort) when one of the files
is > 4 GB:

ftp://ftp.berlios.de/pub/cdrecord/alpha/cdrtools-3.01a01.tar.bz2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers