cannot burn ISO images to CDs

Bug #590522 reported by Robert B on 2010-06-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cdrkit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wodim

For some reason, Lucid Lynx correctly brought up a dialog when I inserted a blank CD only the first time.

After that, it does not work. I'm using exactly the same brand of CD-Rs bought at the same time and I've tried several.

The first time, I cancelled out of the suggestion to burn the CD. Later, I right-clicked on a file and did "Write to Disc...". It brought up the dialog and chunked away for a while. But, then it got an "Unknown error has occurred" and popped out the CD.

After this, the above described behavior seems to occur -- when I insert a blank CD, a dialog does not appear and when I try to "Write to Disc...", it says "Please replace the disc with a supported CD or DVD."

I also tried using wodim on the command line and it says:

$ sudo wodim dev=/dev/cdrw -v -data trash/debian-504-powerpc-CD-1.iso
wodim: No write mode specified.
wodim: Assuming -tao mode.
wodim: Future versions of wodim may have different drive dependent defaults.
TOC Type: 1 = CD-ROM
scsidev: '/dev/cdrw'
devname: '/dev/cdrw'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.10
SCSI buffer size: 64512
wodim: Cannot do inquiry for CD/DVD-Recorder.
Errno: 5 (Input/output error), test unit ready scsi sendcmd: fatal error
CDB: 00 00 00 00 00 00
cmd finished after 0.000s timeout 40s

I tried sticking a CD with data on it and it correctly read it.

$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04
$ apt-cache policy wodim
wodim:
  Installed: 9:1.1.10-1ubuntu1
  Candidate: 9:1.1.10-1ubuntu1
  Version table:
 *** 9:1.1.10-1ubuntu1 0
        100 /var/lib/dpkg/status

Robert B (robertbub) wrote :

BTW, I just now tried burning the ISO image to the same CD-R on my Debian desktop using cdrecord and it works fine.

Robert B (robertbub) wrote :

FWIW, this may be related to bug 562092 . I.e., it may be a udev bug.

Schily (schilling-fokus) wrote :

On Friday noon, Marc Shuttleworth is in Berlin at the Linux Tag.

I believe it would be a good place to ask him why he is so stubborn
and prevents legal working software from appearing in Ubuntu.

RickDole (rdole1) wrote :

I've had "successful" burns of iso images that are corrupted. my current workaround is to boot to System Rescue (Gentoo derivative) and burn it there.

Robert B (robertbub) wrote :

I suspect it may have something to do with Ubuntu device drivers w.r.t. this particular laptop/DVD writer. (I have an Acer Aspire AS5750-5513 and it just lists the DVD writer as "DVD Super Multi DL", which seems pretty meaningless.)

I haven't tried burning under Windows 7, but I bet it would work.

My Debian desktop (a Dell) uses a standard EIDE ATAPI Sony CD/DVD burner.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers