DVD writing takes more than an hour with any DVD, set to any speed in both Brasero and Gnomebaker

Bug #227886 reported by Madhusudan.C.S on 2008-05-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cdrkit (Ubuntu)
Undecided
Unassigned

Bug Description

    It is a painful task to burn DVDs on Hardy. I first burnt a DVD at maximum speed in Brasero. The content size was around 4.1GiB. It took nearly 75 minutes to burn the DVD, but it was successful. Then I thought there must be some problems with Brasero and burnt another DVD with Gnomebaker, again the result it same. Its painful to see both of these applications use 1.14GiB(100%) of my RAM which I see when I run top when burning DVDs. This makes it impossible to use any other application. Even chatting in Pidgin becomes impossible. Still more paining is that Brasero uses 100% CPU most of the time.

     Hardy is an LTS and shouldn't have shipped with such a critical bug. I tried with both Moserbaer Pro DVD and a cheap DVD. Results are same. It is so sad that I have to install Winblow$ now on my machine to use Nero or I should install another distro just for burning DVDs. I dont want to go out of Ubuntu. Please help me.

Thanks in advance,

Madhusudan.C.S (madhusudancs) wrote :

Bah, Ubuntu is not slow as hell at least. I had reported this in the very first week of my usage with Hardy Heron and at last the package name has been changed now, when there is just 2 more months for the release of Intrepid. And to be very frank the bug is not alone in brasero but in every CD/DVD writing utility I tried like k3b and others. If the case mentioned above was for the DVD. CD writing is also a pain. It takes around 30 minutes to write a 700 MiB CD at 52x consuming full 100% CPU. So I think the bug is not in a specific package but a common backend used by all the burning tools.

  Things doesn't stop here. The problem also continues with the playing of CD/DVD. I mean when I put already burnt CD/DVD into the tray, the moment it is accessed the CPU usage raises to 100% hampering all other work happening on the system. By any chance if I try to play the video in the DVD/CD if there exists some such, I can see frame by frame of the video with a gap between each frame anywhere in the range of 1 or 2 seconds.

   I thought Ubuntu will fix this bug in 8.04.1 itself, but nothing has been done. Looks like people are least interested in the bug. I don't know why but it exists. I at least hope Intrepid will not have such hopeless problems.

Pedro Villavicencio (pedro) wrote :

not a brasero bug then, this needs to be reassigned.

Ian Weisser (ian-weisser) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Hi lanW,
         Yes this is still an issue on my machine. Its still not solved and
I get back to Windows whenever I want to burn a CD/DVD. Let me
try with the next release after the stable comes out.

--
Thanks and regards,
 Madhusudan.C.S

Blogs at: www.madhusudancs.info
Official Email ID: <email address hidden>

Ian Weisser (ian-weisser) wrote :

If this issue is resolved by an upgrade, please let us know.

If it's not resolve by an upgrade, please try the following and post the results here:
1) Open a terminal
2) Put a blank CD-R or DVD-R in the disc drive. If it mounts (it should) then unmount your disc drive with the command: umount /cdrom
3) Run a dummy burn (laser off) using the command: wodim -dummy speed=12 tsize=500000000 -v /dev/null
4) Copy and paste the terminal debug output into a text document, and attach the document below.
If you have any problems executing these commands, ask on irc at #ubuntu.
The purpose of this is to see what speed wodim chooses to burn at, and if it pays attention to the user-selected speed of 12x.
Thanks in advance.

Madhusudan.C.S (madhusudancs) wrote :

Hi lanW,
     Thanks for all the help and response. Will do it as soon as I
upgrade to Intrepid Ibex and will update you about it soon.

--
Thanks and regards,
 Madhusudan.C.S

Blogs at: www.madhusudancs.info
Official Email ID: <email address hidden>

Madhusudan.C.S (madhusudancs) wrote :

My woes continue to Intrepid.

The Debug Output is attached below.

This is the debug output. Please help me this time at least. Its really painful to boot to Winblow$ for burning CDs and DVDs

Changed in cdrkit:
status: Incomplete → New
David Johnston (davedcj) wrote :

I had the problem of DVD burn taking ages, too.
I used brasero.
my machine only has 256MB Ram, 1.6 ghz cpu
it took about 3.5 hrs to burn a 3.8gb data dvd, including just over 1hr generating the checksum.

Schily (schilling-fokus) wrote :

Brasero is not a burning program but rather a GUI only...

I cannot tell which burn program you actually used.
If it was wodim, then you need to know that wodim does not
offer working DVD support.

I recommend you to fetch a recent original cdrtools source from:

ftp://ftp.berlios.de/pub/cdrecord/alpha/

compile and install (the latter as root)

Then call cdrecord -v xxx.iso

If your system is not fast enough because you disabled DMA,
cdrecord will complain before starting to write.

This issue still affects 12.04.x.

I'm marking this bug as confirmed.

Changed in cdrkit (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments