Ubuntu

Upgrade cdrdao to 1.2.3

Reported by dungeon on 2009-12-11
174
This bug affects 37 people
Affects Status Importance Assigned to Milestone
cdrdao (Debian)
Fix Released
Unknown
cdrdao (Ubuntu)
High
Unassigned
Nominated for Lucid by RavanH

Bug Description

Binary package hint: cdrdao

 http://www.poolshark.org/?p=10
 http://sourceforge.net/projects/cdrdao/
 .....
 o By default, cdrdao tries to build with a native SCSI interface. Use
    "--with-libscg" to use bundled libscg library. (Denis Leroy)

 o Complete rewrite of native Linux SG driver for SG 3.0 using SG_IO
    ioctl. That should make it behave better with ConsoleKit based
    permissions environment. Cdrdao should now be compiled on Linux
    without cdrtools by using "--without-scglib". (Denis Leroy)

 So there is no need for scsilib anymore in linux;). It working good for me with native interface.

tags: added: upgrade
summary: - Needs packaging for cdrdao-1.2.3
+ Upgrade cdrdao to 1.2.3
RavanH (ravanhagen) wrote :

Trying the copy a CD with Brasero in Ubuntu 10.04, it fails due to the fact that cdrdao in the repository is "too old" (as Brasero reports on it's Plugins dialog) ...

Hope the upgrade is planned soon :)

RavanH (ravanhagen) wrote :

Not a duplicate but very much related bug report:

https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/529696

Changed in cdrdao (Ubuntu):
status: New → Confirmed

Like many people here I have to cope with an error launched by Brasero (latest version 10.04 on a 64 bit processor) when trying to copy an audio CD. I installed icedax as suggested which is supposed to replace cdda2wav but this has not sorted out the problem. I made an update today (18:44:12 CEST time) and it looks like this bug has not yet been solved. This is annoying for a LTS version. Thanks for trying to solve it.

Brian Kemp (brian-kemp) wrote :

TAO (track-at-once) burning is unaffected (because it's not handled by cdrDAO).

Uqbar (uqbar) wrote :

Whatever is affected, why using an old package?

Marc MAURICE (dooblem) wrote :

I can confirm that upgrading to 1.2.3 solve the Brasero problem.

cdir (carlos-insunza) wrote :

i can confirm this problem.

Changed in cdrdao (Ubuntu):
importance: Undecided → High
Changed in cdrdao (Debian):
status: Unknown → New
Thomas Holbach (thomasholbach) wrote :

I can confirm this problem.

Renzo Bagnati (renbag) wrote :

I've put test packages of cdrdao-1.2.3 and gcdmaster-1.2.3 in my ppa: https://launchpad.net/~renbag/+archive/ppa
They have been build without any of the debian patches used for the 1.2.2 version (many of them were already merged upstream).
See also comments in bug #529696.

Uqbar (uqbar) wrote :

Any chance to have this in mainstream?
Grazie mille.

Uqbar (uqbar) wrote :

Anyway, Renzo's packages solve my problems, as well as CD cover editor.

Changed in cdrdao (Debian):
status: New → Fix Committed
Changed in cdrdao (Debian):
status: Fix Committed → Fix Released
NoOp (glgxg) wrote :

Any chance that the Debian fix:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580873
Date: Sun, 11 Jul 2010 15:47:10 +0000
will be integrated in 10.04?

Colin Watson (cjwatson) wrote :

cdrdao (1:1.2.3-0.1ubuntu1) maverick; urgency=low

  * Update to latest version (LP: #495655)
  * debian/patches/14-arm-target.patch:
    - Add armv7l target
  * debian/patches/15-include-sys-stat-h.patch:
    - Add missing include to sys/stat.h

 -- Robert Ancell <email address hidden> Fri, 10 Sep 2010 11:49:24 +1000

Changed in cdrdao (Ubuntu):
status: Confirmed → Fix Released
Uqbar (uqbar) wrote :

My opinion, but I would say "fix released" when I can actually use it.
And as of now, it is not yet: it's still pool/main/c/cdrdao/cdrdao_1.2.2-18ubuntu4_amd64.deb

Siddharth Fadnis (sidfadnis) wrote :

any chance this will be release for 10.04 ?

Michael Hanke (micha-hanke) wrote :

can anybody please explain why this fix isn't released for a LTS-version (lucid) yet?

oddentity (tetlow-dan) wrote :

Just tried installing cdrdao 1.2.3 from source, but that didn't fix the brasero issue for me, although I am now able to use cdrdao to copy audio CDs from the command line.

Bit confused because others have reported this fix working - did you have to do anything else other than the default configure,make,install procedure? I used checkinstall to make a deb which installed it under /usr/local.

Herczeg Zsolt (zsolt94) wrote :

Why this confusing bug is still here?

The new version is not in the main repositories, and I can't use this function of Brasero.
I'm using lucid, which is an LTS system. It should work!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.