cdebootstrap failed in "Internal error: install" on Intrepid

Bug #259755 reported by Steven Shiau on 2008-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cdebootstrap (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cdebootstrap

When running cdebootstrap on Intrepid, I got the a error with "E: Internal error: install"
Here it is:
sudo cdebootstrap --debug --allow-unauthenticated -f build intrepid ./intrepid http://free.nchc.org.tw/ubuntu
D: Init suite intrepid
D: Using keyring /usr/share/keyrings/ubuntu-archive-keyring.gpg
P: Retrieving Release
D: Execute "wget -q -O /home/steven/live/ubuntu-clonezilla-live/1/intrepid/var/cache/bootstrap/_dists_._Release http://free.nchc.org.tw/ubuntu/dists/intrepid/Release"
D: Status: 0
P: Retrieving Release.gpg
D: Execute "wget -q -O /home/steven/live/ubuntu-clonezilla-live/1/intrepid/var/cache/bootstrap/_dists_._Release.gpg http://free.nchc.org.tw/ubuntu/dists/intrepid/Release.gpg"
D: Status: 0
P: Validating Release
D: Execute "gpgv --logger-fd 1 --status-fd 1 --keyring /usr/share/keyrings/ubuntu-archive-keyring.gpg /home/steven/live/ubuntu-clonezilla-live/1/intrepid/var/cache/bootstrap/_dists_._Release.gpg /home/steven/live/ubuntu-clonezilla-live/1/intrepid/var/cache/bootstrap/_dists_._Release"
I: Good signature from "Ubuntu Archive Automatic Signing Key <email address hidden>"
D: Status: 0
P: Parsing Release
...
D: call action: helper-install
D: Execute "cp /usr/share/cdebootstrap/cdebootstrap-helper-rc.d.deb /home/steven/live/ubuntu-clonezilla-live/1/intrepid/var/cache/bootstrap/cdebootstrap-helper-rc.d.deb"
D: Status: 0
P: Configuring helper cdebootstrap-helper-rc.d
D: Execute "dpkg -i /var/cache/bootstrap/cdebootstrap-helper-rc.d.deb" in chroot
O: dpkg: `update-rc.d' not found on PATH.
O: dpkg: 1 expected program(s) not found on PATH.
O: NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
D: Status: 512
E: Internal error: install

The verbose messages are attached.

Steven Shiau (stevenshiau) wrote :

A workaround is to put "sysv-rc" in the base package in /usr/share/cdebootstrap/generic-ubuntu/packages. However, there must be a better way to deal with this. Something must have changed from 17/Aug/2008. It was working before 17/Aug/2008.
Thanks.

Steven Shiau (stevenshiau) wrote :

Oops.. It should be "cdebootstrap --debug --allow-unauthenticated -f minimal intrepid ./intrepid http://free.nchc.org.tw/ubuntu" (-f minimal, _not_ -f build)was working before 17/Aug/2008, and failed on 20/Aug/2008, and today it's working now. Sorry. My bad.

lhl (lhl) wrote :

Just wanted to add a note, that I've encountered a similar problem running the following:

# cdebootstrap -a i386 -f minimal intrepid /mnt/intrepid http://archive.ubuntu.com/ubuntu/

... Lots of packages ...
P: Unpacking package dpkg
P: Configuring package dpkg
P: Configuring helper cdebootstrap-helper-rc.d
E: Internal error: install

This was done on a fresh Alestic Ubuntu Intrepid image (ami-1ad73373).

Running cdebootstrap w/ hardy instead of intrepid worked, so I'm guessing this is just a bug w/ Intrepid.

Steven Shiau (stevenshiau) wrote :

After Feb/19/2009, I have similar problem on Ubuntu Jaunty again. It was working on Feb/12/2009 when I tried.
The cdebootstrap is 0.5.4ubuntu1.
I have to workaround this by putting "sysv-rc" in the base package in /usr/share/cdebootstrap/generic-ubuntu/packages.
BTW, I have to add:
------------------
Suite: jaunty
Config: generic-ubuntu
Keyring: ubuntu-archive-keyring.gpg
------------------
in /usr/share/cdebootstrap/suites before I ran the command:
cdebootstrap --debug --allow-unauthenticated -f minimal jaunty ./jaunty http://free.nchc.org.tw/ubuntu

rew (r-e-wolff) wrote :

Nothing has changed... Now on natty, trying to bootstrap lucid (*):

P: Unpacking package python-minimal
P: Unpacking package tar
E: Internal error: install

(*) Natty fails much quicker, will report separately.

Bhavani Shankar (bhavi) wrote :

Hi,

Does this problem persist in the latest version in the archives?

Regards
Bhavi

Changed in cdebootstrap (Ubuntu):
status: New → Incomplete
Bhavani Shankar (bhavi) wrote :

Also, Closing this bug as Intrepid is no longer supported in the latest version in the archives.

If anyone would experience same problem as a regression against the latest version in the archives, Request them to raise a new bug, which can be worked upon.

Regards
Bhavi

Changed in cdebootstrap (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers