Alt + Tab freezes progress bar

Bug #47643 reported by Pete Savage on 2006-05-31
12
Affects Status Importance Assigned to Milestone
cdebconf (Ubuntu)
Medium
Unassigned

Bug Description

Press alt tab during any progress bar whilst installing, installation totally freezes. Keyboard is still responding as Ctrl+Alt+F4 gets to console, and F2 enables a shell to be created. This was tested on i386.

Pete Savage (petesavage) on 2006-05-31
description: updated
Colin Watson (cjwatson) wrote :

Reproduced in VMware. Probably a bug in either cdebconf or the underlying newt library.

Changed in debian-installer:
status: Unconfirmed → Confirmed
Adam Niedling (krychek) wrote :

Which version of Ubuntu were you using back then? Is this still an issue for you?

Changed in cdebconf:
status: Confirmed → Invalid
Colin Watson (cjwatson) wrote :

This bug should not have been closed. Asking for more information should happen by setting the bug to Incomplete (although I am the relevant developer and do not need more information, so don't do that!), NOT Invalid.

Changed in cdebconf:
status: Invalid → Triaged
Alon Swartz (alonswartz) wrote :

We came across a similar issue, might be the same.

Our installer (di-live) uses debconf to interact with the user, which in turn uses the available debconf frontend, which happens to be whiptail (ie. newt).

When the key combination ALT + *anykey* (not only tab) is pressed, whiptail will exit with code 255.
This is easily reproducable at the prompt:

    $ whiptail --yesno test 20 50; echo $?
    press ALT + *anykey*

BTW - the same issue is present in dialog, so the problem is probably not in newt itself...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers