automatic keyboard layout detection loops and messes up screen

Bug #172807 reported by Martin Pitt on 2007-11-29
2
Affects Status Importance Assigned to Milestone
cdebconf-keystep (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: debian-installer

Hardy Alpha 1 alternate amd64 CD: Select automatic keyboard layout detection, press y, press w, then the screen gets corrupt. Switching VTs back and forth restores it, but you again land on the 'detect layout automatically?' question. You have to say no and select it manually to proceed.

Colin Watson (cjwatson) on 2007-11-29
Changed in debian-installer:
assignee: nobody → kamion
status: New → In Progress
Colin Watson (cjwatson) wrote :

cdebconf-keystep (0.7) hardy; urgency=low

  * Port fixes from cdebconf-entropy (LP: #172807):
    - Switch the handler symbol to the "cdebconf_" namespace.
    - Use the proper namespace to access newt frontend API.
    - Remove the usage of dlsym() and dlopen() now that frontend symbols are
      loaded globally.
    - Bump Depends on cdebconf accordingly.
  * Change Maintainer to <email address hidden>.
  * Add Vcs-Bzr field.
  * Fix Section.
  * Fix configure options so that it doesn't always think we're
    cross-compiling.
  * Remove unused debhelper command cruft.

 -- Colin Watson <email address hidden> Thu, 29 Nov 2007 16:32:50 +0000

Changed in cdebconf-keystep:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

According to http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/current/images/udeb.list the installer has built against 0.8, but the bug still happens on the current images.

Changed in cdebconf-keystep:
status: Fix Released → Confirmed
Colin Watson (cjwatson) wrote :

I don't seem to be able to reproduce this on i386 now. I wonder if this is a different bug.

Could you attach /var/log/syslog from after the failure, please?

Colin Watson (cjwatson) wrote :

(Or a screenshot would probably do if extracting syslog is too hard.)

Changed in cdebconf-keystep:
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

I still get the looping: I press 'y', 'w', and am back to the 'do you want to detect...' question. /cdrom/pool/main/c/cdebconf-keystep/* has version 0.8.

On my first boot I did not get screen corruption, the question dialog was clean. On the second boot I did get the garbled screen again (see screenshot in comment 2), so this looks like a race condition.

I attach /var/log/syslog.

Colin Watson (cjwatson) wrote :

I'm not quite sure what was going on back in late November / early December, but I tried it with the final http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-amd64/current/images/netboot/mini.iso and it worked fine, so I think this has gone away now. The syslog Martin posted ("undefined symbol: newt_create_window") is definitely a sign of something still using cdebconf-newt-detect-keys 0.6 for some reason.

Changed in cdebconf-keystep:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers