oz776 smart card reader no longer works

Bug #163072 reported by Märt Suga on 2007-11-16
2
Affects Status Importance Assigned to Milestone
OpenSC
Invalid
Unknown
ccid (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, I found out that Dell Latitude D620 integrated oz776 smart card reader no longer works in Gutsy but it still works in Feisty (tried it with vmware on the same machine). And after making it work under vmware's Feisty, it start working under host until i write "sudo /etc/init.d/pcscd restart". After that it stops working again. The problem should be with opensc, pcscd or libpcsclite (I am not sure).
Here are some "pkcs15-tool --list-certificates" outputs:

Under Gutsy:
[pkcs15-tool] reader-pcsc.c:534:pcsc_connect: SCardConnect failed: Card is unresponsive.
[pkcs15-tool] card.c:228:sc_connect_card: returning with: Unresponsive card (correctly inserted?)
Failed to connect to card: Unresponsive card (correctly inserted?)

Under Feisty:
X.509 Certificate [Isikutuvastus]
        Flags : 0
        Authority: no
        Path : 3f00eeeeaace
        ID : 01

X.509 Certificate [Allkirjastamine]
        Flags : 0
        Authority: no
        Path : 3f00eeeeddce
        ID : 02

Same machine, same configuration.

I have also tried other USB smart card readers with the same machine and they all work without any problems under Gutsy.

Märt Suga (mart-suga) wrote :
Märt Suga (mart-suga) wrote :
Märt Suga (mart-suga) wrote :

I managed to find a workaround:
Downgrading the package libopensc2 from version 0.11.3 (Gutsy default version) to 0.11.1 (Feisty default version) will fix the problem so I assume that the problem is with libopensc2 package.

See bug here: https://www.opensc-project.org/opensc/ticket/172

Changed in opensc:
status: Unknown → New
Märt Suga (mart-suga) wrote :

Looks like the problem was with libccid package. Now it is fixed in ccid source Rev 2849. http://lists.alioth.debian.org/pipermail/pcsclite-cvs-commit/2008-March/003024.html

Changed in opensc:
status: New → Invalid
Märt Suga (mart-suga) wrote :

Here is a fixed package of libccid for i386 (built from newest svn commit).

Andres Järv (andresjarv) wrote :

Also ccid could be bumped to current version 1.3.5 from upstream since it introduces quite many enhancements.

Changed in ccid:
status: Fix Committed → Confirmed
Andres Järv (andresjarv) wrote :

The fixed version is in Ubuntu Intrepid.

Changed in ccid:
status: Confirmed → Fix Released
Martin Paljak (martinpaljak) wrote :

The reader is bogus and generally not supported. http://pcsclite.alioth.debian.org/unsupported.html#0x0B970x7762

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.