Xubuntu 18.10 catfish crashed searching for // , showing hidden files and searching within files

Bug #1772437 reported by Willem Hobers on 2018-05-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
catfish (Ubuntu)
Undecided
Unassigned

Bug Description

Testing Xubuntu 18.10. I had catfish search for '//'. Hidden files showing, and also looking inside files, searching from filesystem /. My mouse became slow and later catfish had disappeared. I started up ubuntu-bug catfish to report this.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: catfish 1.4.4-1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.10-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon May 21 17:24:43 2018
PackageArchitecture: all
SourcePackage: catfish
UpgradeStatus: No upgrade log present (probably fresh install)

I have been able to reproduce this several times now.

Willem Hobers (whobers) wrote :
Willem Hobers (whobers) wrote :

I should add: the crash happens when searching from filesystem /

description: updated

It looks like catfish should not search within files in /dev.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in catfish (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.4.7-1

---------------
catfish (1.4.7-1) unstable; urgency=medium

  * New upstream release.
    - Fixed context menu activation (LP: #1788058)
    - Fixed crash with searching inside /dev (LP: #1772437)
    - Fixed window button placement in LXDE (LP: #1512031)
    - Fixed occasional crash at startup (LP: #1753163)
  * d/control:
    - Bump Standards-Version to 4.3.0, no changes needed.
  * d/copyright:
    - Bump source copyright years to 2019

 -- Sean Davis <email address hidden> Mon, 11 Feb 2019 18:44:12 -0500

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers