catfish seems to regard folder names with '.' in the middle of a string as hidden folders

Bug #1731608 reported by rye on 2017-11-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Catfish
Fix Released
Medium
catfish (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

First noticed with an insync google drive folder automatically labelled as <email address hidden>. Catfish will not search this folder unless "show hidden files" is selected.

To test I created another folder "he.llo", and catfish's behaviour was the same.

ubuntu 16.04.3
1.4.2-0ubuntu1 (via catfish maintainers ppa)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: catfish 1.4.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-38.42~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-38-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Nov 11 07:54:48 2017
InstallationDate: Installed on 2017-10-26 (15 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: catfish
UpgradeStatus: No upgrade log present (probably fresh install)

rye (ry.) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in catfish (Ubuntu):
status: New → Confirmed
Kev Bowring (flocculant) on 2018-01-28
tags: added: bionic
David Pearson (akxwi-dave) wrote :

I am unable to reproduce.. on today's ISO catfish happily finds the document test.hidden.txt in folder dave.p

From https://bugs.launchpad.net/catfish-search/+bug/1731608

First noticed with an insync google drive folder automatically labelled as <email address hidden>. Catfish will not search this folder unless "show hidden files" is selected.

To test I created another folder "he.llo", and catfish's behaviour was the same.

ubuntu 16.04.3
1.4.2-0ubuntu1 (via catfish maintainers ppa)

Sean Davis (bluesabre) on 2018-06-29
Changed in catfish-search:
importance: Undecided → Unknown
status: New → Unknown
Changed in catfish-search:
importance: Unknown → Medium
status: Unknown → Confirmed
In , Gitbot (gitbot) wrote :

Sean Davis referenced this bugreport in commit 8b3fe1149562195b33f73825db21e231caa5aea7

Improve hidden file logic (bug #14497)

https://git.xfce.org/apps/catfish/commit?id=8b3fe1149562195b33f73825db21e231caa5aea7

Fixed in the above commit.

Changed in catfish-search:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.4.6-0ubuntu1

---------------
catfish (1.4.6-0ubuntu1) cosmic; urgency=medium

  * New upstream release, packaging from unreleased Debian VCS.
    - Fixed PermissionError in settings handler (LP: #1567787)
    - Fixed UnicodeDecodeError in search (LP: #1646714)
    - Fixed detection of hidden files (LP: #1731608)
    - Fixed display of icons in Buuf themes. Closes: #816126
  * d/control:
    - Updated homepage to docs.xfce.org
  * d/upstream/signing-key.asc:
    - Dropped, Xfce release manager does not have key signing
  * d/watch:
    - Removed pgpsigurlmangle
    - Updated release pattern to archive.xfce.org

 -- Sean Davis <email address hidden> Fri, 20 Jul 2018 00:57:29 -0400

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
Łukasz Zemczak (sil2100) wrote :

Since this bug is mentioned in the changelog of the new catfish SRU to bionic, please fill in the required SRU information into the description.

An upload of catfish to bionic-proposed has been rejected from the upload queue for the following reason: "bugs linked in the changelog do not have SRU templates and it's unclear they should; https://bugs.launchpad.net/ubuntu/bionic/+source/catfish/+bug/1646714/comments/6".

Steve Langasek (vorlon) wrote :

There is a catfish upload in the bionic-proposed queue referencing this bug but this is not on track for inclusion in bionic-proposed. This bug lacks an SRU bug template. Please either update all bugs referenced in the changelog to include SRU templates (including test cases), or reupload dropping the bug references to the individual bugfixes and include only the reference to the microrelease exception request (https://bugs.launchpad.net/ubuntu/+source/catfish/+bug/1782735).

In the meantime I am rejecting this package from the queue. If you choose to update these bugs with test cases rather than dropping the bug references, then you can ping a member of the SRU team directly to recover this SRU from the rejected queue for reconsideration, or you can just reupload to the queue yourself.

Changed in catfish (Ubuntu Bionic):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.