Catfish calculates end date in custom range incorrectly

Bug #1514018 reported by Jack Fromm on 2015-11-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Catfish
Undecided
Sean Davis
One Hundred Papercuts
Medium
Unassigned
catfish (Ubuntu)
Medium
Unassigned

Bug Description

When setting a custom modified date range it seems that you have to choose a date at least one day later than the actual end date you intended in order for files time-stamped on the intended date to show up in the results. Not only that, it appears that there is a discrepancy between local time and UTC when comparing displayed file dates in Thunar and Catfish. In the attached screenshot, the file highlighted in Thunar at the top of the image shows a date of October 01. To get that file to show up in Catfish with a custom date range, you have to select October 03 as the end date and then Catfish shows the file date as October 02 (which it would be in UTC).

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: catfish 1.3.3-0ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Nov 6 21:15:35 2015
InstallationDate: Installed on 2015-10-03 (34 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151003)
PackageArchitecture: all
SourcePackage: catfish
UpgradeStatus: No upgrade log present (probably fresh install)

Jack Fromm (jjfrv8) wrote :
Jack Fromm (jjfrv8) on 2015-11-07
tags: added: package-qa-testing xenial xubuntu-exp
removed: wily
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in catfish (Ubuntu):
status: New → Confirmed
Changed in catfish (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
Changed in catfish-search:
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Medium
Sean Davis (bluesabre) wrote :

Thanks for the bug report. This fix has been applied with this commit: https://bazaar.launchpad.net/~catfish-search/catfish-search/trunk/revision/459

This fix will be included in the next release.

Changed in catfish-search:
status: Confirmed → Fix Committed
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre) on 2016-02-25
Changed in catfish-search:
milestone: none → 1.4.1
Sean Davis (bluesabre) on 2016-02-25
Changed in catfish-search:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.4.1-0ubuntu1

---------------
catfish (1.4.1-0ubuntu1) xenial; urgency=medium

  * New upstream stable (bugfix) release.
    - Fix: Deleting from search results (LP: #1508918)
    - Fix: Catfish calculates end date in custom range
      incorrectly (LP: #1514018)
    - Fix: Catfish launch script with different
      Python installations (LP: #1445739)
    - Fix: Need to click in empty space for right click
      options to work (LP: #1547807)
  * debian/control:
    - Add build dependency on python-gi-dev
  * debian/rules:
    - Build with pybuild
  * debian/patches:
    - Dropped, included upstream.

 -- Sean Davis <email address hidden> Thu, 25 Feb 2016 22:12:22 -0500

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
flocculant (flocculant) on 2016-03-27
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints