Version 1.3.3 under Lubuntu 15.10 does not respect window button placement

Bug #1512031 reported by Scott Cowles Jacobs on 2015-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Catfish
Fix Released
Medium
catfish (Ubuntu)
Undecided
Unassigned

Bug Description

I prefer to have the window close/minimize/maximize controls on the left, and have placed them there with Customize Look and Feel.
However, catfish places its own window controls on the right (with a different Theme, as well).

I checked the Preferences, in case (as with Chromium) there were an option to "Use System Title Bar and Borders", but found none.

-------

[This seems to be the same bug as with eog (Gnome Image Viewer),
and I have filed a bug report for that as well (Bug #1511616)

In case it is useful, I here quote a comment for that bug, that states:
"That has to do with the use of CSD/GtkHeaderBar that doesn't work great out of gnome-shell"

On that bug report page, it states that it apparently is an "upstream bug" and I ought to report it upstream as well.

If that is so here as well (as seems likely), tell me, and I will do the same for catfish as I will do for eog.]

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: catfish 1.3.3-0ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic i686
ApportVersion: 2.19.1-0ubuntu4
Architecture: i386
CurrentDesktop: LXDE
Date: Sat Oct 31 19:27:27 2015
PackageArchitecture: all
SourcePackage: catfish
UpgradeStatus: No upgrade log present (probably fresh install)

Sean Davis (bluesabre) wrote :

As indicated in the description, this bug is outside of Catfish's control. If you want to use standard window controls, you can use the "use-headerbar" setting in ~/.config/catfish/catfish.rc

use-headerbar=false

Xfce gets around this issue completely by configuring the decoration layout, see http://git.xfce.org/xfce/xfce4-settings/commit/?id=6a812b203769fc440267a0486f2775d2405bdc3d . It would probably benefit LXDE/Lubuntu to handle this as well in the window manager settings.

@Sean Davis (bluesabre)
Thank you for your reply - I didn't see it until today.

I did not find the config file, but when I did a search, I came across one of your replies
to another bug that stated "Catfish creates this file when you change the settings in the application.", so I clicked on "Hidden Files" and on "Sidebar", and the file was created.
I changed the option as you said, and after two tries (must have goofed something up...) it worked.

Thank you again.

I am going to try and see if the same technique works for eog, which does exactly the same thing with the window controls...

[Might I suggest that it become one of the Settings and/or a command-line option?]

From https://bugs.launchpad.net/catfish-search/+bug/1512031

I prefer to have the window close/minimize/maximize controls on the left, and have placed them there with Customize Look and Feel.
However, catfish places its own window controls on the right (with a different Theme, as well).

I checked the Preferences, in case (as with Chromium) there were an option to "Use System Title Bar and Borders", but found none.

-------

[This seems to be the same bug as with eog (Gnome Image Viewer),
and I have filed a bug report for that as well (Bug #1511616)

In case it is useful, I here quote a comment for that bug, that states:
"That has to do with the use of CSD/GtkHeaderBar that doesn't work great out of gnome-shell"

On that bug report page, it states that it apparently is an "upstream bug" and I ought to report it upstream as well.

If that is so here as well (as seems likely), tell me, and I will do the same for catfish as I will do for eog.]

Sean Davis (bluesabre) on 2018-06-29
Changed in catfish-search:
importance: Undecided → Unknown
status: New → Unknown
Changed in catfish-search:
importance: Unknown → Medium
status: Unknown → Confirmed
In , Gitbot (gitbot) wrote :

Sean Davis referenced this bugreport in commit 75dce159cb602d9d2c6f23d937a2e10e8080e613

Add DE detection for headerbar usage: use headerbar for Budgie, GNOME, and Pantheon; titlebar for all others (bug #14486)

https://git.xfce.org/apps/catfish/commit?id=75dce159cb602d9d2c6f23d937a2e10e8080e613

This issue should be resolved with the above commit. LXDE will now use the titlebar layout by default.

Changed in catfish-search:
status: Confirmed → Fix Released

"LXDE will now use the titlebar layout by default."

Well, time marches on, and Lubuntu now has LXQt.

Should I assume that the comment also applies to LXQt as well?

Sean Davis (bluesabre) wrote :

Yes, specifically: only Budgie, GNOME, and Pantheon will use the headerbar layout by default.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.4.7-1

---------------
catfish (1.4.7-1) unstable; urgency=medium

  * New upstream release.
    - Fixed context menu activation (LP: #1788058)
    - Fixed crash with searching inside /dev (LP: #1772437)
    - Fixed window button placement in LXDE (LP: #1512031)
    - Fixed occasional crash at startup (LP: #1753163)
  * d/control:
    - Bump Standards-Version to 4.3.0, no changes needed.
  * d/copyright:
    - Bump source copyright years to 2019

 -- Sean Davis <email address hidden> Mon, 11 Feb 2019 18:44:12 -0500

Changed in catfish (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.