Deleting from search results

Bug #1508918 reported by Kev Bowring on 2015-10-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Catfish
Fix Released
Medium
Unassigned
catfish (Ubuntu)
Medium
Unassigned

Bug Description

When searching for files with Catfish, possibility exists that the search is for files to delete.

While it is possible to delete files from within the results, it can only be done singly, not able to select multiple files either with keyboard nor mousepad.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: catfish 1.3.3-0ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Oct 22 13:52:16 2015
InstallationDate: Installed on 2015-10-01 (20 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151001)
PackageArchitecture: all
SourcePackage: catfish
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1508918

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in catfish (Ubuntu):
status: New → Confirmed
Istimsak (saqman2060) wrote :

The same issue affecte me as well. Can only delete file one at a time not as a group.

Kev Bowring (flocculant) wrote :

It will - that's how it works. This is a 'usability' bug. Possibly end up marked Wishlist.

tags: added: usability
Sean Davis (bluesabre) wrote :

Thanks for the bug report. I think this once worked with a selection of multiple files, so this is either a regression or incomplete feature. I'll work on adding this in the next release.

Changed in catfish-search:
status: New → Confirmed
importance: Undecided → Medium
Changed in catfish (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
Sean Davis (bluesabre) wrote :

This should now be resolved with the following commit.

https://bazaar.launchpad.net/~catfish-search/catfish-search/trunk/revision/435

Changed in catfish-search:
status: Confirmed → Fix Committed
Sean Davis (bluesabre) on 2016-01-31
Changed in catfish-search:
milestone: none → 1.3.4
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.4.1-0ubuntu1

---------------
catfish (1.4.1-0ubuntu1) xenial; urgency=medium

  * New upstream stable (bugfix) release.
    - Fix: Deleting from search results (LP: #1508918)
    - Fix: Catfish calculates end date in custom range
      incorrectly (LP: #1514018)
    - Fix: Catfish launch script with different
      Python installations (LP: #1445739)
    - Fix: Need to click in empty space for right click
      options to work (LP: #1547807)
  * debian/control:
    - Add build dependency on python-gi-dev
  * debian/rules:
    - Build with pybuild
  * debian/patches:
    - Dropped, included upstream.

 -- Sean Davis <email address hidden> Thu, 25 Feb 2016 22:12:22 -0500

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
Jack Fromm (jjfrv8) wrote :

Confirmed fix in version 1.4.1 on Xenial.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints