live install CD reports I/O error dev fd0

Bug #97306 reported by Michael Kofler on 2007-03-28
78
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned

Bug Description

hardware: Asus P5B Deluxe, Intel Dual Core 2, NO floppy drive!
software: Ubuntu 7.04 Beta DVD 64 bit

when trying to start the desktop system (live installer) from the dvd, the kernel reports

end_request: I/O error, device fd0, sector 0
Buffer I/O error on device fd0, logical block 0

over and over again until I reset the machine with Strg+Alt+Del

in console 6, one udevd-event is reported

run_program: '/sbin/modprobe' abnormal exit

--------

when I do an text mode installation from the very same DVD, this problem does not appear! the installation proceeds, the installed system works;

for reasons beyond my understanding, even bug

https://launchpad.net/bugs/81596

does not appear; is there a difference between the text mode installer of the DVD and the text mode installer of the alternate CD?

description: updated
Ridley (quasit33) wrote :

I can confirm this behavior.

Hardware is the same as above, but I have a floppy drive.

I used Ubuntu 7.04 Beta Desktop CD 32 bit.

When booting from cd it trys to do something with the floppy in a loop. After a while it stops and reports the same error as above.

It may have to do something with initramfs, because it is displayed on screen and you can type in some commands... But I don't really know ...

xsist10 (xsist10) wrote :

Confirmed with:

ubuntu-7.04-beta-desktop-amd64.iso
ubuntu-7.04-beta-desktop-i386.iso

I don't have a floppy drive and it is disabled in the BIOS.
Attempted both with and without graphic installer

Alexandre (frevandonanet) wrote :

I had the same problem trying to install from CD. I don't have any floppy and I'm using a Toshiba Satellite 2435-S255.

Nate Boom (nateboom) wrote :

I can confirm this error with the final release cd, ubuntu-7.04-desktop.iso. I have a Compaq Evo N600c with no floppy drive and disabled in the bios

Nate Boom (nateboom) wrote :

I must clarify my last comment: I believed that my floppy was disabled in the bios, but when I went to double-check, there wasn't even an option. So my floppy must be permanently enabled on this laptop. Regardless, the kernel is still looking for a floppy drive that does not exist

bob (bob7) wrote :

I'm using a Dell Inspiron 4000 and get the exact same error.
I'm in the same boat as Nate, no option in bios to disable the FDC.

I'm also having problems eith corrupted display when gnome starts.
I can add screen=1280x1024 to the boot options to fix it.

Is there a boot option to disable the FDC?

Naseer Ahmed (naseer) wrote :

I am having the same problem using Feisty Final release on a HP nx5000 laptop.
I do not have a floppy drive.

Naseer Ahmed (naseer) wrote :

Sorry for the double post, but I felt I should mention that I have a normal IDE drive

bob (bob7) wrote :

Ok. I got it working with the desktop alternate version. The CD boot still paused for 3-5 minutes while it tried to find a FDC, but after the text-based install it no longer does it. I suspect that the same will be true for the normal desktop install, I wasn't able to use that one because of an issue with my display.
As far as the display goes, the screen= command was for a knoppix live cd and not Ubuntu. To get the display working I switched to a text terminal ctrl-alt-F1 and ran 'sudo dpkg-reconfigure xserver-xorg' and manually setup my monitor.

So, try installing. The problem will likely go away after installed.

Ben Crowe (ben-crowe) wrote :

I am having the same problem with the final release, at least on a Dell Latitude C610. I also have no floppy drive and get the I/O error - fd0.
I am experiencing the issue with Kubuntu 7.04. Thought it originally to be a bad burn from ISO, but not the case...

I had the same problem with mi little sisters Dell Latitude C600...
There's no floppy drive either, but it's possible to add a floppy drive instead of the cd drive...

I was using the ubuntu 7.04 official release...

But when I waited a few minutes it started to move pass the error and continued the livecd... But I can tell you if the rest of the livecd works :) it doesn't seem have enough ram to run Ubuntu from livecd, perhaps I'll try with Xubuntu...

Ben Crowe (ben-crowe) wrote :

"I am having the same problem with the final release, at least on a Dell Latitude C610. I also have no floppy drive and get the I/O error - fd0.
I am experiencing the issue with Kubuntu 7.04. Thought it originally to be a bad burn from ISO, but not the case..."
**UPDATE***
I finally got Feisty installed on a Dell Latitude C610. After I got the fd0 errors, I noticed that I also got an sr0 error. (A quick Google search came up with optical media errors.) I knew the CD was good, so I swapped out the DVD/CDRW drive with a basic CD-Rom drive and the install went perfectly. Apparently there's an issue getting the combo drive to be recognized during install. All works well now!

ThisPlay (thisplay) wrote :

Hi,

I had the same bug and have solved it.
This happened because I burnt a CD-ROM ISO over a DVD media.
So... if I'm right and you've done the same thing yourself, try re-burning but this time on a CD-ROM media.

Have a great day,
TP!

beeryf (fred-beery) wrote :

i had the same problem and found that my bios was listing that i had a floppy. i dont have a floppy. took it out of the bios and was able to boot.

Nevell (nevell) wrote :

I don't install Ubuntu 7.04 DVD too... I have the same problem (end_request: I/O error, device fd0, sector 0, Buffer I/O error on device fd0, logical block 0) how to fix it? Anybody fix this problem? ASUS Barebone machine, no floppy drive, no options about floppy in the BIOS... This very actually problem, and i must fix it quickly...

P.S. Maybe install/start command promt have any options about disable floppy check or misc?

Darik Horn (dajhorn) wrote :

This also happens while trying to install Ubuntu Feisty on a stock Dell PowerEdge 2650.

Ludwik Trammer (ludwik) wrote :

I just want to report that this bug remains in Gutsy Tribe 3. It affects both my desktop and one of the laptops. Its an important issue, because system looks like crashed - for 60 seconds (really? feels more like several minutes...) the screen is completely blank and you don't hear the cd working. User has no idea what's going on (on the beginning I was just restarting, because I was sure that the boot process just froze). Only after that period user sees two "Buffer I/O error on device fd0, logical block 0" errors, and system continue to boot.

Nanley Chery (nanoman) wrote :

Thanks for the follow up, does this bug still remain in tribe 5?

Changed in casper:
status: New → Incomplete
Nanley Chery (nanoman) on 2007-09-02
Changed in casper:
status: Incomplete → Confirmed
Ludwik Trammer (ludwik) wrote :

Yes, I just checked and the problem remains in tribe5. Nothing changed.

Here's something you may want to try. I didn't think it was a real kernel parameter, but adding "nofloppy" to the boot parameters allowed me to boot without even seeing the error. Try it out, I'd like to see if it works for other people.

Henrik Width (henrikwidth) wrote :

nofloppy did not work for me, I can confirm this bug on daily build 13.10.2007. I worked around this by disabling the floppy in bios

John Bruno (jbalaska) wrote :

I encountered this problem when trying to install feisty on a HP Pavilion 540n desktop, after basically pulling my hair out, swearing and throwing things for a while I found a fix:

Add "all_generic_ide" (without the quotes) to the end of the boot string. (F6 at the install menu)

Problem solved.

Philippe Coval (rzr) wrote :

Hi,
I was stuck on this error while booting the livecd (copied on a usb memory),
Just checked with hardy-alpha-3 xubuntu flavor and it seems to work flawlessly...
Hope this helps, regards.
--
http://rzr.online.fr/q/syslinux

episteme1972 (episteme1972) wrote :

Same "Buffer I/O error on device fd0" problem on my Dell Latitude C600 with Xubuntu 7.10.

It makes it past the error but the bottom 20% of the desktop is white (no image or anything happening there). I can install but it crashes when it's checking the file system before erasing the HD. I have to force the computer off.

The *only" ubuntu OS that I've been able to boot from CD and install in ubuntu 6.06. All other ubuntus give some problem or other.

I don't want to sound too demanding, but shouldn't the developers have a solution to this by now?

D

Victor Mendonça (victorbrca) wrote :

I installed Xubuntu Gutsy on a really (really) old laptop and had the same problem when booting into the live CD. However, it actually did boot and I was able to install it.

Vic.

ChristofferS (ubuntu-curo) wrote :

I just got the same error with the Hardy beta live CD.

glentium (glentium) wrote :

I got the same error in Hardy RC on a desktop w/o FDD but no error on a laptop (also without FDD)

Ala (ala-luszczak) wrote :

I have Core 2 Duo, P35 mainboard, SATA HDD & SATA DVD.
I can confirm this bug on Ubuntu 8.10 (hardy).

I tried to boot from CD. My PC acted as described above, but after many lines with the same error, it managed to boot. So I installed Ubuntu 8.10 from LiveCD. But after installation I couldn't boot from HDD. Orange box was just moving from side to side and then BusyBox shell appeared.

I found 2 ways out:
1) Unplug my DVD (not good, I want to use my DVD)
2) Disable floppy in BIOS and also *disable floppy drive controller*. Those two switches are in totally different places in my BIOS menu. So if you already disabled floppy and it didn't helped, try searching all menus in your BIOS and find the other one.
In my AMI BIOS (on Foxconn P35-A mainboard):
Standard BIOS Features -> Floppy A -> Disable
Advanced BIOS Features -> SuperIO Configuration -> OnBoard Floppy Controller -> Disable
Disabling both does the trick for me.

Laurent Bigonville (bigon) wrote :

I have the same error on a compaq evo w8000

Giga (gislersoft-hotmail) wrote :

Hi,

I have the same error on a "Dell Latitude CPx H600GT" with the "Ubuntu 8.04 Desktop i386 CD", i haven't plug the floppy, so i decided to plug it ... and the installation continues normally and i didn't see the error again.

I have an external floopy drive that comes with the Dell latitude and plugs via Parallel port. I think is very frustraiting don't see what the installation process is doing, so you don't know if everything is ok or not, i will try the Alternate CD for future installations.

lony (4gotten-soul) wrote :

Hi,

I m expecting the same problem on Abit IP35, 8.04 (KDE4 mix) where I have no FDD and have no ideas where to get it in this location. I have found that this problem is appearing for about 2 or more years, and nothing changed from beta to beta, from release to release.

Some remark- When i trying to boot LiveCD I get this in 50%. When I trying to install I always have this error for about 6 retries.

Tormod Volden (tormodvolden) wrote :

This happens because casper (in the initrd mountroot() function) looks for the live CD on all block devices, including the floppy drive (somewhat unnecessary).

A workaround is to boot with "break=mount" and then when you have get the text prompt (press Enter to see it, because device detection messages hide it), type:
 rmmod floppy
 exit

Does this workaround for everybody?

Tormod Volden (tormodvolden) wrote :

The "floppy=off" boot option should also do the job. There's a long forum thread with many likely related reports at http://ubuntuforums.org/showthread.php?t=767154

Tormod Volden (tormodvolden) wrote :

I think we safely can suppose that no one wants to put the live file system on a floppy disk, so we can skip looking at the floppy.

Changed in casper:
status: Confirmed → Fix Committed
Tessa (unit3) wrote :

"floppy=off" doesn't work for me in a VirtualBox VM I'm doing testing in, it still tries to problem the (non-existent) floppy drive.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.141

---------------
casper (1.141) intrepid; urgency=low

  [ Johannes Ballé ]
  * Handle spaces in file names in md5sum.txt (LP: #251112).

  [ Colin Watson ]
  * Support ?= (set value but don't mark as seen) preseeding syntax in
    preseed script; previously we only supported it in the keyboard script,
    which confusingly doesn't deal with propagating console-setup/* preseeds
    to the target filesystem (LP: #253749).
  * Update to localechooser's new languagelist format.

  [ Tormod Volden ]
  * scripts/casper: don't scan floppy drives for livefs images (LP: #97306)
  * scripts/casper: fix broken RE in is_nice_device() (LP: #250328)
  * scripts/casper: properly use argument $1 in matches_uuid()

 -- Colin Watson <email address hidden> Fri, 19 Sep 2008 02:14:05 +0100

Changed in casper:
status: Fix Committed → Fix Released
WulfTheSaxon (wulf-bugmail) wrote :

I'm having this issue attempting to boot from a Jaunty live USB* on a Toshiba Satellite 2435-S255 (note that Alexandre had the same model). If I leave it for about 10 minutes, it eventually boots.

* created using instructions at http://rudd-o.com/en/linux-and-free-software/a-better-way-to-create-a-customized-ubuntu-live-usb-drive

Jim Rorie (jfrorie) wrote :

I'm seeing this in Karmic Alpha 4. There is no floppy in the system. Regression?

Tormod Volden (tormodvolden) wrote :

Can you please take a look at https://wiki.ubuntu.com/DebuggingCasper and provide a log? Please also file a new bug for this (just run "ubuntu-bug casper") since this must be another issue than the one that got fixed here.

Jim Rorie (jfrorie) wrote :

Tormod

This problem is also on a Karmic 4 system that is installed and running. Therefore, I'm not sure is specific to the live CD.

Reporting at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/409094

Florian Schweikert (kelvan) wrote :

I had the same problem a few minutes ago, booting karmic daily from usb.
Disabling floppy in bios solves the problem (with my mainboard).

Jim Rorie (jfrorie) wrote :

Your right. I'm an idiot. Thanks.

Tangram (lists-bluebox) wrote :

Have just installed Ubuntu 9.10 onto a USB using Linux Live USB Creator (www.linuxliveusb.com) with the intention of carrying Ubuntu in my pocket with a "persistent" configuration". Install went fine.

When I booted a PC from the Ubuntu USB, it sat for about 4 mins scrolling: .... Buffer I/O error on device fd0 .... on the screen before eventually giving up and proceeding with boot.

Sorry I'm pretty green on the whole linux/ubuntu/boot process, so can't tell you much more. I understand that disabling floppy in the bios might be an option, but that's not something I want to have to do to every maching I may end up using.

Cheers,
T.

FBKK (bursucel88) wrote :

This appears as fix released, but I still have this problem with 10.04.1 LTS version, so what is the fix and how do I Fix it ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments