Please disable the com.canonical.indicator.datetime show-calendar setting with low vision profiles, because the default setting block Orca keyboard commands in date/time indicator menues

Bug #965015 reported by Attila Hammer
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Dear Developers,

The com.canonical.indicator.datetime show-calendar setting value default is true.
If this setting is true, when an Orca user activate the date/time indicator, after move the second silent menu item, keyboard focus is grabbed, and impossible to use any Orca keyboard command.
Only possible to resume the date/time indicator menu system if the user clicking for example a cursor routing cell with he's braille display, or click Orca flat review binding for example a separator. Impossible for example switch other window, or leave the opened date/time indicator menue with escape key.
If the com.canonical.indicator.datetime show-calendar setting is false, all awailable menu items possible accessible with keyboard and Orca, and this problem are not happening.
The com.canonical.indicator.datetime show-calendar value change to false is a temporary fix, bug because near the final Precise release, need hiding this problem with screen reader users.
I attaching a video with full demonstrate the problem, and will be attaching a patch.

Attila

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: casper 1.312
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Mon Mar 26 08:33:52 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120308)
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Attila Hammer (hammera) wrote :
Revision history for this message
Attila Hammer (hammera) wrote :

The patch set from true to false value the com.canonical.indicator.datetime show-calendar setting with low vision and blindness profiles, this change result calendar menu item not grab focus and not block Orca keybinding commands.

Attila

tags: added: patch
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "The patch set the wrote calendar related setting from true to false value with low vision and blindness profiles" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Luke Yelavich (themuso)
Changed in casper (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.313

---------------
casper (1.313) precise; urgency=low

  * bin/casper-a11y-enable:
    - Remove code to create a sudoers config file that is no longer needed
      in the at-spi dbus world we now live in, thanks to Attila Hammer for
      the patch. (LP: #964985)
    - Disable the calendar in all low vision accessibility profiles as it has
      issues with keyboard navigation, thanks to Attila Hammer for the patch.
      (LP: #965015)
    - Do not hard code the ubuntu-2d session name in the set_session method.
  * ubiquity-hooks/30accessibility:
    - Use the orca settings from the live session for unity-greeter on the
      installed system, thanks to Attila Hammer for the patch. (LP: #968929)
 -- Luke Yelavich <email address hidden> Mon, 02 Apr 2012 16:39:26 +1000

Changed in casper (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers