Live-usb: italian language but english keyboard

Bug #953999 reported by Sandra Farnedi on 2012-03-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Low
Stéphane Graber

Bug Description

I try to explain the situation:
-boot with a fresh created usb persistent edubuntu version (2012-03-13)
- at ubiquity-dm choose the italian language
- Select 'Prova Ubuntu'
- everything is in italian, my keyboard too (see first screen-shot)
- I reboot and choose the Français language, select 'Essayer ubuntu'
- everything is in french, the keyboard too (it is a strange french variant, see the second screen-shot) )
- I reboot and choose the english language, select 'Try Ubuntu'
- every thing is still in FRENCH the keyboard too
- I reboot and choose italiano, select 'Prova Ubuntu'
- everything is in italian but the keyboard is the english one (see the third screen-shot), please note the window caption (gnome-control-center)
- in this moment, for instance, I am using my italian keyboard but my characters are mapped as in an english one and it is a problem

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.91-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CasperVersion: 1.307
Date: Tue Mar 13 12:54:51 2012LiveMediaBuild: Edubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120313)
ProcEnviron:
 TERM=xterm
 LANG=it_IT.UTF-8
 SHELL=/bin/bashSourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.3-0ubuntu1
 deja-dup 21.90-0ubuntu1
 gnome-bluetooth 3.2.2-0ubuntu3
 indicator-datetime 0.3.91-0ubuntu1

Related branches

See also bugs 951397 and 941399

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's specific to a live image right? (i.e not happening on installed system)? I'm not sure where the issue is but it's gnome-control-center, seems like either the CD language selector is acting weird or the settings are not stored as they should...

affects: gnome-control-center (Ubuntu) → gnome-session (Ubuntu)
Changed in gnome-session (Ubuntu):
importance: Undecided → Low
summary: - italian language but english keyboard
+ Live-usb: italian language but english keyboard

Yes, I'm using a live version of edubuntu on a persitent usb flah memory

Fabio Marconi (fabiomarconi) wrote :

Hello Sandra
Following your steps I cannot reproduce the issue, at the third time i've got language and keyboard italianized.
So as you are encountering this problem from various builds (see ex bug 952749 ) I mark this as confirmed and assign to edubuntu-meta subscribing stgraber for a better triage.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

description: updated
Fabio Marconi (fabiomarconi) wrote :

Oops I cannot reproduce on Ubuntu amd64 desktop 20120313

affects: gnome-session (Ubuntu) → edubuntu-meta (Ubuntu)
Fabio Marconi (fabiomarconi) wrote :

Hello Stephane
I cannot reproduce this in ubuntu, I acconseil too to take a look at all the bugs reported by sandra that is actually intensively testing edubuntu.
Thanks
fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Stéphane Graber (stgraber) wrote :

Moving bug to ubiquity as Edubuntu doesn't have any custom code that could do that.

affects: edubuntu-meta (Ubuntu) → ubiquity (Ubuntu)

No, the edubuntu boot phase is a bit different from the ubuntu one. When I start my machine with the install usb media in place, I have the same screen as in ubuntu when I press any key at start up and I choose "Try without any change to your computer". From now on I have NO other request about my preferred language. I am using edubuntu DVD i386.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/953999

tags: added: iso-testing
Stéphane Graber (stgraber) wrote :

Right, Edubuntu doesn't have the gfxboot timeout stuff, so the problem might have to do with casper preseeding.

If you have time to go through the same test, could you for each case paste the output of:
"cat /proc/cmdline"

That'd help to know exactly what the initrd received from gfxboot and might explain the weird keyboard layout change.

Here are the various contents of /proc/cmdline
ITALIAN CHOSEN:
noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/edubuntu.seed boot=casper initrd=/casper/initrd.lz persistent debian-installer/language=it keyboard-configuration/layoutcode?=it
FRENCH CHOSEN:
noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/edubuntu.seed boot=casper initrd=/casper/initrd.lz persistent debian-installer/language=fr keyboard-configuration/layoutcode?=fr keyboard-configuration/variantcode?=oss
ENGLISH CHOSEN:
noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/edubuntu.seed boot=casper initrd=/casper/initrd.lz persistent
ITALIAN CHOSEN:
noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/edubuntu.seed boot=casper initrd=/casper/initrd.lz persistent debian-installer/language=it keyboard-configuration/layoutcode?=it

I have a workaround. I add the italian layout to the one already present and my layout becomes italian for BOTH the italian keybords present. See the attached screen shot.

I delete one of the two italian keyboards and obtain the message shown in the attached screen-shot and here are the contents of the suggested commands:

xprop -root|grep XKB:
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "it", "oss", "lv3:ralt_switch"
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "it", "", "lv3:ralt_switch"

gsettings get org.gnome.libgnomekbd.keyboard model:
''

gsettings get org.gnome.libgnomekbd.keyboard layouts:
['it\toss']

gsettings get org.gnome.libgnomekbd.keyboard options:
@as []

Same messages if I select "Ripristina predefinite"

Anyway, now, my keyboard correctly works with the italian layout.

Stéphane Graber (stgraber) wrote :

Ok, I think I have an idea of what's going on here, basically the variant isn't reset, so choosing a keyboard without a variant fails.

I'll have a look soon, creating a fake usb disk now to test in a VM :)

affects: ubiquity (Ubuntu) → casper (Ubuntu)
Changed in casper (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.309

---------------
casper (1.309) precise; urgency=low

  * scripts/casper-bottom/14locales:
    - Stop dealing with /etc/environment
    - Always overwrite /etc/default/locale at boot time
    - Use /root/rofs/etc/default/locale as the base locale (LP: #951397)
  * scripts/casper-bottom/19keyboard
    - Reset /etc/default/keyboard if present in the overlay (LP: #953999)
  * scripts/casper-bottom/50ubiquity-bluetooth-agent
    - Only do the diversion the first time around
 -- Stephane Graber <email address hidden> Tue, 13 Mar 2012 17:00:58 -0400

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers