suspect race condition Keyboard layout, oem-config not set on persistent USB image

Bug #946406 reported by Giovanni Tornatore on 2012-03-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned

Bug Description

Test "precise-dvd-amd64.iso" 20120303 md5:- 597dcbbdd1e4aa59b3334b1ea1cb30e5

1) create a live usb session persistent;
2) in the list of available languages select italiano;
3) select "Prova Ubuntu" and press <Enter> and proceed to the Live Session;
4) In the live session start a terminal and press SHIFT+2; It will be shown the keys with an Italian keyboard layout.

ACTUAL RESULT
The keyboard is set to "us" : SHIFT+2 gives an '@'

EXPECTED RESULT
The keyboard layout is "it" : SHIFT+2 gives an ' " '

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: casper 1.305
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
CasperVersion: 1.305
Date: Sun Mar 4 15:20:01 2012
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120303)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/946406

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

Hello
I can see this fixed in casper 1.304 version, but here is shipped again 1.305.
reassigning
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

affects: casper (Ubuntu) → ubuntu-meta (Ubuntu)
Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
affects: ubuntu-meta (Ubuntu) → casper (Ubuntu)

Ciao Fabio,
ti confermo che il bug si ripropone!
Anche se ho effettuato una verifica della iso lanciandola in virtualbox e il problema non c'è!
Ciao!

I did a test of precise-dvd-amd64.iso 20120306 2ef7822bb012bc02f9cfb023982374de

casper versione 1.306

the bug there is.

For every restart resets the keyboard.
In the settings, the keyboard is "Italian", but the keyboard is English.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/946406

tags: added: localized-iso
Paolo Sammicheli (xdatap1) wrote :

Bug reproduced with 20120317 i386 live desktop. The strange thing is that the keyboard indicator in the bar is showing "it" as Italian. Selecting again Italian in the keyboard indicator the layout changes correctly

Sergio Zanchetta (primes2h) wrote :

Another step in testing.

The keyboard indicator shows "it" (Italian), the first selection out of 4, see screenshot

But on the ubiquity language selection window at boot, it shows "it4" (Italian, USA keyboard with italian characters), the fourth on the list.

Sergio Zanchetta (primes2h) wrote :

Screenshot showing "it4" (the fourth in the menu list)

Italiana
Italiana (tasti muti rimossi)
Italiana (Macintosh)
Italiana (tastiera USA con lettere italiane) ←

Sergio Zanchetta (primes2h) wrote :

Just tested official daily ISO (20120319)

On the language selection window, it shows "cm" with English selected (bug #956912) but shows "it" (not "it4") selecting Italian.

description: updated
Sergio Zanchetta (primes2h) wrote :

The bug is still present using build 20120321 but language selection window now correctly shows "it"

Hello, I have tested build precise 20120324.

This bus is confirmed!

In Sistem Setting, the keybord show "it", but the terminal pressing Shift 2, the result is @, but must "

I have setting keybord to "inglese UK", but top bar show "it"

Changed in casper (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

This seems like the same bug as bug 960096.

Hello I have tested quantal-dvd-amd64.iso (20120529) (md5:- e089276e5ab9487ce45d7de5df6120d4), on live usb persistent.

This bug is confirmed!

tags: added: quantal
Changed in casper (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-12.04.1
tags: added: rls-mgr-p-tracking
Stéphane Graber (stgraber) wrote :

Could you please test one of these images:
http://cdimage.ubuntu.com/precise/daily-live/20120704.1/

I'm wondering if this bug isn't a duplicate of bug 985065 which got fixed a week ago.

Changed in casper (Ubuntu Precise):
assignee: nobody → Stéphane Graber (stgraber)
Changed in casper (Ubuntu Quantal):
assignee: nobody → Stéphane Graber (stgraber)
Changed in casper (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in casper (Ubuntu Quantal):
status: Confirmed → Incomplete
Stéphane Graber (stgraber) wrote :

Can someone please test?

Hello I have tested quantal-desktop-amd64.iso (20120712) (md5:- 3e359505f6509be45bf2546a52ac6b49), on live usb persistent.

This bug is confirmed!

Stéphane Graber (stgraber) wrote :

This bug won't be fixed in time for 12.04.1 as it's not trivial to reproduce and the actual root of the bug is still unknown.

Changed in casper (Ubuntu Precise):
milestone: ubuntu-12.04.1 → none
Stéphane Graber (stgraber) wrote :

Can you provide a full step by step guide on how to reproduce this, including:
 - version of OS used to make the USB stick
 - name of the tool and version used ot make the USB stick
 - URL and md5 of the image you used
 - any relevant option in the tool used to make the USB stick
 - step by step instruction of any user input you do from the time you boot the USB stick

Quite a few people have recently been trying to reproduce this bug on 12.04.1 and 12.10 without any success, even when using the Italian keyboard layout, so there's something we're missing and that's not currently described in this bug report.

Brian Murray (brian-murray) wrote :

I downloaded Ubuntu 12.04.1 amd64 with md5sum 06472ddf11382c8da1f32e9487435c3d burned it to a DVD and booted off of it.

I then pressed F2 at the keyboard / accessibility screen and chose Italiano, choose Try Ubuntu and then launched a text editor. I then pressed Shift+2 and saw a " instead of an @.

Brian Murray (brian-murray) wrote :

I wonder if this isn't actually bug 960077.

Stéphane Graber (stgraber) wrote :

That perfectly could be, that other bug at least seems easy to reproduce and debug. I'll poke at it.

Stéphane Graber (stgraber) wrote :

Issue seems to be happening when you do (using 12.10 persistent media made with usb creator):
 - Boot media
 - Don't press any key, let it boot ubiquity
 - Choose a language like French and click on "Essayer Ubuntu"
 - Reboot the machine
 - When booting the media, enter gfxboot
 - Choose German and select Ubuntu ohne Installation ausprobieren
 - Let it boot
 - You'll get a session with a french keyboard layout instead of german (azerty vs qwertz)

The problem is the gsettings key set by ubiquity that's not cleared when reconfiguring the system wide keyboard setting.

Changed in casper (Ubuntu Quantal):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.326

---------------
casper (1.326) quantal; urgency=low

  * 22desktop_settings:
    - Rename 22screensaver to 22desktop_settings
    - Move 22gnome_panel_data's content to 22desktop_settings
    - Flush overrides in 22desktop_settings to avoid getting duplicate keys
      when using persistence.
    - Check for gsettings-desktop-schemas instead of gnome-panel-data
  * 35fix_language_selector:
    - Use sed against the original file (from rofs) instead of the target file.
      This avoids another case where the change is re-applied at every boot
      when using persistence.
  * 25adduser:
    - Remove RUNNING_UNDER_GDM from /etc/environment which was a big hack
      for back when we still used xscreensaver and was getting appended with
      every single boot.
    - Use /etc/sudoers.d instead of appending to /etc/sudoers, avoid getting
      duplicate lines with every reboot.
  * 23networking:
    - Change default /etc/network/interfaces to match that in /rofs, makes it
      easier to diff /etc when debugging casper.
  * casper-init, casper, 19-keyboard, casper-functions:
    - Remove any remaining reference to usplash as it's been deprecated for a
      long long time and just makes things harder to read.
  * casper-update-initramfs:
    - Exit when called from a non-writable media (cdrom) or when called from
      ubiquity. This fixes a > 1 minute wait when clicking "Try Ubuntu".
  * 19keyboard:
    - Add code to detect that the keyboard layout changed from the previous
      value and flush the gsettings key so that the indicator is properly
      reset. (LP: #946406)
  * 43disable_updateinitramfs:
    - Don't try to chmod a dangling symlink.
    - Only write /usr/sbin/update-initramfs if it doesn't already exist.
  * postinst:
    - Remove code generating symlink for /usr/sbin/update-initramfs to
      /usr/share/casper/casper-update-iniramfs as the diversion and symlinking
      is done in the initramfs and that code was only useful when the shim was
      first introduced. (LP: #984276)
  * scripts/casper:
    - Allow specifying live-media on the command line, helps when booting
      computers that are unable to boot a CD/USB disk. (LP: #423616)
    - Fix NFSOPTS handling by adding the needed comma and sticking it to the
      existing "ro" option of nfsmount (LP: #476208)
  * 22serialtty:
    - Move 22serialtty to 26serialtty to avoid overriding the newly generated
      upstart jobs. Note that this will spawn getty instead of login, but
      it's probably for the best as we need a specific baudrate. (LP: #747888)
 -- Stephane Graber <email address hidden> Tue, 02 Oct 2012 18:11:44 -0400

Changed in casper (Ubuntu Quantal):
status: Fix Committed → Fix Released

Hello, I have tested Edubuntu amd64 20121211 (md5sum:- 55c0d1196032c280c018f75c22dc5c5d *raring-dvd-amd64.iso), on live usb persistent.

This bug is confirmed!

Also cd live, this bug is confirmed.

Changed in casper (Ubuntu):
assignee: Stéphane Graber (stgraber) → nobody
Changed in casper (Ubuntu Precise):
assignee: Stéphane Graber (stgraber) → nobody
Changed in casper (Ubuntu Quantal):
assignee: Stéphane Graber (stgraber) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers