Ubuntu

Keyboard layout, oem-config not set on persistent USB image

Reported by Fabio Marconi on 2012-02-25
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Stéphane Graber
Precise
High
Stéphane Graber

Bug Description

TEST CASE
0. This test must be run on bare metal booted from usb
1. Create a USB Stick with latest image and _persistence enabled_
2. Boot a real machine from this stick
3. At ubiquity-dm select "Italiano" in the list of available languages
4. Select "Prova Ubuntu" and press <Enter> and proceed to the Live Session
5. In the live session start a terminal and press SHIFT+2. Compare the keys with an Italian keyboard layout

ACTUAL RESULT
The keyboard is set to "us" : SHIFT+2 gives an '@'

EXPECTED RESULT
The keyboard layout is "it" : SHIFT+2 gives an '"'

ALTERNATE TESTCASE
1. Select OEM Install mode on syslinux
2. Start Ubiquity

EXPECTED RESULT
Installation starts in OEM mode

ACTUAL RESULT
Installation start in normal mode

=== Original Description ===
Hello
Actually, when I launch a live session and I choose the italian language, the sessions started in italian language, but the keyboard layout still english.
If I launch the live session from the old splash menu, everythings works.
Thanks
Fabio
probably related to bug 940919
to reproduce>
start a live session, let it run till try or install window and select italian
the language will be set to italian, nut the keyboard layout still in english.
expected
If i choose italian the keyboard too needs to be italian

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: console-setup 1.70ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CasperVersion: 1.304
Date: Sat Feb 25 12:23:33 2012LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120225)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bashSourcePackage: console-setup
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Fabio Marconi (fabiomarconi) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/940908

tags: added: iso-testing
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in console-setup (Ubuntu):
status: New → Confirmed
Jonathan Kolberg (bulldog98) wrote :

If I selected an other keyboard layout in Ubiquity this layout was applyed

Martin Pitt (pitti) wrote :

I tried this on today's image (20120226), with selecting Italian or German at the initial Ubiquity "test or install" screen, and I get an Italian/German keyboard in the live session. So I cannot reproduce this. When trying this, did you select anything in gfxboot (the "old" splash screen that appears when you press a key at the very beginning with the "human equals keyboard" screen)?

affects: console-setup (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Francesco Ruvolo (ruvolof) wrote :

I have the same problem.
Actually I got us layout also selecting italian from the "old splash screen".

Fabio Marconi (fabiomarconi) wrote :

Hello Martin
This bug is present from many weeks (probably pre alpha1)
Step to reproduce:
- start the live cd and wait till it prompt for the language, select italian, wait the session start.
- pressing the number 2 key now you have @ (english keymap) instead of " (italian keymap).
Thanks a lot for everithings
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
Martin Pitt (pitti) wrote :

I still cannot reproduce this. I get accented characters for the keys right of l, and shift+2 is " (as expected for Italian). It's also fine in German for me.

This is the 20120226 amd64 Ubuntu desktop image: http://cdimage.ubuntu.com/daily-live/current/precise-desktop-amd64.iso

Martin Pitt (pitti) wrote :

Do you really use the Ubuntu image, or perhaps Xubuntu or another flavour? When you say "session starts in Italian", you mean there is a correct locale? The Ubuntu desktop images don't have the Italian langpack on the CD, so the session is actually appearing in English.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Shift+2, sorry
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Yesterday i found this on Ubuntu and Kubuntu amd 64.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

We all have found this on real hardware.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed

Fabio, I cannot reproduce either.
I tried 'Italian' from ubiquity-dm, Italian from syslinux, keymap only Italian from syslinux and every time the keyboard layout on the live session was correctly set to Italian.

I noticed from your bug report that /etc/default/keyboard is set to "us", in all the tests I did it is set to "it"

Could you please tell us exactly what is your testing environment:
The exact image you use for testing with md5
VM or bare metal
Are you booting from a CD, USB or ISO
Do you use persistence
Could you please attach the file /var/log/syslog

Thanks in advance

Fabio Marconi (fabiomarconi) wrote :

the syslog from the running live session with italian language and us keyboard.

Fabio Marconi (fabiomarconi) wrote :

Hello Jean
md5sums compare the one on the site
njin@precious:~/Ubuntu$ md5sum precise-desktop-amd64.iso
a27ffb52b2f01c0c2176b1be51f23b83 precise-desktop-amd64.iso
njin@precious:~/Ubuntu$
a27ffb52b2f01c0c2176b1be51f23b83 *precise-desktop-amd64.iso
I, everytime sync my images with zsync, write it to key with usb-creator-gtk with persistence, I always run my tests on real hardware, I don't rely on VM.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Here you can see the bug in action, look at the ubiquity icon translated into italian, and the layout just english, it don-t keep the settings for the keyboard and the system clock, because if i now run the installer it propose me to install in italian language and then propose egnlish layout.
Thanks
Fabio

Changed in ubiquity (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → ubuntu-12.04-beta-1

Confirmed with latest image

Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
assignee: nobody → Canonical Foundations Team (canonical-foundations)
description: updated
description: updated
tags: added: rls-mgr-p-tracking
Fabio Marconi (fabiomarconi) wrote :

Tested just now with the latest image and it is reproducible only with persistence enable.
Without persistence the ubiquity-dm works as expected.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Bug not reproducible burning the image on a CD rom.

description: updated
Steve Langasek (vorlon) on 2012-02-27
Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Stéphane Graber (stgraber)
Martin Pitt (pitti) on 2012-02-27
summary: - Cannot localize keyboard at startup in live session
+ Keyboard layout not set on persistent USB image

Can you attach the content of your /var/log/ubiquity/*

Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
  • dm Edit (4.9 KiB, text/plain)
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :

The attached logs are with persistence enabled.

Fabio Marconi (fabiomarconi) wrote :

This bug also afflict OEM installation, localization is possible only without persistence
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

This bug also afflict OEM installation, localization is possible only without persistence, elsewhere it launch a normal installation.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I could reproduce the problem on Virtual Box without persistence. I selected French and the layout is 'us'
XKBLAYOUT is set to "" in /etc/default/keyboard

Fabio Marconi (fabiomarconi) wrote :

tested 20100227.1 I cannot reproduce the bug, on real hardware, without persistence
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

same result on a different machine
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

summary: - Keyboard layout not set on persistent USB image
+ Keyboard layout, oem-config not set on persistent USB image

I did more tests and with persistence enabled boot settings like oem-config/enable=true are ignored
The parameter is present in /proc/cmdline but ignored by ubiquity.

ubiquity debug log attached

tags: added: qa-manual-testing
description: updated
Martin Pitt (pitti) wrote :

casper (1.305) precise; urgency=low

  * Wait for debconf-communicate to exit before trying to copy the
    database. (LP: #940908)

 -- Stephane Graber <email address hidden> Wed, 29 Feb 2012 21:48:39 -0500

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Fix Released
affects: ubiquity (Ubuntu Precise) → casper (Ubuntu Precise)
Fabio Marconi (fabiomarconi) wrote :

Fix confirmed.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Thanks for confirming the fix Fabio !

Installed 12.04 beta 2 from cdrom on my i3-2120T. I could not get norwegian keyboard, only english. Then I installed both English and Norwegian at the same time, enabling me to choose between them in the top bar. When choosing Norwegian keyboard layout, I get english, and when I choose english keyboard, I get norwegian layout. Something is really mixed up here.

EowynCarter (churbain) wrote :

I confirm the problem on beta 2. I set french, but no french keybord.

EowynCarter (churbain) wrote :

Just to add up :
What I did was go to keybord options ; revert to default, only english shows up there. Then add french. And voilà, french layout.

Henning Kulander (hennikul) wrote :

I can confirm that Robert's described problem still happens on a 12.04 machine with all updates from 24. april 2012. Get the same effect with having to choose English to get Norwegian layout. I will then get the layout I want, but after logout or locking the machine, the layout switches back to something that looks like US. I have this effect on three different machines running 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers