[Oneiric] PXE/NFS boot requires "IPAPPEND 2" in PXE menus

Bug #923219 reported by TJ on 2012-01-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned

Bug Description

In previous Ubuntu releases PXE/NFS netboots would correctly configure the network interface.

In Oneiric ipconfig fails to configure the interface because $DEVICE isn't defined for configure_networking() in '/scripts/functions'

The solution is to add the pxelinux "ipappend 2" option to the menu entries in the PXE boot menu, e.g:

LABEL 11.10 Oneiric 32-bit Ubuntu Live
    kernel iso-image/ubuntu-11.10-desktop-i386/casper/vmlinuz
    ipappend 2
    append root=/dev/nfs boot=casper netboot=nfs nfsroot=10.254.251.2:/srv/boot/iso-image/ubuntu-11.10-desktop-i386 initrd=iso-image/ubuntu-11.10-desktop-i386/casper/initrd.lz

'ipappend' causes "BOOTIF=01-<bootp-mac-address>" to be added to the kernel command line which is used by '/init' to set $DEVICE

TJ (tj) on 2012-01-29
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
AS (asu72sep) wrote :

I can confirm the above problem and solution on Oneiric 64-bit live CD

tags: added: oneiric
Changed in casper (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

I tested netboot with nfs and cifs without ipappend and the code seems fine nowadays.

Changed in casper (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers