casper doesn't configure autologin for lightdm properly

Bug #819624 reported by Mario Limonciello on 2011-08-02
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Canonical Foundations Team
Oneiric
High
Canonical Foundations Team

Bug Description

lightdm changed it's syntax with the most recent version and also no longer requires a configuration file causing the automatic login normally configured for the 'ubuntu' user to stop working.

Derivatives will still use /etc/lightdm/lightdm.conf but you can't rely on the contents anymore and just replace a string with a regular expression. Standard ubuntu doesn't have /etc/lightdm/lightdm.conf.

This failure is with the mythbuntu lightdm conf but will happen on all cases of lightdm right now.

[SeatDefaults]
user-session=mythbuntu
allow-guest=false

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: casper 1.272
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
CasperVersion: 1.272
Date: Tue Aug 2 04:38:11 2011
LiveMediaBuild: Mythbuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110802)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Mario Limonciello (superm1) wrote :
tags: added: iso-testing
Changed in casper (Ubuntu):
importance: Undecided → High
status: New → Triaged
Brian Murray (brian-murray) wrote :

Seems to me that this was fixed:

---------------
casper (1.273) oneiric; urgency=low

  [ Mario Limonciello ]
  * scripts/casper: Add support for SAS controllers now that 575297 is fixed.
    (LP: #819564)

  [ Stéphane Graber ]
  * lightdm no longer ships with /etc/lightdm/lightdm.conf in its package.
    Updating 15autologin casper hook to create one when missing. (LP: #819609)
 -- Stephane Graber <email address hidden> Tue, 02 Aug 2011 17:47:10 -0400

Changed in casper (Ubuntu Oneiric):
status: Triaged → Fix Released
Mario Limonciello (superm1) wrote :

Reviewing the diff, no it wasn't. It only fixed the ubuntu scenario. The derivative scenario still doesn't work properly (it doesn't check for and set the proper lines)

Changed in casper (Ubuntu Oneiric):
status: Fix Released → Confirmed
Paolo Sammicheli (xdatap1) wrote :

Just verified while performing ISO Testing with Ubuntu Desktop i386 and also Ubuntu is still affected from this bug.

Image: Ubuntu Desktop i386 (20110802.1)

Changed in casper (Ubuntu Oneiric):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Joel Pickett (jpickett) wrote :

Confirmed, got this bug while installing Ubuntu 11.10 Alpha 3

Stéphane Graber (stgraber) wrote :

Hmm, my latest casper upload should take care of most of the derivatives as well by removing any existing lightdm.conf prior to generating a new one.

The only case that's failing is when lightdm can't find the "default" session (it's hardcoded to "ubuntu" apparently).
This is a separate Launchpad bug, bug 806408.

Charlie Kravetz (charlie-tca) wrote :

Using the Xubuntu oneiric-desktop-amd64.iso image dated 2011-08-14, auto-login to the live session worked. I have not attempted auto-login in any other session today.

Paolo Sammicheli (xdatap1) wrote :

Solved in Ubuntu Desktop i386 (20110830)

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Colin Watson (cjwatson) wrote :

Mario, do you know if this still needs to be open, considering comment 6 and comment 7?

Mario Limonciello (superm1) wrote :

Colin,

It's been fixed now with the current collection of fixes around everywhere else, thanks.

Changed in casper (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers