Lubuntu Oneiric live desktop lacks restart and shutdown buttons

Bug #792850 reported by Erick Brunzell
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: casper

I was just testing the Lubuntu Oneiric Alpha1 image from here:

http://people.ubuntu.com/~gilir/

Now, first and foremost, this is more of a test regarding bug filing against the Lubuntu project than anything else. Since it is now on a fast-track to becoming a full fledged member of the Ubuntu family I decided to dedicate my iso-testing skills (however limited they may be) to the Lubuntu project.

That said, I was testing the aforementioned image and noticed that the Reboot and Shutdown buttons are lacking on the live desktop only. They are present post-installation.

This is hardly anything critical given that this is Alpha1, as stated above this is largely a learning exercise for myself so once Lubuntu is added to QA's iso-testing I'll have some idea what I'm doing :^)

Revision history for this message
Erick Brunzell (lbsolost) wrote :

I just subscribed the Lubuntu Dev Team.

As stated above, I'm NOT concerned about this particular bug (or any others encountered ATM), I'm just testing the waters, so to speak, in order to be more useful once the Lubuntu images are added to the QA Testing Tracker.

I look forward to helping in any way possible.

I had previously posted a query at "<email address hidden>" regarding the addition of the package 'lubuntu-desktop' to bug filing options. My thought was that such an addition might make it easier to file bugs against Lubuntu, but I could certainly be all wet.

Sometimes while testing the water one slips and falls in ;^/

I'm sort of thinking that's the wrong team to assign. I earlier joined this team:

https://launchpad.net/~lubuntu-desktop

But I doubt I'd get notifications from the dev team, and I am NOT a developer!

I might however be able to help sort out a few bugs and assign them properly, or at least perform some testing on both Ubuntu and Lubuntu images to get a comparison of behavior.

I hope I'm not just being a pain.

Revision history for this message
Erick Brunzell (lbsolost) wrote :

Just saving a screenshot, this is from the Lubuntu Oneiric Live CD. The buttons, and for that matter the Lubuntu DE, are generally fine post installation. The pop-up window looks the same whether it's launched from the button in the lower right hand corner or from the menu.

Revision history for this message
Jonathan Marsden (jmarsden) wrote :

The screenshot supplied demonstrating the reported issue does not show the default Lubuntu theme, it seems to show an LXDE theme instead.

Here, a virtualbox 4.0.8 VM running Lubuntu 11.10 Oneiric Alpha 1 shows the expected Lubuntu theming and the shutdown menu has all the expected buttons.

Did you perhaps change themes, and fail to note this in your bug report? That could well be significant in reproducing an issue of this kind.

See lubuntu-oneiric-alpha1-shutdown-jmarsden.png attached -- works for me :)

Revision history for this message
Erick Brunzell (lbsolost) wrote :

"The screenshot supplied demonstrating the reported issue does not show the default Lubuntu theme, it seems to show an LXDE theme instead."

Correct, and it only happens on the live desktop, not after I've installed. I began discussing this on the mailing list, to which I'd not subscribed in time for Julien's release announcement, but there were three issues regarding casper and/or ubiquity that I didn't experience with Ubuntu:

1) The Lubuntu Alpha1 Live CD boots to a tty, so you have to type startx to get the DE.

2) The default DE lacks restart or shutdown buttons.

3) Upon completing the installation I was asked whether to restart or keep using the Live DE as usual. I chose to restart and the CD ejected as expected but the screen was just blank. So I removed the CD, closed the tray and hit enter, but nothing happened. I tried some common key combos but finally had to use the reset button on my box to complete the restart.

Per Julien's instructions on the mailing list I repeated this procedure, and upon booting to a tty I tried waiting (I took a shower), and I tried to restart lxdm via "sudo service lxdm start", but I'm used to Gnome so I could easily be doing something wrong.

Regardless I could only get X to start by typing "startx" in the tty. Then I end up in what appears to be a pure LXDE.

"Here, a virtualbox 4.0.8 VM running Lubuntu 11.10 Oneiric Alpha 1 shows the expected Lubuntu theming and the shutdown menu has all the expected buttons."

I'm running on actual hardware, not in a VM. The hardware involved is:

JetWay JATOM-GM1-230-LF Motherboard
Intel Atom 230 CPU @ 1.60GHz
System Memory 2GB DIMM
Intel 82945G/GZ Integrated Graphics
Intel N10/ICH 7 Family High Def Audio Controller

"Did you perhaps change themes, and fail to note this in your bug report? "

No. I installed nothing. Well, since Julien requested a screenshot I installed the screenshot tool, but that's all.

Maybe starting from "startx" rather than starting from lxdm starts the wrong session?

Given what Julien said in the release announcement I doubt this is worth spending much time on.

Revision history for this message
Erick Brunzell (lbsolost) wrote :

OK, while "sudo service lxdm start" failed to work, the command "sudo /etc/init.d/lxdm restart" does work and boots the true Lubuntu DE which includes the proper buttons :^)

So it all has something to do with lxdm not handing off boot properly, or something of the nature.

Given the fact that this is Alpha1, and the next build begins with a whole new process, I think it would be foolish to waste any additional time on this.

Revision history for this message
Jonathan Marsden (jmarsden) wrote :

Using startlubuntu rather than startx seem to solve this issue.

Changed in casper (Ubuntu):
status: New → Confirmed
Revision history for this message
Erick Brunzell (lbsolost) wrote :

I marked this invalid for the following reasons:

1) Lubuntu Alpha1 was not an official build and as Jonathan Marsden pointed out starting X with a more proper work-around solved the issue in Alpha1.

2) This problem does NOT exist in the official Lubuntu Alpha 3 build.

Changed in casper (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers