10.10 live CD prompts to upgrade to 11.04

Bug #777759 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2011-05-05
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson
Maverick
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: casper

Boot from a live 10.10 CD/USB media. Wait a short while. Update manager pops up offering to upgrade to 11.04. This is prior to actually installing the OS. If you click 'yes' to upgrade it actually starts going through the motions of upgrading the live environment.

Probably best to suppress this upgrade popup until we have an installed OS?

Colin Watson (cjwatson) on 2011-05-05
Changed in casper (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → In Progress
Colin Watson (cjwatson) on 2011-05-05
Changed in casper (Ubuntu):
status: In Progress → Fix Committed
Changed in casper (Ubuntu Lucid):
status: New → Triaged
Changed in casper (Ubuntu Maverick):
status: New → Triaged
Changed in casper (Ubuntu Natty):
status: New → Triaged
Changed in casper (Ubuntu Lucid):
importance: Undecided → High
Changed in casper (Ubuntu Natty):
importance: Undecided → High
Changed in casper (Ubuntu Lucid):
milestone: none → ubuntu-10.04.3
assignee: nobody → Colin Watson (cjwatson)
Changed in casper (Ubuntu Maverick):
importance: Undecided → High
Colin Watson (cjwatson) wrote :

I think we should SRU this, although it'll only be effective with new live CD builds; I can certainly do custom ones for prior releases although the only one that will definitely be released as a point release is Lucid. Testing will be a pain on Lucid and Natty as there won't naturally be any releases to upgrade to; for those releases, it might be simplest to test for regressions (e.g. the system boots without errors, etc.).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.266

---------------
casper (1.266) oneiric; urgency=low

  * Disable release-upgrade prompts in the live session (LP: #777759).
 -- Colin Watson <email address hidden> Thu, 05 May 2011 12:28:33 +0100

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2011-05-05
Changed in casper (Ubuntu Lucid):
status: Triaged → In Progress
Changed in casper (Ubuntu Maverick):
status: Triaged → In Progress
Colin Watson (cjwatson) on 2011-05-05
Changed in casper (Ubuntu Natty):
status: Triaged → In Progress
Changed in casper (Ubuntu Maverick):
assignee: nobody → Colin Watson (cjwatson)
Changed in casper (Ubuntu Natty):
assignee: nobody → Colin Watson (cjwatson)

Accepted casper into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in casper (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted casper into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in casper (Ubuntu Maverick):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted casper into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in casper (Ubuntu Lucid):
status: In Progress → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Lucid:
I have verified that the version of casper 1.236.3 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done-lucid
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.236.3

---------------
casper (1.236.3) lucid-proposed; urgency=low

  * Disable release-upgrade prompts in the live session (LP: #777759).
 -- Colin Watson <email address hidden> Thu, 05 May 2011 12:31:54 +0100

Changed in casper (Ubuntu Lucid):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

Adding back v-needed for maverick/natty.

tags: added: verification-needed
JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bugtask for Maverick. Please upgrade to a newer version of Ubuntu.
More information here: https://lists.ubuntu.com/archives/ubuntu-announce/2012-April/000158.html

Changed in casper (Ubuntu Maverick):
status: Fix Committed → Invalid
dino99 (9d9) wrote :
Changed in casper (Ubuntu Natty):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers