[Natty] If have preconfigured Orca settings with /etc/skel folder, 30accessibility script owerwrite preconfigured Orca settings for live session

Bug #744227 reported by Attila Hammer on 2011-03-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: casper

Dear Developers,

Some minor Ubuntu based accessible distributions using settings storage for /etc/skel folder to provide new future created users a preconfigured basic accessibility services.
This is true for example the Vinux distribution.
If /etc/skel folder containing a preconfigured .local/share/orca folder, the settings file is automaticaly owerwriting the live session running 30accessibility script.

The problem is live with scripts/casper-bottom/30accessibility script for casper source package. Only user-settings.conf file is owerwrite the script, another files is right copyed from /etc/skel folder to live user home directory.

In scripts/casper-bottom/30accessibility script every blindness related profiles happening following code part with Orca related:
                        # Moderate Visual Impairment
   if [ -x /root/usr/bin/orca ]; then
    mkdir -p /root/home/$USERNAME/.local/share/orca
    set_orca_config /root/home/$USERNAME/.local/share/orca/user-settings.conf magnifier
    chroot /root chown -R $USERNAME.$USERNAME /home/$USERNAME/.local/share/orca
   fi

                        # Blindness
   if [ -x /root/usr/bin/orca ]; then
    mkdir -p /root/home/$USERNAME/.local/share/orca
    set_orca_config /root/home/$USERNAME/.local/share/orca/user-settings.conf speech
    chroot /root chown -R $USERNAME.$USERNAME /home/$USERNAME/.local/share/orca
   fi

                        # Braille
   if [ -x /root/usr/bin/orca ]; then
    mkdir -p /root/home/$USERNAME/.local/share/orca
    set_orca_config /root/home/$USERNAME/.local/share/orca/user-settings.conf braille
    chroot /root chown -R $USERNAME.$USERNAME /home/$USERNAME/.local/share/orca
   fi

If possible, please not owerwrite existing Orca settings file for live session created users if the file existing for /etc/skel/.local/share/orca folder (user-settings.conf).

Attila

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: casper 1.259
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Mon Mar 28 13:57:05 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110327)
ProcEnviron:
 LANGUAGE=hu_HU:en
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Attila Hammer (hammera) wrote :
Luke Yelavich (themuso) wrote :

This functionality is already taken care of by the 10adduser script, not directly, but by calling the various commands/scripts to create a new user. As part of this process, the user add command copies everything from /etc/skel into the new user's home directory.

Changed in casper (Ubuntu):
status: New → Invalid

Hy Luke,

Why invalid this bug for live user creation? I see this bug.
I attaching a proper setted absolute sure right user-settings.conf file
with I putted the /etc/skel folder when I generate a custom live CD build.
If all contents are copyed proper from /etc/skel folder to live user
home directory, why absolute different the created
.local/share/orca/user-settings.conf file with this attached file?
My attached orca settings file is for example the sound pitch is 3.0,
turned off some key echo settings, turned on tutorial messages, speak
child position function, speak object mnemonics function, but this
changes are dropped automaticaly with automatic created live session
user creation script or casper-bottom/30accessibility script.
Look following code part for scripts/casper-bottom/30accessibility file,
this part have the problem I think:
   if [ -x /root/usr/bin/orca ]; then
    mkdir -p /root/home/$USERNAME/.local/share/orca
    set_orca_config
/root/home/$USERNAME/.local/share/orca/user-settings.conf speech
    chroot /root chown -R $USERNAME.$USERNAME
/home/$USERNAME/.local/share/orca
   fi

So, following line simple owerwrite the preconfigured Orca settings for
live session user .local/share/orca folder if have orca configuration
file with /etc/skel folder without examine have already a created
user-settings.conf file with live user home directory/.local/share/orca
directory?
    set_orca_config
/root/home/$USERNAME/.local/share/orca/user-settings.conf speech

You are absolute true, if I manual creating a new user after live CD is
booted and login is happened with adduser blabla command, all thinks
right copyed for /etc/skel folder to new blabla named user home
directory. The problem happening only with live user automatic creation.
Please put an if case the required code parts for
casper-bottom/30accessibility script or another script if have already
for automatic created live user .local/share/orca directory an
user-settings.conf file, don't run the script the factory Orca
configuration setting file creation.

How can possible fix this problem for live user automatic creation?
Prewious Ubuntu releases since Hardy does'nt have this problem, this
problem beginning with Natty.
I use this way preconfiguring Orca with Hardy, Intrepid, Natty, Karmic,
Lucid, Maverick, all prewious releases this way works right (put orca
configuration file with /etc/skel folder the proper Orca folder with
custom generated live CD build).
Prewious releases live user automatic get proper the I want setted Orca
settings if I generated a custom build.

If this bug is inwalid, please tell me how can I disable this working
method to live user creation scripts not owerwrite already setted custom
Orca settings for automatic created live session user?

Attila

Hy,

I attaching the factory generated user-settings.conf, when live user is
created, this orca configuration file is created and owerwrited with I
prewious attached configuration file.

Attila

Changed in casper (Ubuntu):
status: Invalid → New

Hy Luke,

 I attaching a test only patch, not real fix, but help me full sure
detecting what part have the problem with the script.
Absolute sure the scripts/casper-bottom/30accessibility script have the
bug I think.
Look my patch. When I applied the patch (remove I prewious two comment
copyed code parts) with blindness related profiles, and installed my
custom live CD build the modifyed casper package, my custom putted Orca
configuration is wonderful copyed from with /etc/skel folder to live
user home directory.
If the removed code part is present the
scripts/casper-bottom/30accessibility script with blindness related
profiles, the /etc/skel folder prewious copyed
.local/share/orca/user-settings.conf file is automatical owerwrited the
script with you want doed factory default configuration.

I full understand why you want this possibility, and full accept,
because if the user selected a visual impaired related profile (speech,
magnification, braille etc), and not have a preconfigured orca
configuration file with /etc/skel/.local/share/orca folder, the script
automatical enabled the required Orca functions for live session user if
I right understand the function code.
This is right, only need examining the proper function existing the
/etc/skel/.local/share/orca/user-settings.conf or not. If existing, this
file have a customization purpose, and the script not need creating a
new configuration with live user home directory and owerwriting the
already existing configuration. If not existing, this is right, and the
script need creating the factory Orca configuration with you doed now
without this examining.

I try doing this fix? You accept this type fix?
What the last date before I need ready the fix?

Attila

Attila Hammer (hammera) wrote :

Hy Luke,

Please look this way fix patch.
The fix is not perfect ready yet, but if have Orca configuration file in
the root/etc/skel/.local/share/orca folder, not happening configuration
file owerwriting with live user home directory, and right copyed the
custom Orca configuration the live user home directory.
The problem have if not have Orca configuration in skel folder.
The configuration file is right creating automaticaly, but before this
creation presenting Orca preferences window. When I press Escape key the
dialog and restart Orca, preferences window right not presenting, and
~/.local/share/orca directory have the user-settings.conf file.
Running later the set_orca_config
/root/home/$USERNAME/.local/share/orca/user-settings.conf speech script
part and Orca already launched this part?

What can I forgot?

Attila

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.262

---------------
casper (1.262) natty; urgency=low

  * scripts/casper-bottom/30accessibility:
    - Don't blindly assume that there are no orca config files/directories in
      the created user's home directory. A derivative may have placed something
      in /etc/skel as part of the live filesystem, and we shouldn't be
      clobbering it, thanks to Attila Hammer for the pointer (LP: #744227)
 -- Luke Yelavich <email address hidden> Mon, 04 Apr 2011 17:32:40 +1000

Changed in casper (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers