live session from usb key take very long to start (40 min.) due to probing of non-existent floppy

Bug #739774 reported by Carla Sella on 2011-03-21
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Medium
Martin Pitt
Natty
Medium
Martin Pitt
udisks (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: casper

When starting my pc form persistent usb using "Startup disk creator" the pc hangs for about 40 minutes (I have the ubuntu word in white in the center of the screen) and then suddenly the live session starts.
The same thing doesn't happen on a 64 bit notebook I have, if I start the notebook from the same usb key the notebook starts regularly.
The version of "statup disk creator" is the. 0.2.28.
Note that I do not have this problem if the usb key is not a persistent one.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: casper 1.259
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Mon Mar 21 21:59:12 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110321)
ProcEnviron:
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Carla Sella (carla-sella) wrote :
tags: added: iso-testing
description: updated
description: updated
Fabio Marconi (fabiomarconi) wrote :

From Kern.log:

Mar 21 21:57:22 ubuntu kernel: [ 20.788412] end_request: I/O error, dev fd0, sector 0
Mar 21 21:57:22 ubuntu kernel: [ 32.869106] end_request: I/O error, dev fd0, sector 0
Mar 21 21:57:22 ubuntu kernel: [ 32.869109] Buffer I/O error on device fd0, logical block 0

Mar 21 21:57:22 ubuntu kernel: [ 2209.279269] end_request: I/O error, dev fd0, sector 0
Mar 21 21:57:22 ubuntu kernel: [ 2209.279271] Buffer I/O error on device fd0, logical block 0

Look at the times.

Changed in casper (Ubuntu):
status: New → Confirmed
Carla Sella (carla-sella) wrote :

I confirm having the same problem with Natty Beta1 the iso 20110328

Carla Sella (carla-sella) wrote :

I confirm having the same problem with Natty Beta1 iso 20110329.1

Carla Sella (carla-sella) wrote :

I'm having the same exact problem with the iso 20110330 of Natty Beta 1 (testing)

Jean-Baptiste Lallement (jibel) wrote :

Thanks for you report.

Is there of floppy drive in this system ?

Changed in casper (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

On 03/31/2011 09:34 PM, Jean-Baptiste Lallement wrote:
> Thanks for you report.
you're welcome !

> Is there of floppy drive in this system ?
>
>

No I do not have a floppy but I have a card reader/writer.

--
Carla Sella
email: <email address hidden>
https://launchpad.net/~carla-sella

This sounds reminiscent of bug 539515. Carla, can you go into your BIOS (when you boot you'll see something like, "Press F2 for options.") and see if you can disable the floppy controller? Do let us know whether or not that fixes the issue.

Thanks!

On 04/01/2011 02:04 PM, Evan Dandrea wrote:
> This sounds reminiscent of bug 539515. Carla, can you go into your BIOS
> (when you boot you'll see something like, "Press F2 for options.") and
> see if you can disable the floppy controller? Do let us know whether or
> not that fixes the issue.
>
> Thanks!
>
Hello Evan,
It worked ! :)
I entered my BIOS and disabled the entry "Legacy Diskette A", rebooted
with the usb persistent key and my PC started within a few seconds.

--
Carla Sella
email: <email address hidden>
https://launchpad.net/~carla-sella

Hello Evan,

we found this bug during the ISO Testing (another guy on the Italia testing team mailing list said to have reproduced it). As far as I can see it's a regression because bug #539515 claim to be fixed in Maverick. What do you recommend, should it be assigned to udisks package?

Changed in casper (Ubuntu):
status: Incomplete → Confirmed
Changed in udisks (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: regression-release
summary: - live session from usb key take very long to start (40 min.)
+ live session from usb key take very long to start (40 min.) due to
+ probing of non-existent floppy
Changed in casper (Ubuntu Natty):
status: Confirmed → Triaged
Changed in udisks (Ubuntu Natty):
status: Confirmed → Triaged
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I finally found an old computer which still has a floppy controller (I don't have an actual floppy anywhere, but having one wouldn't expose this bug at all). I can reproduce the problem there.

Nothing in udisks changed since maverick, and as the problem only occurs on the live CD, with persistency, then the bug is in casper somewhere. I debugged this a bit and indeed found that find_cow_device() iterates over all block devices and runs blkid and other tests on them; this will time out badly.

In udev and udisks we set up the rules to avoid touching a floppy device automatically at all costs, for this very reason. casper must do the same. I figure it wouldn't be very useful to have a persistency file on a floppy disk anyway.

Changed in udisks (Ubuntu Natty):
assignee: Martin Pitt (pitti) → nobody
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

I definitively found one place where this wreaks havoc, and I'll upload a fix for that in a minute. It remains to be seen whether this is the only place where things go wrong, but as the scripts are very hard to test without a cow (chicken-egg problem), I'll upload this and test tomorrow's daily CD.

Changed in casper (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.263

---------------
casper (1.263) natty; urgency=low

  [ Evan Dandrea ]
  * Suppress Log Out item in the live session (LP: #750140).

  [ Martin Pitt ]
  * scripts/casper-helpers, find_cow_device(): Do not ever probe floppy
    devices. There are lots of computers which still have a floppy controller
    (and thus a /dev/fd0), but no actual floppy. Trying to send anything to
    /dev/fd0 will result in very long timeouts. Here this causes booting the
    live CD to take more than 30 minutes. (See also LP #539515 for the
    corresponding bug in udev/udisks). (LP: #739774)
 -- Martin Pitt <email address hidden> Mon, 04 Apr 2011 16:12:34 +0200

Changed in casper (Ubuntu Natty):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

I tested today's desktop image, and it's a lot better now. I still get about three floppy accesses from somewhere, but now the live system starts within two or three minutes.

Carla Sella (carla-sella) wrote :

I tested today.s live 64 bit desktop image with and without the floppy controller enabled and the system started in both cases in 2-3 minutes.
So everything's ok.
Thank you.
Carla

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers