Natty live CD fails to complete boot w/o user interaction

Bug #711965 reported by Erick Brunzell on 2011-02-02
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: casper

I'm iso-testing the Natty i386 rebuild image this AM and I notice that boot "stalls" completely if no user input is provided. That is just let it boot w/o pressing a key to display boot options.

I did begin by testing CD for defects and it passed fine, so after a hard reset I pressed a key to display the boot options and selected Try Ubuntu and the boot process completed just fine.

Outside of that this Natty image is the best I've tried in weeks so I'm tempted to say this could just be addressed in the release notes.

Note: most of the logs attached will provide no useful info other than providing package info. The failed "live boot" is not far enough into the process to allow starting a TTY.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: casper 1.255
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Wed Feb 2 10:19:38 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: casper

Erick Brunzell (lbsolost) wrote :
tags: added: iso-testing
Changed in casper (Ubuntu Natty):
milestone: none → natty-alpha-3
Brian Murray (brian-murray) wrote :

I was unable to recreate this using the daily build 2011-02-02 (which is Alpha 2) in a virtual machine. Was this using real hardware or a virtual machine?

Changed in casper (Ubuntu Natty):
status: New → Incomplete
Erick Brunzell (lbsolost) wrote :

Actual hardware:

JetWay JATOM-GM1-230-LF Motherboard
Intel Atom 230 CPU @ 1.60GHz
System Memory 2GB DIMM
Intel 82945G/GZ Integrated Graphics
Intel N10/ICH 7 Family High Def Audio Controller

And it was a Live CD used in a fairly new Asus DVD multi-recorder. All of my installation testing completed successfully as long as I began by hitting a key, displaying the boot option menu, and then selecting either Try Ubuntu or Install Ubuntu.

I'd noticed with the previous build (20110201.1) it booted OK, but it had much worse problems. I did notice recently that the two "mid-boot" options (Try or Install) appear to have been removed but I felt that was likely a design decision.

Changed in casper (Ubuntu Natty):
status: Incomplete → New
Evan (ev) wrote :

Can you press a key at CD boot to break into the menu, then hit F6, followed by escape on the first entry. This will let you edit the kernel command line. Remove "quiet splash" and add "maybe-ubiquity" in its place, then hit enter to boot. This should provide more feedback on the boot process. Take a picture of whats on the screen once it's definitely hanging.

Thanks

Changed in casper (Ubuntu Natty):
status: New → Incomplete
Erick Brunzell (lbsolost) wrote :

@ Evan Dandrea,

I'm not sure how useful this will be. To say I stink at photography is a gross understatement. I'm legally blind and I really can't see what I'm doing while I'm doing it. There's one file in here that's pdf and it shows the full screen, but it's nearly unreadable other than the last line. I was finally able to use macro mode and grab some bits and pieces. The pdf and the JPG's were taken at different times. Sorry I couldn't do better, but even to see the LCD monitor on my camera is nearly impossible.

I suspect this is somehow related to my hardware shown in post #3. I can't reproduce it on my other box:

VIA PC2500 Mainboard
VIA Esther C7 CPU 1500MHz
System Memory 1GB DIMM
VT8233/A/8235/8237 AC97 Audio Controller
CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] Graphics

Nor can I reproduce it using the same disc as an image with VirtualBox/testdrive. And the disc does pass the "Check CD for defects" test. The previous days image didn't do this but had much worse problems. I'm not terribly concerned about this ATM and I'm just waiting for daily updates to Natty resulting in a fairly decent desktop before burning a new daily image.

I hope this tar.gz works, and apologies again :^(

Martin Pitt (pitti) wrote :

Taking off the natty RC radar, as this is unreproducible.

Changed in casper (Ubuntu Natty):
milestone: natty-alpha-3 → none
status: Incomplete → Won't Fix
Erick Brunzell (lbsolost) wrote :

This is no longer valid with the Alpha 3 iso-testing image. That is, I've tried to reproduce it with the "daily-live/20110302/natty-desktop-i386.iso" on the same hardware originally effected and it's not reproducible so Martin is correct in marking this Won't Fix.

Launchpad Janitor (janitor) wrote :

[Expired for casper (Ubuntu) because there has been no activity for 60 days.]

Changed in casper (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers