"Eject CD" message not translated

Bug #70566 reported by Miguel Ruiz on 2006-11-06
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
casper (Baltix)
Undecided
Unassigned
casper (Guadalinex)
High
Juanje Ojeda
casper (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: casper

If I selected an spanish session (using options at boot time) every system message must be in this language.

After session finished (reboot or shutdown) an english message appeared. (related to eject cd - in blue letters)

I think this message must be translated.

This is happening from Edgy to Jaunty

Miguel Ruiz (mruiz) on 2006-11-06
description: updated
Colin Watson (cjwatson) wrote :

This is casper's problem, and there's an existing comment in the source about it.

# XXX - i18n
echo -n "Please remove the disc, close the tray (if any) and press ENTER: "
if [ -x /sbin/usplash_write ]; then
    /sbin/usplash_write "TIMEOUT 86400"
    /sbin/usplash_write "TEXT-URGENT Please remove the disc, close the tray (if any)"
    /sbin/usplash_write "TEXT-URGENT and press ENTER to continue"
fi

Changed in ubiquity:
status: Unconfirmed → Confirmed

I'm developer from Guadalinex v4, what is a spanish Ubuntu derivative. This is a important bug for as, because a lot of our users don't speak (or read) english.

We're trying to fix it in the better way so if you got any plans for it or know the best way to do it, let me know, please.

I'll attach the patch. Those changes works for me outside the casper. I mean, running the i18n part from my system (Edgy).
The only difference is I put an "echo" before each "/sbin/usplash_write" for testing the translations.

I had to put inside the "for" the .mo directory and the "gettext" binary to be cached, but this part is not giving problems.

I keep trying but I like to know if you see teh problem, or you had something already done, or maybe you don't like the aproach we've taken.

Thanks

Colin Watson (cjwatson) on 2007-09-29
Changed in casper:
importance: Undecided → Wishlist
status: Confirmed → Triaged
Pierre Slamich (pierre-slamich) wrote :

This bug persists in the 7.10 (Gutsy) Ubuntu Live CD I've just received.

It would be nice to have it fixed for Hardy, as the live CD is the entry door for many users on Ubuntu, and must be as perfect as possible. (Also think Firefox and OOo dictionnaries and user interfaces for native languages pre-installed)

We might even need a Live CD Love and polish spec to thoroughly find anf fix problems, speed up boot.

Bryce Harrington (bryce) wrote :

The patch looks okay to me.

Pierre Slamich (pierre-slamich) wrote :

Could it be forwarded to Casper devs for upstream inclusion then ?

Colin Watson (cjwatson) wrote :

There is no need to "forward it to casper developers"; casper's upstream *is* Ubuntu and we are already subscribed to this bug.

Colin Watson (cjwatson) wrote :

I'm looking at this now and see a number of problems. There is no need to respond to these; I'm just listing them to help Juanje avoid making the same mistakes in future.

 * The translation of the TEXT-URGENT string splits a single sentence into two translatable pieces. This is a fundamental "don't do this" about internationalisation; the smallest sensibly-translatable unit is almost always a sentence. As it happens it seems that usplash has supported line-wrapping text since breezy (and if it doesn't then we should fix it), so this can just be collapsed into a single string.
 * Use xgettext to generate .pot files and don't edit them after doing so. The .pot file shouldn't have stuff in it indicating that a Spanish translation team is responsible for it.
 * You don't need to set TEXTDOMAINDIR explicitly; gettext(1) makes it clear that there's a default, and in any case we don't want to override language pack handling here.

I think the rest is OK, but will attempt to test it before committing.

Colin Watson (cjwatson) wrote :

Actually, usplash seems to line-wrap character-by-character rather than splitting on word boundaries. It would probably be best to fix this in usplash rather than using an external tool (the most obvious such tool would be fold, which demonstrably miscalculates word boundaries when Unicode is involved).

Also, this patch does not fetch the language from /etc/default/locale or similar. I'll fix that.

Colin Watson (cjwatson) wrote :

Even leaving the line-wrapping problem aside, usplash processes text as char * and really isn't going to work all that well with most languages. We need to fix this before a casper change will be useful.

Changed in usplash:
importance: Undecided → Medium
status: New → Triaged
Colin Watson (cjwatson) wrote :

Furthermore, usplash's fonts only include 229 characters, which definitely isn't going to be enough for many non-European languages (e.g. CJKV).

Daniel Holbach (dholbach) wrote :

Unsubscribing Sponsors team for now, please re-subscribe when ready.

Juanje Ojeda (juanje) wrote :

This issue is importan for Guadalinex and must be solved.

Changed in casper:
assignee: nobody → juanje
importance: Undecided → High
Juanje Ojeda (juanje) wrote :

The comment before was just for us. If Ubuntu can't doit because of the 299 characteres and the full languages support, I undertand, but we need solved for Guadalinex.

Colin, I'll take your advises and I'll try again the gettext thing.

Changed in casper:
status: New → In Progress
Juanje Ojeda (juanje) on 2009-03-01
description: updated
Colin Watson (cjwatson) wrote :

My comments were general quality issues with the patch, not things that should affect one distribution rather than another. I would suggest taking them into account rather than discounting them as things that only affect Ubuntu!

Juanje Ojeda (juanje) wrote :

> My comments were general quality issues with the patch, not things that should affect one distribution rather than
> another. I would suggest taking them into account rather than discounting them as things that only affect Ubuntu!

I know and I'll take them into account. The thing is that for Guadalienx is mandatory to have this in Spanish. We must have it in one way or another for this version.
If we have to do in a not very nice way, we'll do it. But this doesn't mean we'll try later to do it in the better way for Ubuntu (so for Guadalinex). But we have not much time and we can't wait for having a usplash issue fixed or even fixing it ourself.

That was what I meant, sorry if I didn't explain well myself.

With the move away from uspash, what's the status of that bug ?

AJenbo (ajenbo) wrote :

Any progress on this, the string is a very visable one and should realy be translatable.

Nigel Babu (nigelbabu) on 2010-06-12
tags: added: patch-needswork
Nigel Babu (nigelbabu) wrote :

This patch has been reviewed as part of Operation Cleansweep. Looking at the comments from cjwatson, I'm marking the patch as patch-needswork. If you can look into the issues and suggest a new patch, please feel free to change the 'patch-needswork' tag to 'patch' so it comes into our review queue again.

AJenbo (ajenbo) wrote :

Here is a patch that fixes the issue when using plymouth

AJenbo (ajenbo) on 2010-09-21
tags: removed: patch-needswork
David Planella (dpm) on 2010-09-22
tags: added: patch
Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
AJenbo (ajenbo) wrote :

Please look in to applying this patch or improving it, people who don't understand english are left stumped at the end of a live session or install.

David Planella (dpm) on 2011-05-16
Changed in ubuntu-translations:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → Low
Bilal Akhtar (bilalakhtar) wrote :

Thank you for reporting this issue and bringing it to our attention. However, this bug is not a valid paper cut, as a paper cut should be a small usability issue, in the default or featured applications, that affects many users and is quick and easy to fix.
Therefore this bug cannot be addressed as part of the One Hundred Paper Cuts project.

This is a temporary translation issue and not a bug.
For further info about the paper cut criteria, please read <https://wiki.ubuntu.com/PaperCut>.

Don't worry though, This bug has been marked as "Invalid" ONLY in the One Hundred Paper Cuts project.

Changed in hundredpapercuts:
status: New → Invalid
Adolfo Jayme (fitojb) on 2015-11-28
no longer affects: hundredpapercuts
no longer affects: ubuntu-translations
no longer affects: usplash (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers