persistence doesn't work on liveusb

Bug #683260 reported by Francesco Ruvolo on 2010-11-30
80
This bug affects 14 people
Affects Status Importance Assigned to Milestone
usb-creator
Invalid
Undecided
Unassigned
casper (Ubuntu)
High
Evan
Natty
High
Evan

Bug Description

Binary package hint: casper

I'm testing natty. I tried with Kubuntu and I found that the persistant option doesn't work at all.

I made the liveusb with usb-creator from Ubuntu 10.10.

Because of a bug on apport (bug #683250) I wasn't able to send a good report. Please let me know what else I can provide to you. I'll put as attachment the only report I was able to get.

Related branches

Francesco Ruvolo (ruvolof) wrote :
tags: added: iso-testing
Ara Pulido (ara) wrote :

Same results in Ubuntu, testing Natty Alpha 1

summary: - persistant doesn't work on liveusb
+ persistence doesn't work on liveusb
Changed in casper (Ubuntu Natty):
status: New → Confirmed
Sander Jonkers (jonkers) wrote :

Yep, the same for me with Ubuntu Natty Alpha 1: live-usb is not persistent. Both with sticks created with usb-creator-gtk from Ubuntu 10.10 and from Natty Alpha 1 booted from CD.

Very annoying: this way I can't test-use Natty from my live-usb because all settings and updates are lost at reboot.

FWIW: output of 'mount' below, and dmesg attached.

ubuntu@ubuntu:~$ mount
aufs on / type aufs (rw)
none on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
/dev/sdb1 on /cdrom type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)
ubuntu@ubuntu:~$

Sander Jonkers (jonkers) wrote :

I booted without the boot options "quiet splash --", and the screen showed this:

stdin: error 0
umount: can't umount /casper-rw-backing: Invalid argument
Warning: Unable to find the persistent medium
stdin: error 0:
umount: can't umount /home-rw-backing: Invalid argument
Warning: Unable to find the persistent home medium
stdin: error 0

I will try to post the picture of the boot screen.

Sander Jonkers (jonkers) wrote :

And, FWIW, adding "persistent" to the boot options did not change anything.

Sander Jonkers (jonkers) wrote :

And there is the picture (sorry for the flash)

Sander Jonkers (jonkers) wrote :

Still the same problem in Natty Alpha 1 daily live build 2011-01-12 ...

Francesco Ruvolo (ruvolof) wrote :

Still the same problem in Natty Alpha 2.

Paolo Rotolo (paolorotolo) wrote :

Still the same problem in Kubuntu Natty Alpha 2.

tags: removed: kubuntu
Kate Stewart (kate.stewart) wrote :

Cleaning up the priority (ie. assigning one), so it gets tracked for the release.

Changed in casper (Ubuntu Natty):
importance: Undecided → High
milestone: none → natty-alpha-3
Sander Jonkers (jonkers) wrote :

Kate, I'm glad this bug is now mentioned on the Alpha 2 known bugs list (http://www.ubuntu.com/testing/natty/alpha2): "Persistence doesn't work on liveusb. (683260) "

Do you think there will be a daily build before Alpha 3 that will solve this?

Changed in casper (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Evan (ev) on 2011-02-09
Changed in casper (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
Changed in usb-creator:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.257

---------------
casper (1.257) natty; urgency=low

  * Handle $cow_backing already being mounted elsewhere (LP: #683260).
 -- Evan Dandrea <email address hidden> Fri, 11 Feb 2011 16:41:11 +0000

Changed in casper (Ubuntu Natty):
status: Confirmed → Fix Released
Sander Jonkers (jonkers) wrote :

Seems indeed to be fixed: I'm running Natty daily build 2011-02-13 from USB-stick, and after a reboot the file I created on the Desktop is still there. :-)

Fabio Marconi (fabiomarconi) wrote :

I confirm that save connections settings too

Luigi Tanese (luigitanese) wrote :

I gave the problem with this version of Ubuntu i386 DVD. Version: 20120817.1

Evan (ev) wrote :

Luigi,

Please open a new bug report. The issue you are experiencing is unlikely to be related.

Thanks!

Luigi Tanese (luigitanese) wrote :

The bug I found in this version. now do not know if I should open in new bug as you say.

Good job

http://iso.qa.ubuntu.com/qatracker/milestones/230/builds/21411/testcases/27/results

Kate Stewart (kate.stewart) wrote :

please open a new bug, and cross post it here, and on the iso tracker.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers