[dove] casper fails to boot if SATA HDD is attached

Bug #618489 reported by Michael Casadevall on 2010-08-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Michael Casadevall
linux-mvl-dove (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: casper

On Dove A0 and on AVD1, the board fails to boot if there is a SATA hard drive attached to the board, complaining that there is no 'init='. This appears to be a problem with is_nice_device() which isn't properly identifying the board if SATA is plugged in.

Changed in casper (Ubuntu):
assignee: nobody → Michael Casadevall (mcasadevall)
importance: Undecided → High
milestone: none → ubuntu-10.10-beta
Oliver Grawert (ogra) wrote :

this seems to rather be a problem with the driver for the sata controller not using a standard kernel interface to expose devices.

affects: linux-meta-mvl-dove (Ubuntu) → linux-mvl-dove (Ubuntu)
Changed in linux-mvl-dove (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.240

---------------
casper (1.240) maverick; urgency=high

  * scripts/casper
    - Added platform-sata_mv to is_nice_device() to allow Marvell
      Dove A0 and AVD1 to properly boot live media (LP: #618489)
 -- Michael Casadevall <email address hidden> Mon, 16 Aug 2010 19:36:56 +0800

Changed in casper (Ubuntu):
status: New → Fix Released
Tobin Davis (gruemaster) on 2011-03-16
Changed in linux-mvl-dove (Ubuntu):
status: New → Fix Released
Paolo Pisati (p-pisati) wrote :

This bug is not reproducible anymore in linux-mvl-dove, and after a bit of testing on IRC with Tobin and Oliver we concluded it has already been fixed. Closing it.

Changed in linux-mvl-dove (Ubuntu):
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers