usplash progress reporting is not very accurate for casper

Bug #61535 reported by Matt Zimmerman on 2006-09-20
14
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Low
Tollef Fog Heen

Bug Description

As we discussed on IRC, the progress reporting via usplash on casper boots isn't very accurate. Much of the time in a casper boot is spent in the initramfs, but this only accounts for a small fraction of the progress bar display.

Matt Zimmerman (mdz) on 2006-09-20
Changed in casper:
importance: Untriaged → Low
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) on 2006-09-22
Changed in casper:
assignee: nobody → tfheen
Matt Zimmerman (mdz) wrote :

Looking at it, it doesn't seem very accurate for a number of other configurations as well. I think the approach used for ticking the progress bar in initramfs isn't adequate and this needs a rethink. Please look into this in detail after beta.

On di, 2006-09-26 at 18:18 +0000, Matt Zimmerman wrote:
> Looking at it, it doesn't seem very accurate for a number of other
> configurations as well. I think the approach used for ticking the
> progress bar in initramfs isn't adequate and this needs a rethink.
> Please look into this in detail after beta.

You could make the progressbar pulsate whilst spending quality time in
initramfs.
--
Dennis K.

Time is an illusion, lunchtime doubly so.

Tollef Fog Heen (tfheen) wrote :

Latest upload:

casper (1.71) edgy; urgency=low

  * Use TEXT-URGENT in shutdown script to make sure we display the "please
    remove disc and press enter" text. Malone: #61533
  * Increase usplash timeout since "TIMEOUT 0" no longer means "spin
    forever".
  * Don't move-mount all the squashfs-es into / since that confuses mono
    (and some other apps too). Malone: #62756
  * Disable kwallet by default. Malone: #47743
  * Add -n to language selector to make it not whine about
    not-fully-installed langpacks. Malone. #37568
  * Override definition of log_end_msg in casper-functions. Make sure all
    casper-bottom scripts use this.
  * Pulsate bar in casper-top and casper-bottom. Malone: #61535

 -- Tollef Fog Heen <email address hidden> Wed, 4 Oct 2006 09:52:06 +0200

This fixes the problem a bit, but now the progress bar after casper-bottom is finished seems to never progress. I'll look at tomorrow's ISOs and see if they have the same problem, if so I'll have to work around it somehow.

Tollef Fog Heen (tfheen) wrote :

Marking as in-progress since this is hopefully-fixed but might need a bit more work.

Changed in casper:
status: Confirmed → In Progress
Tollef Fog Heen (tfheen) wrote :

   * Force suspend and hibernate both off, since reconfiguring
     gnome-power-manager kills usplash here. Fixes Malone: #61535
     completely.

Changed in casper:
status: In Progress → Fix Released

On Fri, Oct 06, 2006 at 12:31:11PM -0000, Tollef Fog Heen wrote:
> * Force suspend and hibernate both off, since reconfiguring
> gnome-power-manager kills usplash here. Fixes Malone: #61535
> completely.

It's useful to be able to test suspend to RAM using the live CD. Can this
be fixed a different way?

--
 - mdz

Tollef Fog Heen (tfheen) wrote :

* Matt Zimmerman

| On Fri, Oct 06, 2006 at 12:31:11PM -0000, Tollef Fog Heen wrote:
| > * Force suspend and hibernate both off, since reconfiguring
| > gnome-power-manager kills usplash here. Fixes Malone: #61535
| > completely.
|
| It's useful to be able to test suspend to RAM using the live CD. Can this
| be fixed a different way?

My guess is that it's the dmidecode call that (at least on my test
machine) kills usplash. (By kill I mean «freeze», since what happens
is usplash seems to stop updating the screen). If my guess is
correct then it's non-trivial to fix since we only enable suspend for
machines where it's supported. (AFAIK, at least. If I'm wrong, I
could always enable it and tell people whose systems it doesn't work
on «tough luck».)

--
Tollef Fog Heen ,''`.
UNIX is user friendly, it's just picky about who its friends are : :' :
                                                                      `. `'
                                                                        `-

Matt Zimmerman (mdz) wrote :

On Mon, Oct 09, 2006 at 11:02:28AM -0000, Tollef Fog Heen wrote:
> * Matt Zimmerman
>
> | On Fri, Oct 06, 2006 at 12:31:11PM -0000, Tollef Fog Heen wrote:
> | > * Force suspend and hibernate both off, since reconfiguring
> | > gnome-power-manager kills usplash here. Fixes Malone: #61535
> | > completely.
> |
> | It's useful to be able to test suspend to RAM using the live CD. Can this
> | be fixed a different way?
>
> My guess is that it's the dmidecode call that (at least on my test
> machine) kills usplash. (By kill I mean «freeze», since what happens
> is usplash seems to stop updating the screen). If my guess is
> correct then it's non-trivial to fix since we only enable suspend for
> machines where it's supported. (AFAIK, at least. If I'm wrong, I
> could always enable it and tell people whose systems it doesn't work
> on «tough luck».)

The progress reporting on the current dailies looks good, thanks.

--
 - mdz

Michael (michaeljt) wrote :

I don't know if this quite fits in here, but I will add it anyway. Currently, during boot of an installed system, the first part of the bootsplash is very slow to start moving, and a new user might think their machine has frozen. Some sort of indication (anything moving on the screen would do really) that that is not the case might not be a bad thing.

Matt Zimmerman (mdz) wrote :

On Wed, Mar 28, 2007 at 05:34:10PM -0000, Michael wrote:
> I don't know if this quite fits in here, but I will add it anyway.
> Currently, during boot of an installed system, the first part of the
> bootsplash is very slow to start moving, and a new user might think
> their machine has frozen. Some sort of indication (anything moving on
> the screen would do really) that that is not the case might not be a bad
> thing.

That is a different issue; casper is only used on the live CD and reports
progress differently.

--
 - mdz

Matt Zimmerman (mdz) wrote :

(I've filed said issue as bug #162397)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers