F5 options need to be linked to the right casper options

Bug #58836 reported by Henrik Nilsen Omma on 2006-09-04
10
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Colin Watson
casper (Ubuntu)
High
Unassigned
gfxboot-theme-ubuntu (Ubuntu)
Undecided
Colin Watson

Bug Description

This is just a reminder-bug to make sure we keep track of this. (I'm also suggesting some name changes here from use case to technology used, hope that's OK)

On Ubuntu:

0. None
1. 'High Contrast' - Use Gnome High Contrast Large Print theme
2. 'Magnifier' - Set AT-SPI on and the default Magnifier (as before)
3. 'Screen reader' - Set AT-SPI on and the default Screen reader (as before)
4. 'Keyboard modifiers' - Set sticky keys and mouse keys (as before)
5. 'On-screen keyboard' - Launch the default Gnome on-screen keyboard (we skipped this in Dapper, reintroducing)

On Kubuntu:

0. None
1. 'High Contrast' - Use KDE High Contrast Large Print theme
2. 'Magnifier' - Launch kmag on starting session
3. 'Keyboard modifiers' - Set sticky keys and mouse keys (as before)

On Xubuntu (if possible):

0. None
1. 'Keyboard modifiers' - Set sticky keys and mouse keys (as before)

Colin Watson (cjwatson) wrote :

I've added a gfxboot-theme-ubuntu task, because the option names live there.

Jonathan Riddell (jr) wrote :

On Kubuntu please set up

0. None
 1. 'High Contrast' - Use KDE High Contrast Large Print theme
 2. 'Magnifier' - Launch kmag on starting session
 3. 'Keyboard modifiers' - Set sticky keys
 4. 'Keyboard and mouse modifiers' - Set sticky keys and mouse keys and mouse click tool

Colin Watson (cjwatson) wrote :

gfxboot-theme-ubuntu (0.2.2) edgy; urgency=low

  * If available, play startup.mod sound on startup and accessv1.mod (etc.)
    when selecting accessibility menu items. However, this isn't working
    well in tests, so I've left it disabled by not shipping any .mod files.
    Anyone who would like to try to take this from here and figure out
    what's wrong would be welcome.
  * Improve keyboard navigation in accessibility menu: 0 selects None, and
    1, 2, etc. select other menu items in order (closes: Malone #39303).
  * Rename accessibility menu options to describe technology rather than use
    case, per Henrik (closes: Malone #58836).
  * Interpret gfxboot-access-options keyword in isolinux.cfg; for example,
    "v1 v2 m1" enables only the high contrast, magnifier, and keyboard
    modifiers options.
  * Re-enable access=m2 option (now "On-Screen Keyboard") by default.

  * Add/update translations from Rosetta: Afrikaans, Arabic, Belarusian,
    Bengali, Catalan, Kashubian, Danish, Esperanto, Spanish, Estonian,
    Basque, Persian, Filipino, Galician, Hindi, Croatian, Hungarian,
    Indonesian, Icelandic, Italian, Japanese, Kannada, Korean, Kurdish,
    Lithuanian, Latvian, Mongolian, Malay, Low German, Occitan, Polish,
    Portuguese, Romanian, Russian, Slovak, Slovenian, Somali, Swedish,
    Tamil, Thai, Urdu, Chinese (Taiwan).

 -- Colin Watson <email address hidden> Tue, 5 Sep 2006 13:51:36 +0100

Changed in gfxboot-theme-ubuntu:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Colin Watson (cjwatson) wrote :

revno: 1141
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Wed 2006-09-06 13:49:14 +0100
message:
  restrict accessibility options to v1/v2/m1 for Kubuntu and v1 for Xubuntu (closes: #58836)

Changed in ubuntu-cdimage:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Henrik Nilsen Omma (henrik) wrote :

AFAICS the F5 options still do not activate the access settings on the latest daily. AT-SPI is not activated and the relevant application is not started.

Changed in casper:
importance: Undecided → High
Henrik Nilsen Omma (henrik) wrote :

This patch fixes a few items that are out of date, changing gnopernicus -> orca and gok -> onboard (the gok entry was missing some brackets as well).

HOWEVER, I don't think that's the real problem because when I test the live CD none of the settings are affected, including ones that looked correct to me in the old script.

This patch has not been tested in casper. It also fails to configure orca to start the magnifier (starts speech by default) because orca no longer uses gconf :( I'll investigate other ways of starting it, but we may need to remove the magnifier F5 option in Edgy :(

Henrik Nilsen Omma (henrik) wrote :

usplash sans 'quiet' does show "Configuring accessibility options..." and /var/log/casper.log also shows:

Begin: Configuring accessibility options...
Done.

Nothing very interesting.

Colin Watson (cjwatson) wrote :

debian/changelogcasper (1.74) edgy; urgency=low

  [ Tollef Fog Heen ]
  * Sync up ubiquity-hooks/30accessibility with
    scripts/casper-bottom/30accessibility fixing spelling errors and
    enabling accessibility in KDE.

  [ Colin Watson ]
  * Fix check for presence of gconf2 (closes: Malone #58836).

 -- Colin Watson <email address hidden> Wed, 11 Oct 2006 11:18:00 +0100

Changed in casper:
status: Unconfirmed → Fix Released
Jani Monoses (jani) wrote :

This makes Xubuntu support the same 5 options as the Ubuntu liveCD, with the same
shortcoming of not starting the magnifier but speech instead on v2.
Not opening a new bug as the relevant people are already subscribed to this one and to keep all F5 info in one place, hope it's ok.

Jani Monoses (jani) wrote :

On the Ubuntu LiveCD v2 and v3 are identical as orca uses it's default config of speech on and magnifier off. This changes the defaults that are written in the initial config file in the user's home dir.

Creating an ~/.orca/user-settings.py might have been cleaner even if more code, but then orca sees that dir exists and it does not pop up its preferences dialog on startup.

Henrik Nilsen Omma (henrik) wrote :

The patch looks good to me. I'm opening the bug again (hope that is appropriate).

Changed in casper:
status: Fix Released → Confirmed
Colin Watson (cjwatson) wrote :

Please file a new bug on this, and subscribe whoever needs to be subscribed; it's getting too confusing to keep on closing and reopening this one.

Changed in casper:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers