compcache leaves too little free RAM for systems with 256M when installing with ubiquity

Bug #568038 reported by Paul Larson on 2010-04-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Critical
Oliver Grawert

Bug Description

Binary package hint: casper

Installing on beagle with 256MB ram currently results in compcache using 50% to create a compressed swap area. This was done in bug #560548 and was the right idea to get us past the original constraints. Also, this has allowed for d-i based images that work great. However the image has since moved to just running ubiquity for the netbook install, rather than full live environment, so the memory requirements should be a bit less.

The result currently, is that during the install, we are seeing order 5 page_alloc failures, and the install fails to complete. I tried removing the ramzswap and still got the page_alloc failures, but the install completed successfully. Could just be that a bit more tweaking is needed here, but this means that on the target beagle platform, the ti_omap image will currently not complete the install.

Paul Larson (pwlars) wrote :
Paul Larson (pwlars) wrote :
Changed in casper (Ubuntu):
importance: Undecided → Critical
Paul Larson (pwlars) wrote :

I experimented some more with this last night by reloading the ramzswap module with different disksize_kb settings. I tried 25%, 10%, and even turning it off completely.
50% - install fails, error message at the end saying the install was unable to complete
25% - install fails, dumped out to a blank X screen at the end
10% - install fails, dumped out to a blank X screen at the end
0% (remove ramzswap and xvmalloc) - install succeeds, but there is a failed page_alloc towards the beginning (possibly around partition/mkfs time)

So with no compcache, it seems like we have our best chance of getting all the way through the install, however I was going with the default partitioning scheme in each of these tests. So it remains to be seen whether changing the partitioning would work as well.

In light of this, it seems like our best bet may be to just disable compcache entirely, unless a better solution can be found.

Oliver Grawert (ogra) wrote :

a nocompcache option was added to casper and is enabled by default in the omap images now.

Changed in casper (Ubuntu):
status: New → Fix Released
assignee: nobody → Oliver Grawert (ogra)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments