Ubuntu

Unable to install off USB 3.0 port (HP Envy 15 Laptop)

Reported by Joe Barnett on 2010-04-16
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
initramfs-tools (Debian)
Fix Released
Unknown
initramfs-tools (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

SRU information (by broder):

IMPACT: initramfs-tools-generated initramfs's do not contain the xhci-hcd kernel module, which means that they can not find a root filesystem hanging off of a USB 3.0 port, regardless of whether or not the device is USB 3.0 or not.

DEVELOPMENT: Not yet addressed, but will be fixed in initramfs-tools 0.99 (see Debian bug #625224)

PATCH: lp:~broder/ubuntu/maverick/initramfs-tools/fix-565047 and lp:~broder/ubuntu/natty/initramfs-tools/fix-565047

INSTRUCTIONS: Install Ubuntu onto an external USB hard drive connected to a USB 2.0 port, then connect the hard drive to a USB 3.0 port and attempt to boot. Observe that you get dropped to an "(initramfs)" shell (or don't, if you have the fix)

RISK: Minimal. The change just changes the name of the module that mkinitramfs looks for

========
Original bug description:

I'm trying to install ubuntu on a new HP Envy 15 laptop, which has no internal CD drive, but does have a USB CD drive

Any CD (9.04, 10.04alpha2, 10.04beta2) I have tried results in "(initramfs) unable to find a medium containing a live file system". Have also tried putting the 10.04beta2 image on a USB key, with the same results. Am guessing that its for some reason unable to find devices plugged into USB, possibly related to USB 3.0 things?

Also tried netboot install of http://archive.ubuntu.com/ubuntu/dists/lucid/main/installer-amd64/current/images/netboot/netboot.tar.gz , but it seems to be unable to bring up the network after booting into the curses based installer frontend. Am guessing need an updated driver for the network card somehow?

typing out some USB/netowrk related lspci lines from the netboot cmdline from another machine, let me know if more specific information would be useful -- somewhat hard to get detailed info due to various issues so far, though...:

00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
02:00.0 USB Controller: NEC Corporation Device 0194 (rev 03)
03:00.0 Network controller: Intel Corporation WiFi Link 6000 series (rev 35)
04:00.0 Ethernet controller: Atheros Commmunications AR8131 Gigabit Ethernet (rev c0)

Colin Watson (cjwatson) on 2010-04-16
affects: debian-installer (Ubuntu) → casper (Ubuntu)
Joe Barnett (thejoe) wrote :

for the network configuration issue w/ netboot, lscpi -n shows:

03:00.0 0280: 8086:4239 (rev 35)
04:00.0 0200: 1969:1063 (rev c0)

Joe Barnett (thejoe) wrote :
Joe Barnett (thejoe) wrote :
Joe Barnett (thejoe) wrote :

added casper.log & dmesg output from lucid daily amd64 install cd image

Joe Barnett (thejoe) wrote :

slightly more clarification:

this was cd image installed onto a usb stick.
also, had an SD card w/ an image on it inserted, but machine won't boot from it, so was booting from the usb stick.

even though it won't boot from it, the SD card shows up as /dev/sdb (and /dev/sdb1). Even though it will boot from it, the usb stick doesn't show up as /dev/sd*.

Joe Barnett (thejoe) wrote :

wow, ok; so if i put the *same* cd image on both the usb stick & the SD card, then the installer (casper?) loaded from the usb stick recognizes the SD card filesystem, and I am able to install successfully. once booted into the installer/installed system, USB & network all seem to work fine.

attaching lspci -nvvv

Joe Barnett (thejoe) wrote :

wow, more fun;

apparently the laptop also has an eSATA/USB2.0 port (originally thought it was just eSATA, but learned that it's both). Plugging in the USB CD drive to that port allows the installer to boot successfully.

retitled bug to emphasize USB 3.0; probably not HP Envy 15 specific either, but don't have another machine with USB3.0 ports to test with.

summary: - Unable to install on HP Envy 15 laptop
+ Unable to install off USB 3.0 port (HP Envy 15 Laptop)
Airam RR (airamrguezrivero) wrote :

I have an HP Envy15 with USB 3.0 ports and with the same characteristics as Joe Barnett and I'm having the same problems as him. I'm getting this error:
"(initramfs) unable to find a medium containing a live file system."

andypiper (andypiperuk) wrote :

This same issue seems to affect the Dell Inspiron 1545 models.

Airam RR (airamrguezrivero) wrote :

This bug is still present in Ubuntu 11.04 Natty. (The final version).

Furthermore, I also put the installation files into an SD and I'm still unable to install the OS.

cheshirekow (cheshirekow) wrote :

Same problem on the HP Slate 500. There are no USB 2.0 ports. The Natty image works from a USB disk without modification.

Evan Broder (broder) wrote :

The issue is described in the linked Debian bug - the name of the kernel module for USB 3.0 changed, but initramfs-tools didn't, so the module didn't end up in the initramfs, leaving it unable to activate any USB 3.0 devices.

Changed in casper (Ubuntu):
status: New → Invalid
Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Evan Broder (broder) on 2011-06-08
Changed in initramfs-tools (Ubuntu):
assignee: nobody → Evan Broder (broder)
Evan Broder (broder) on 2011-06-08
description: updated
Changed in initramfs-tools (Ubuntu):
assignee: Evan Broder (broder) → nobody
Evan Broder (broder) wrote :

Here's the fix for oneiric

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.98.8ubuntu4

---------------
initramfs-tools (0.98.8ubuntu4) oneiric; urgency=low

  * Rename xhci to xhci-hcd to fix booting from USB 3.0 devices
    (cherry-picked fix from Debian bug #625224). (LP: #565047)
 -- Evan Broder <email address hidden> Wed, 22 Jun 2011 10:57:43 -0700

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
Stéphane Graber (stgraber) wrote :

Uploaded to oneiric, natty-proposed and maverick-proposed.
Added nominations for natty and maverick to track the status.

Thanks

Changed in casper (Ubuntu Maverick):
status: New → Invalid
Changed in casper (Ubuntu Natty):
status: New → Invalid
Changed in initramfs-tools (Ubuntu Maverick):
status: New → Fix Committed
Changed in initramfs-tools (Ubuntu Natty):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Do we really need to bother about maverick here?

tags: added: verification-needed

Accepted initramfs-tools into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Verified in natty-proposed, using the workflow described in the ticket
description.

Martin Pitt (pitti) on 2011-06-28
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.98.8ubuntu3.1

---------------
initramfs-tools (0.98.8ubuntu3.1) natty-proposed; urgency=low

  * Rename xhci to xhci-hcd to fix booting from USB 3.0 devices
    (cherry-picked fix from Debian bug #625224). (LP: #565047)
 -- Evan Broder <email address hidden> Wed, 08 Jun 2011 09:46:20 -0700

Changed in initramfs-tools (Ubuntu Natty):
status: Fix Committed → Fix Released

Hello Joe, or anyone else affected,

Accepted initramfs-tools into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
affects: initramfs-tools (Ubuntu) → cloud-initramfs-tools (Ubuntu)
Changed in cloud-initramfs-tools (Ubuntu):
assignee: nobody → pat belshaw (phil-atio2000)
Evan Broder (broder) on 2011-07-06
affects: cloud-initramfs-tools (Ubuntu) → initramfs-tools (Ubuntu)
Changed in initramfs-tools (Ubuntu):
assignee: pat belshaw (phil-atio2000) → nobody
Evan Broder (broder) wrote :

Verified maverick-proposed.

I had to use usb-creator and create a USB drive with a persistent store, because Maverick's GRUB 2 doesn't seem to boot off of USB 3.0 ports, but I was able to reproduce the bug then make it go away using syslinux.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.98.1ubuntu6.1

---------------
initramfs-tools (0.98.1ubuntu6.1) maverick-proposed; urgency=low

  * Rename xhci to xhci-hcd to fix booting from USB 3.0 devices
    (cherry-picked fix from Debian bug #625224). (LP: #565047)
 -- Evan Broder <email address hidden> Wed, 08 Jun 2011 09:49:46 -0700

Changed in initramfs-tools (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in initramfs-tools (Debian):
status: Unknown → Fix Released

Good day to you good and kind people.

I have also had this problem, and it is USB 3.0, but the fix has not worked for my system.
See my thread on Linux Mint Forums.
http://forums.linuxmint.com/viewtopic.php?f=49&t=83476

Have just read #21 above. Maverick's Grub2 doesn't boot to USB3.0.
OH.

Now what? Mint10 surely uses the same Grub as Maverick, and Mint 11 is based on Natty - it had the same problem when I tried it.

I have just UNetbootin-ed an image of Mint Debian, the most recent image. I am told this contains your fix, but so did the Maverick-proposed version of initramfs-tools I slipped into Mint Gnome 10 - without any luck.

Anyone searching for a fix to these problems would surely like to know if there is a version of Grub that works on USB 3.0.
Or a way to make it work. Any ideas?

Thank you very much for your hard work.

alfred (harlock59) wrote :

i have a kernel panic when trying to boot from a usb 3 port on a desktop pc on a usb 2 usb stick with ubuntu 12.10 or 13.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.