Ubuntu

unable to find a medium containing a live file system

Reported by map7 on 2010-03-22
108
This bug affects 16 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Medium
Unassigned

Bug Description

When trying to boot Ubuntu 10.04 beta1 64bit on the Primary Slave IDE CD-ROM drive it fails with the message:
stdin: error 0 (repeated over 25 times)

BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu9) built-in shell (ash)
Enter 'help' for a list of built-in commands

(initramfs) Unable to find a medium containing a live file system.

If I switch my CD-ROM drive over to Primary Master IDE then it will boot no problem.

I'm not using any of the other IDE ports, my HD is SATA.

Problem still exists in Natty.

affects: ubuntu → linux (Ubuntu)
tags: added: kernel-series-unknown
nullkuhl (null-kuhl) on 2010-04-10
Changed in linux (Ubuntu):
status: New → Confirmed
Béné (bene-d) wrote :

I get the same error when trying to install 10.04.1. The only version of Ubuntu not affected by this error is Ubuntu 8.04...

Arie Skliarouk (skliarie) wrote :

The error happened on ubuntu 10.10 beta as well. Had to use Wubi installed to get going...

Walter Lapchynski (wxl23) wrote :

same here, 10.10 beta. on a ppc. curious that the cd gets popped out right before the problem. didn't have that happen with 10.04.

Aaron Gutman (disco) wrote :

Same issue, Vaio P-series laptop (VPCP11AKJ) using Ubuntu 10.10 on a USB stick. I did not have this problem when I installed 10.04 on it. No optical drive in this computer.

delance (olivier-delance) wrote :

Hello everybody. I will try to manage this issue.

map7 CD-ROM
Béné ???
Arie Skliarouk ???
Walter Lapchynski CD-ROM
Aaron Gutman USB stick

@map7, @Béné, @Arie Skliarouk, @Walter Lapchynski: could you try with a USB stick ?
@Aaron Gutman: sorry, I found nothing on USB stick with google. Could you check MD5 of your USB stick ? https://help.ubuntu.com/community/HowToMD5SUM

Greg Wilkins (gregw-wiltel) wrote :

I'm having the same problem with a lenovo thinkpad w510.

I have tried 10.4, 10.10 beta and 10.10 on various USBs and always get the unable to find medium message after the splash screen.
I was able to install 10.4 via CD.

I have attached my lspci output

Greg Wilkins (gregw-wiltel) wrote :

Oops sorry. This issue is probably not related to my problem, as I'm trying to boot from USB.
sorry

delance (olivier-delance) wrote :

@Greg Wilkins: Aaron Gutman has issue with a USB stick, so it seems there are many issues with this error message. And I will try to manage USB issue also.

Hi

Same here with 32-bit on a USB stick on my Clevo laptop where I am trying to compile and test the dreadful unsupported sis671 driver. I could boot reliably in 64-bit and do the job, on the very same machine (clevo m761s). The "standard" live CD does not boot either. md5 is ok. xubuntu 32 boots ok, but if is passed on a stick, chaos... There are 2 visible messages:

"disabling IRQ #28"
"disabling IRQ #29"

before the disaster occurs. Maybe it will help.

Cheers

Antonio

Markku Huotari (turkka80) wrote :

This one happens with Fujitsu-Siemens Amilo XA 2528. No luck with any version of Ubuntu (8.04, 8.10, 9.04, 10.04 or 10.10). It's also a no-go with Fedora, Zenwalk, Debian and Mint too, so I guess it's not related to distribution, but rather a kernel issue. I have a Nvidia nForce 430/410 Serial ATA controller, which I think is the problem here. No matter whether I try 32-bit or 64-bit.

delance (olivier-delance) wrote :

I saw two approaching bugs with casper package.

affects: linux (Ubuntu) → casper (Ubuntu)
Jon Loldrup (loldrup) on 2010-10-30
Changed in casper (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Walter Lapchynski (wxl23) wrote :

@delance, would love to test out the usb but i can't seem to get the basic steps taken care of to make the usb on me powerbook. the download page suggests to use hdiutil convert to change the .iso to an .img, but i keep getting an error 22 and can't seem to find any info about this. my concerns echoed here: http://ubuntuforums.org/showthread.php?t=1445659

adam1mc (adam1mc) wrote :

I had this problem with a brand new Dell T3500 64-BIT.

The problem was corrected by changing the Raid settings within bios.

System was setup for Raid, even though the basic windows install that came with the machine only had one drive configured (go figure)

Changed bios setting to Raid-ATA and issue was corrected.

Install with no problems.

Marcelo (mmtsales) wrote :

Same problem here when trying to install 10.10 with an USB stick on a Sony VAIO VGN-P688. I can install 9.10 on the same notebook with no problems using the same USB stick.

Marcelo (mmtsales) wrote :

I have just found out that I can boot 10.10 from a USB stick on the VAIO VGN-P688 if I enable the acpi=off option. This was not required to install 9.10 on this computer.

Ron Griffith (viajerozz) wrote :

I had same issue when booting Mint from USB stick. Changed the boot sequence in BIOS (did not work when I simply F9 to temporarily change boot order) to USB.

Chip Piller (piller) wrote :

I made an updated Lucid bootable USB flash drive that boots fine on one computer but gives the initramfs "unable to find a medium containing a live file system" error when I tried to boot it on an HP elitebook 8540p. After some googling I found a suggestion to try to boot from a different USB port and this worked. Booting from the right side USB port gives the error, booting from the left side USB port works correctly. It might have to do with having USB 3.0 and USB 2.0 ports and the ubuntu kernel driver. Also, booting from a DVD works fine on this machine.

berduchwal (marcin-maleccy) wrote :

I have the same issue. Tried 3 different usb sticks. Ubuntu 10.10 64bit. Toshiba Satellite Pro C650.
Changing BIOS settings with regard to HDD did not work.
Changing USB port did not work.

Fred B (fredbi) wrote :

Also have the same issue on ACER Aspire MC3641.

Also affects Fedora 13.
Same issue with USB stick.

BIOS American Megatrends v2.5, 05/23/2008 release

Also have Nvidia SATA controller like one of the above post.

Could boot with USB stick using DSL with kernel 2.4.

Fred B (fredbi) wrote :

Solved the issue by disabling ACPI management in BIOS.

See nvidia issue report on http://http.download.nvidia.com/XFree86/nforce/1.0-0306/KnownProblems.html

Hope this helps.

bayer (daniel-reichhard) wrote :

same problem here,

i have a sony vaio vpcf1, and booting ubuntu 10.10 from an usb drive gives me the "Unable to find a medium containing a live file system." error.

this also happens when i turn acpi off - so thats no fix for me.

i also get a lot of "/init: line 7: can't open /dev/sr0: No medium found" errors

Krastin Konstantinov (pixel4e) wrote :

I'm having the same exact issue (except my installation is i386 and my machine is Vaio P VGN-P610).

I've tried every possible thing:

Bios: [enable boot external]

Boot order: [external] [hard drive] [network boot]

Tried 2 different USB drives

Tried 2 different external CD drives

Tried 6 different downloads of both the desktop and netbook remix.

All downloads were checked with MD5SUM.

Ubuntu Desktop 9.10 installs properly in every version and from every source.

Getting reaaaally frustrated.

melaz (dmelanjin) wrote :

Also for same thing.
Sony Vaio VGN-P19VRN
Tried to change boot order
Tried to change usb stick
Tried to change usb port

Timofte Gheorghe (timofteghi) wrote :

I have a PC with WinXPsp3 installed, and I installed UBUNTU 10.10 Maverick using Universal-USB-Installer-1.8.3.7 on my USB stick Corsair 4GB.
I booted from my USB_stik using a bootable_CD with Plop_bootmanager on it and evrything was OK !!!!
I Shut_Down my computer and when I start it again and booted from my USB_stik I see the mesage:
( initramfs) unable to find a medium containing a live file system .
Solved:
Ctrl+Alt+Del and I restarted my computer.
Before that Windows run, I unplugged my USB_stik.
After Windows installed, I plugged my USB_stik and it copied some files ( syslinux etc. .....)
I booted again and it worked.

Timofte Gheorghe (timofteghi) wrote :

SORRY !!!
My USB_stick didn't copy any files, autoran.inf from it opened the autoplay window and the antivirus verified the files.
But what happens, because everytime when the message : ( initramfs) unable to find a medium containing a live file system,
is displayed, I repeated this method and it worked.
Did someone say something about that ???
would somebody please try this method ???

Timofte Gheorghe (timofteghi) wrote :

If you make a CD with the Plop_bootmanager on it , you can boot your computer from a USB_stick without change the boot sequences in BIOS
Choose the first boot = CDROM, the second = HDD an so on ....
When the computer boot from CDROM you will see a menu, choose boot USB.
Plop can boot from USB and the old computer witch have not in BIOS_menu a sequence USB-HDD .......
SEE:
http://www.plop.at/en/bootmanager.html

Timofte Gheorghe (timofteghi) wrote :

Boot from a USB_stick with UBUNTU 10.10 Maverick on it.
                      ========
( initramfs) unable to find a medium containing a live file system
I readed your comments and I verified the next suggestions one by one:
1. Disable ACPI from BIOS (it don't work for me)
2. Change the port for connection the USB_stick when start the computer ( it work for me !!!!! )
 CONCLUSION: each time when I start the computer I must change the port for my USB_stick and it's OK !!!

Justin (jjrweb3) wrote :

After several hours and with none of the fixes on the net helping me, I managed to sort this, so thought I'd share my experience.
For me, I was trying to install using CDRom. To make it work I swapped the jumpers on the CDRom drive to make that the master and my hard drive the slave.
Before I did that everything I tried gave me the "unable to find a medium containing ..." error.
I couldn't use the USB method on my pc (too old). Another thing to check is that the CD burn worked correctly (make sure you burn at reduced speed and check the option to verify after burning to make double sure).
Hope this helps someone.

John Haitas (jhaitas) wrote :

Ubuntu Natty Desktop amd64 daily iso 20110427.1 both regular and '+mac' versions booting into live mode

MacBook Pro 8,2 (thunderbolt)

work around is to boot with a usb thumb drive attached

description: updated
tags: added: iso-testing
Jafar Calley (jafar-3) wrote :

Sony Vaio X VPCX117LG

Got the same error trying to install 10.10 Maverick via USB stick.
Problem solved by selecting ACPI=off option at the USB stick's boot screen.

Nizar Kerkeni (nizarus) wrote :

Dell n5110
same error when trying to install oneiric (11.10) amd 64, alpha 1 from Live USB.

francesco visconti (satavtar) wrote :

Dell Vostro 3550
Intel HD Graphics

Nor the install nor the live boot procedure work, they both end up with the same message:
"(initramfs) Unable to find a medium containing a live file system"

I tried both via cd and usb, 32 or 64bit (I actually have an x64), and Ubuntu 10.04 LTS, 10.10, 11.04, Mint 11, OpenSuse 11.4.

Mint 11 pushes a kernel panic:
"No filesystem could mount root, tried ext4 ext3 ext2 fuseblk -
 Kernel panic: not syncing VFS: Unable to mount root fs on unknown block (104, 1)"

Guess it's a hardware problem, since I tried to use the cds on my old laptop (Dell Inspiron 6400) and everything was fine.

Evan Beeton (evanb) wrote :

Intel Z68 chipset & HD graphics
SATA 3.0 DVD drive & hard drive

CD installation fails on 32-bit 10.10 and 11.04 with same error message; discs have successfully installed on other machines. Fedora 15 also fails.

francesco visconti (satavtar) wrote :

Succeded with:

ubuntu 11.04 32bit
apci=off
pci=routeirq
and disableing a number of devices in the bios..

hutxubix (hutxubix) wrote :

Solved in the BIOS:

Settings -> Integrated Peripherials -> Sata Configuration -> Sata Mode -> (It was in IDE in my case) I changed it to AHCI and everything fine then

(also had a NVIDIA graphics card but do not know if it has anything to do with it)

Thanks everybody

kirkevonphilly (ksteffke) wrote :

In regards to Chip Piller's comment #17, I can confirm I was experiencing the same issue with a Toshiba Portege R835-P50.

I was trying to install Linux Mint 11 from a USB created with UNetbootin. I received the message when the USB stick was in the USB 3.0 port. Swapping it over to the 2.0 port allowed it to work fine.

why2jjj (why2jjj) wrote :

I ran into a similar issue that Chip Piller, comment #17 had. I also have a HP Elitebook 8540(w). Booting Ubuntu 11.04 via USB on the right side of the notebook gave me the exact same error; however, using the left USB port on the 8540 allowed me to boot the system successfully with a blank hard drive and then allowed me to install Ubuntu on that blank hard driver.

didadan (d-seitz) wrote :

Hey, I just resolved this issue on my new machine. Goto SATA Settings in your Bios and use AHCI instead of IDE.
Hope this works for you, too.

Changed in casper (Ubuntu):
importance: Undecided → Medium
tags: added: natty
Joeyboy (joeyboy) wrote :

I think there is a problem with booting from USB 3.0 ports - it boots into Busybox.
Using USB 2.0 ports, it boots into Ubuntu fine.

I have tested this so far with a full 11.04 install on a USB 3.0 stick.

I have seen this on 2 machines, each with both USB 3.0 and USB 2.0 ports:
Toshiba R850-14P
Lenovo W520

So I agree with these comments:
Chip Piller, comment #17
why2jjj (why2jjj), comment #37

Is anyone looking at this?

WSmart (wsmart) wrote :

@Justic Thanks for the post.

I had this issue trying to boot a Kubuntu 11.10 LiveCD on an old FlexATX computer which only has one IDE interface. Changing the jumpers on the CD to master and the hard drive to slave did resolve the issue. Oh look, there's Kubuntu now!

I also tried a bunch of other permutations of jumpers and cables, trying to keep the hard drive as master. Somewhere I read that you don't want a hard drive running with an optical on an IDE. But I know I've done it before without apparent issue. Maybe that was with the 40 pin cables. I finally gave up on that though. I guess I have to get a USB optical drive if I want my hard drive as master.

Thanks all.

Be real, be sober.

Cvetan Simsic (cvetan-simsic) wrote :

I got the same problem. Trying to install Ubuntu 10.04.4 64bit. This is the first time i had this kind of problem. Installed 10.04 a million times (32bit). I just got a new machine with 8 GB of RAM so i wanted 64 bit ubuntu.

Adam Stankiewicz (sheerun) wrote :

Got this error on newest MacBookPro9,2 trying to boot 64bit form from USB stick made by unetbootin. Unfortunately I don't know how to solve the problem. It certainly is connected with USB 3.0 port.

XriX (bubblehydro69) wrote :

My problem was Backtrack5 R3 (KDE & Knome X32(Both)) was dooing the same thing...."(initramfs) Unable to find a medium containing a live file system."

turns out it was because (yes looking back I know it was stupid)
My Bootloader (YUMI & EadyBDC was NOT recognizing my Intel Raid Storage Driver.... Specs aside I ended up using UNetbootin.....and holy shit it found my storage driver....booted into Backtrack 5R3 in KDE and Gnome Versions no problem.

Point being, If you have a problem booting into this via USB and have a 3rd party Storage driver installed (or Intel Raid/MB Raid driver installed) Try Unetbootin.... http://unetbootin.sourceforge.net/

By the way I am not running RAID, I just have the driver Installed... so I get the CTRL+I prompt EveryBoot to Setup RAID.

Intel Pentium D 3.0Ghz CPU
Intel D945GPM Motherboard ( Bios NT94510J.86A - 4131.EB)
2 GB DDR2 667Mhz (2x1GB sticks)

*Intel ICH7R/DH SATA RAID CONTROLLER*

WD640 (WD6401AALS)
Seagate 80GB (ST380815AS)
WD 250GB (WD2500YS)

thought I would share my problem... By the way it also did this with Trinity Rescue The newest to date

starkid (ladyquelambe-x) wrote :

Same problem trying to install 12.04 x64 on the second HD of a Dell XPS 17 laptop from USB.

1. checksum matches
2. tried setting all boot options at once, as well as edd=on by itself, as well as edd=on and acpi=off
3. tried all the usb ports (all but the far right boots into a blank screen)
4. SATA configuration was already set to AHCI in BIOS
5. boot order is USB, HD1, HD2, CD drive

starkid (ladyquelambe-x) wrote :

Whoops...I meant all but the far left usb port boots into a blank screen.

To post a comment you must log in.