During "Check disc for defects", error message changes screen mode

Bug #505281 reported by WeatherGod on 2010-01-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

Note, I am using the daily ISO build (Jan. 9, 2010) of Ubuntu-Netbook-Remix on my USB key (iso transferred using USB Startup Disk Creator).

While booted up from the USB key on my EeePC 1000, I tried to "Check disc for defects". The screen goes blank for a moment, and then a message comes up saying "Opening pipe: No such file or folder found". At this point, nothing else appears to be happening.

However, if one then use Ctrl-Alt-F8, you get back to the graphical screen which shows all sorts of activity and it finishes with no errors. Note that in this graphical mode, there are an entire screen's worth of messages showing tests of different parts of the filesystem, and no Ubuntu logo.

I tested the same process using the RC iso of Karmic, and it worked flawlessly. Also, it contained far fewer messages, and the logo remained on the screen.

I see two bugs here. 1) The failed pipe opening command. 2) The fact that the error message switched the screen to tty1, leaving users with the impression that nothing is happening.

Guntbert Reiter (guntbert) wrote :

Tested with a karmic iso under virtual box: nearly same behaviour (apart from two additional errors) - that means this bug is a bit older.
As weatherGod said: two bugs, but I believe (2) is the more serious one, because if something goes wrong the user is led to the assumption that nothing is happening.
2 attachments of the 2 VTs

WeatherGod (ben-v-root) wrote :

guntbert's screenshots are nearly identical to what I viewed using the Lucid iso. The only difference would be the two udev messages (they did not happen for me), and a couple of lines in the "complete checking" screenshot (like checking wubi.exe, which doesn't exist in my iso).

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2010-01-10
affects: ubiquity (Ubuntu) → casper (Ubuntu)
WeatherGod (ben-v-root) wrote :

As an update, casper in the latest ISO build no longer switches to the tty1 screen for the error messages (they are still there if you switch yourself), however, there are no progress messages getting to the graphical screen and the user has no idea if the process is completed or not unless they switch away from the graphical screen (to tty1 for example), and then switch back (resulting in just a text screen with all the appropriate progress messages.

Changed in casper (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers