regression: /etc/gdm/custom.conf messed up

Bug #500786 reported by Wolfgang Kufner on 2009-12-27
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Didier Roche

Bug Description

Binary package hint: casper

Readd for sponsoring:

casper (1.210) UNRELEASED; urgency=low

  * Readd scripts/casper-bottom/15autologin changes: derivatives have
    now a custom.conf file and still need autologin in live version.
    Merge with my previous fix proposed for sponsoring one week ago:
    use echo -e to enable \n interpretation (/bin/sh is busybox ash
    which behavior differs from vanilla ash interpretor) (LP: #500786)

--------------------
Lucid amd64 20091222.1 iso booted via grub loopback from hd was the first iso where I was presented with a login screen but could not login. 20091221 was the last iso with which I was able to get to the desktop just fine.

Today I looked at /etc/gdm/custom.conf and saw that it looked like this:
[daemon]\nAutomaticLoginEnable=true\nAutomaticLogin=ubuntu\nTimedLoginEnable=true\nTimedLogin=ubuntu\nTimedLoginDelay=10

when it should look like this:
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=ubuntu
TimedLoginEnable=true
TimedLogin=ubuntu
TimedLoginDelay=10

When I manually change it to that and "sudo restart gdm" it automatically logs in to the desktop just fine.

I am not an expert but when I looked around a bit this changelog entry aroused my suspicion:
Publishing details
Published on 2009-12-21
Changelog
casper (1.208) lucid; urgency=low

[...]

  [ Didier Roche ]
  * scripts/casper-bottom/15autologin: Don't erase /etc/gdm/custom.conf but
    only append autologin on casper startup if needed. This avoids removing
    default session set in this file for ubuntu derivatives which use GDM.
    The script also check if the modification is already there for
    persistent usb keys. (LP: #498971)
 -- Martin Pitt < <email address hidden>> Mon, 21 Dec 2009 15:54:36 +0100

It seems to fit the timing of the breakage exactly. Could you please take a look?

Hi Didier Roche

Could you please take a look?

Didier Roche (didrocks) wrote :

Thanks for testing Ubuntu and make it better.

You're right: the issue is that apparently /bin/sh uses bash and not dash in casper phases. So, -e option to echo has to be append to force \n interpretation.

I'm only a MOTU and desktop developer, I don't have write access to casper. So, I'm susbcribing sponsor team.

casper (1.209) UNRELEASED; urgency=low

  * scripts/casper-bottom/15autologin: use echo -e to enable \n
    interpretation (/bin/sh uses bash and not dash in casper) (LP: #500786)

Changed in casper (Ubuntu):
status: New → Triaged
importance: Undecided → High
Didier Roche (didrocks) wrote :

Just a short notice to sum up that it's ash and not bash that is used in casper phases.

casper (1.209) UNRELEASED; urgency=low

  * scripts/casper-bottom/15autologin: use echo -e to enable \n
    interpretation (/bin/sh is ash and not dash in casper) (LP: #500786)

Thierry Carrez (ttx) on 2010-01-05
Changed in casper (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: Triaged → In Progress
Thierry Carrez (ttx) wrote :

@Didier: Evan recently published a 1.209 reverting your change, could you have a look at it ? Please resubscribe sponsors (or ping me) if you still need something uploaded.

Changed in casper (Ubuntu):
assignee: Thierry Carrez (ttx) → Didier Roche (didrocks)
status: In Progress → Incomplete

Lucid amd64 20100105 iso booted via grub loopback from hd logged automatically into the desktop just fine, unsurprisingly, with casper 1.209.

@Didier
Thanks for your fast response, however this pans out.

Didier Roche (didrocks) wrote :

Readd new version for sponsoring has derivatives have no more autologin.

casper (1.210) UNRELEASED; urgency=low

  * Readd scripts/casper-bottom/15autologin changes: derivatives have
    now a custom.conf file and still need autologin in live version.
    Merge with my previous fix proposed for sponsoring one week ago:
    use echo -e to enable \n interpretation (/bin/sh is busybox ash
    which behavior differs from vanilla ash interpretor) (LP: #500786)

description: updated
Changed in casper (Ubuntu):
status: Incomplete → Triaged
Thierry Carrez (ttx) on 2010-01-05
Changed in casper (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
Martin Pitt (pitti) wrote :

Thanks Didier, merged

Changed in casper (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.211

---------------
casper (1.211) lucid; urgency=low

  * Readd scripts/casper-bottom/15autologin changes: derivatives have
    now a custom.conf file and still need autologin in live version.
    Merge with my previous fix proposed for sponsoring one week ago:
    use echo -e to enable \n interpretation (/bin/sh is busybox ash
    which behavior differs from vanilla ash interpretor) (LP: #500786)
 -- Didier Roche <email address hidden> Tue, 05 Jan 2010 20:05:26 +0100

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released

This bug has risen from the dead with casper 1.212. Checked by booting todays daily lucid 64 bit iso 20100109 via grub2 loopback.

Changed in casper (Ubuntu):
status: Fix Released → Fix Committed
Didier Roche (didrocks) wrote :

Yes, this version gives that regression I opened a new bug (it's better) and subscribed you to it: bug #505140

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers