casper-md5check needs to be ported to plymouth

Bug #500198 reported by wpshooter on 2009-12-24
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Steve Langasek
Lucid
High
Steve Langasek

Bug Description

Why do I get "Opening pipe: No such file or directory", when attempting to run a check CD for defects function on the Lucid daily build 32 bit desktop version ? I have tried this several days running on the daily builds that are available and this continues to happen.

After this message is displayed NOTHING else happens. The integrity check function does not continue and eventually the message disappears from the screen and I then have to reboot the computer.

Thanks.

Related branches

Erick Brunzell (lbsolost) wrote :

I can verify this, also the 12/23 and 12/24 Live CD's boot to a login window and nothing appears to let it actually boot.

I'll report that in a new bug report. I'm marking this Confirmed.

Changed in ubuntu:
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

Somewhat more specifically when trying to run the CD integrity test I get this:

stdin: error 0
/init: line 7: can't open ?dev/sr0: No medium found
/init: line 7: can't open ?dev/sr0: No medium found
Opening pipe: No such file or directory

Alt > SysReq > B reboots.

Also the Live CD fails to boot to Live Desktop but rather boots to a login window. I've tried everything imaginable to continue to the Live Desktop and nothing seems to work. I'll file a separate bug report about that.

If the two are related trying to boot to Live Desktop shows almost the same with:

Shadow passwords are now on.

I have checked md5sums and I've tried different drives, other Live Cd's work fine.

sparker256 (bgood) wrote :

I can verify that as of 122609 daily build i386 I am getting the same errors as Erick. The last live cd that would boot correctly was daily build 121609.

Bill

Murat Gunes (mgunes) wrote :

Setting cdrom-checker as affected.

affects: ubuntu → cdrom-checker (Ubuntu)
Terry Jones (terryjones28056) wrote :

I can confirm the same thing is happening on daily cd 1-9-10 and 1-10-10.
I have downloaded from Lucid 2 times on 1-9-10 and Karmic (dual boot) on 1-10-10.
On the Lucid cd, I get the same error along with stdin; error 0. On the Karmic download , I get I/O error. None of the three cd burns are any good.

Changed in cdrom-checker (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Incomplete
Erick Brunzell (lbsolost) wrote :

Just performing Lucid pre-alpha 2 iso testing and Check CD for defects fails to complete. Attempted in both default and safe graphics mode, it just never displays any results.

The live CD does however run fine for me in safe graphics mode so this is IMHO a minor issue. Not enough of a reason to give the iso test a fail.

Disc: http://cdimage.ubuntu.com/daily-live/20100112.1/lucid-desktop-i386.iso
md5sum f080fdc16f1232e4b3fcffd26a7a36fa

Will now continue with iso installation tests.

Erick Brunzell (lbsolost) wrote :

I should have added that I no longer get the "Opening pipe: No such file or directory".

The test just never displays any results.

tags: added: iso-testing
Charlie Kravetz (charlie-tca) wrote :

I can confirm this on Xubuntu also. I do get "Opening pip: No such file or directory" when checking Alt+F1 for messages. The cd check gives me a blank screen which apparently is hung someplace. It is impossible to determine if the check is proceeding at all, and the system must be restarted to continue with using / installing the live cd.

Xubuntu lucid-desktop-i386.iso dated 2010-01-12.1

Erick Brunzell (lbsolost) wrote :

"the system must be restarted to continue with using / installing the live cd."

Yes, I forgot to mention that. Have to Alt + SysReq + B.

I did however complete three successful installations and encountered no additional problems with the 1386 Live CD.

Linard Verstraete (linardv) wrote :

*** System ***
Hardware: Dell Vostro 1500.
Xubuntu Lucid Alpha 2 - 2010-1-12.2

I don't get the "Opening pipe..."-message and it seems that the disk does get checked, there is only no interaction with the user.

If I run the checker with default boot options, I get a black-screen, and it starts to check my disk for 4m30s. After that my CD spins-down due the checking-process is complete. But it doesn't respond to any keystroke to reboot the system. I have to use Ctrl+Alt+Del (Alt+SysReq+B, doesn't seem to work).

If I compare this with the behavior of the 9.04 release, I got an visual progress-bar, and it starts to check my disk for 4m30s (did 2 stopwatch tests, both for 9.04 and 10.04). After that my CD spins-down due to the checking-process is complete. Response to a keystroke and system rebooted.

If I run the checker without the options "quiet splash", I see that the console-output gets interrupted around the line:
"ACPI: Video Device [VID] ...", bright flash, cleared screen, and continuation of output on
"Console: switching to colour frame buffer ..."
Maybe this is related to having no visual feedback with the splash option? I didn't had that small interruption on the 9.04. Aside from that output seems similar to 9.04 aside from usual differences (squashfs 4.0 vs. squashfs 3.3, ...).

So my guess is that the checking of the CD still works, but the visualization and keyboard-listing is somehow broken...

Erick Brunzell (lbsolost) wrote :

Identical results as yesterday with:

http://cdimage.ubuntu.com/daily-live/20100113/lucid-desktop-i386.iso

MD5Sum : 4bfe7145072fa01a7e0643db5999a17a

Everything else seemed to work just fine.

description: updated
Changed in cdrom-checker (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → High
Colin Watson (cjwatson) on 2010-01-20
affects: cdrom-checker (Ubuntu Lucid) → casper (Ubuntu Lucid)
Colin Watson (cjwatson) on 2010-01-20
summary: - opening pipe: no such file or directory
+ casper-md5check needs to be ported to plymouth
Changed in casper (Ubuntu Lucid):
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2010-01-27
Changed in casper (Ubuntu Lucid):
assignee: nobody → Steve Langasek (vorlon)
Erick Brunzell (lbsolost) wrote :

I'm sure this is no surprise but I'm just doing pre-alpha 3 iso testing with the i386 Live CD and the integrity test still produces no results.

There are no errors, just no results. Disc md5sum: 01801b0b87669fdcd75fe8d827dac364

Steve Langasek (vorlon) on 2010-03-03
Changed in casper (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
Steve Langasek (vorlon) wrote :

A prelim port of casper-md5check to plymouth has been committed to bzr. It's not elegant, but it should do the job.

Changed in casper (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.227

---------------
casper (1.227) lucid; urgency=low

  * casper-md5check: port from usplash to plymouth. LP: #500198
  * fix up our reliance on usplash, /dev/console elsewhere. LP: #506418.
 -- Steve Langasek <email address hidden> Fri, 12 Mar 2010 01:12:28 -0800

Changed in casper (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers