integrity-check user interface broken karmic

Bug #434980 reported by Michael Fletcher on 2009-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: casper

When I run the integrity-check on either Karmic Alpha 6 or the September 22, 2009 nightly LiveCD all I see is the message 'stdin: error 0\nOpening pipe: No such file or directory' when I attempt to run the integrity-check (Check disc for defects). This used to work on Jaunty. I have observed this on a physical machine as well as a VirtualBox machine.

If I switch to virtual terminal 8 I can see that the integrity check completed successfully.

I am booting from a 1GB USB stick on the physical machine and an emulated cdrom on VirtualBox. This ISO md5sum's correctly.

I have attached screenshots of virtual terminal 1 and virtual terminal 8.

Colin Watson (cjwatson) wrote :

This is because usplash is turned off. We need to make casper declare that it needs usplash.

tags: added: regression-potential
Changed in casper (Ubuntu Karmic):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.194

---------------
casper (1.194) karmic; urgency=low

  * Fix 47unr_ubiquity shell code to make slightly more sense.
  * Tell mkinitramfs that casper needs usplash (LP: #434980).

 -- Colin Watson <email address hidden> Thu, 24 Sep 2009 01:29:21 +0100

Changed in casper (Ubuntu Karmic):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers