remove /var/lib/dbus/machine-id from installed image

Bug #322830 reported by Colin Watson on 2009-01-29
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-server-iso-testing
High
Jean-Baptiste Lallement
casper (Ubuntu)
Critical
Unassigned
dbus (Ubuntu)
Medium
Unassigned
live-build (Ubuntu)
Critical
Adam Conrad
livecd-rootfs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: livecd-rootfs

Havoc Pennington reported that /var/lib/dbus/machine-id needs to be unique across instances of the running live CD, and between installed systems. The simplest way to ensure this is to remove it from the live filesystem.

We do have an upgrade problem, though; a number of people will have installed from previous versions of the live CD and will have duplicated machine-ids, although we can't feasibly identify the list of machine-ids involved (and it would be huge). I'm opening a task on dbus as well to figure out how to do something about it on upgrade. Maybe the answer is that everyone should have their machine-id forcibly regenerated on the first boot after upgrading to some nominated version of dbus?

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 0.77

---------------
livecd-rootfs (0.77) jaunty; urgency=low

  * Remove the D-Bus machine identifier from the livefs; it needs to be
    unique, and it's generated at boot time if it's missing (LP: #322830).

 -- Colin Watson <email address hidden> Thu, 29 Jan 2009 17:21:23 +0000

Changed in livecd-rootfs:
status: New → Fix Released

We never took a decision that, and missed the release boat.

Should we still forcibly change everyone, or just close this bug now?

Changed in dbus (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
dino99 (9d9) wrote :

In Lucid testing:

got problems with dbus & dbus-x11: miss dependencies but don't know which ones, maybe false warnings or not real raisons.
So trying to reinstall those packages in a chrooted space, i fail again saying partial installation.

Removing then reinstalling those packages + ubuntu-desktop to get back all the additional removed packages, i've had a lot of warnings and many packages failed to install : dbus, polycykit, ...

because of : /var/lib/dbus/machine-id ( running: dbus-uuidgen > /var/lib/dbus/machine-id don't resolve it)

dino99 (9d9) wrote :

outdated now, this issue is gone for ages

Colin Watson (cjwatson) wrote :

This has recurred in Oneiric due to the switch to live-build. :-(

Colin Watson (cjwatson) on 2011-10-12
Changed in live-build (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Adam Conrad (adconrad)
Changed in ubuntu-server-iso-testing:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jean-Baptiste Lallement (jibel)
Colin Watson (cjwatson) on 2011-10-12
Changed in casper (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Critical
status: New → In Progress
Jean-Baptiste Lallement (jibel) wrote :

Added a task for "ubuntu-server-iso-testing" to add a regression test to the daily ISO testing.

Colin Watson (cjwatson) wrote :

casper needs to generate the machine-id early on, otherwise a few things it does (such as removing the screensaver lock with gsettings) fail.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-build - 3.0~a24-1ubuntu17

---------------
live-build (3.0~a24-1ubuntu17) oneiric; urgency=low

  * Remove /var/lib/dbus/machine-id in lb_chroot_hacks to prevent every
    machine installed from our media having the same ID. This is a
    regression from the previous livecd-rootfs behaviour (LP: #322830)
 -- Adam Conrad <email address hidden> Wed, 12 Oct 2011 12:11:16 +0100

Changed in live-build (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-server-iso-testing:
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

We decided not to make casper generate machine-id after all, because nothing in casper should be relying on dbus being running. Instead, these fixes dealt with the fallout:

casper (1.287) oneiric; urgency=low

  * Remove typo from 26disable_user_menu that led the script to
    believe that indicator-session was never actually installed.

 -- Adam Conrad <email address hidden> Wed, 12 Oct 2011 14:00:48 +0100

casper (1.286) oneiric; urgency=low

  * Convert the gsettings calls to using the gsettings override files
    because we don't have DBUS in casper.

 -- Stéphane Graber <email address hidden> Wed, 12 Oct 2011 13:38:53 +0100

Changed in casper (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
status: In Progress → Fix Released
Changed in ubuntu-server-iso-testing:
status: Fix Committed → Fix Released
Changed in dbus (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers