casper boot=nfs ipconfig: eth0: SIOCGIFINDEX: No such device

Bug #296089 reported by Marcin Woloszyn on 2008-11-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: casper

I'm trying to PXE boot LiveCD Ubuntu Intrepid 8.10 or Hardy 8.04.1 with no success so far.
Running installer through PXE works perfectly.

vmlinuz and initrd.gz from /casper directory (ubuntu-8.10-desktop-i386.iso) boots, but stops at:
(initramfs)

(initramfs) cat casper.log
Begin: Running /scripts/casper-premount ...
Done.
Done.
ipconfig: eth0: SIOCGIFINDEX: No such device
ipconfig: /tmp/net-eth0.conf: SIOCGIFINDEX: No such device
ipconfig: no devices to configure
Begin: Trying netboot from 192.168.2.15:/pxe/nfs ...
Begin: Trying nfsmount -o nolock -o ro 192.168.2.15:/pxe/nfs /cdrom ...
connect: Network is unreachable
connect: Network is unreachable
NFS over TCP not available from 192.168.2.15
connect: Network is unreachable
connect: Network is unreachable
NFS over TCP not available from 192.168.2.15
[...]

Problem seems to occur at do_netmount() (line 168) in /scripts/casper
have no idea how to bring eth0 up. There is no eth0 in /dev/ directory.
I'm stuck. Please help.

kvm used: /usr/bin/kvm -S -M pc -m 512 -smp 1 -name test -monitor pty -no-reboot -boot n -drive file=/home/nme/test.img,if=ide,index=0 -net nic,macaddr=00:16:36:11:d7:8f,vlan=0,model=virtio -net tap,fd=11,script=,vlan=0,ifname=vnet1 -serial pty -parallel none -usb -vnc 127.0.0.1:0

Marcin Woloszyn (dervsh) wrote :

Ok, I managed to get it working for me now.

Problems seems still exist in casper / kvm-pxe packages.

I'm using virt-manager, I followed instructions in https://bugs.launchpad.net/ubuntu/+source/kvm/+bug/193531

Mine solution:

    <interface type='bridge'>
      <mac address='00:16:36:11:d7:8f'/>
      <source bridge='br0'/>
      <target dev='vnet1'/>
      <model type='virtio'/>
    </interface>

i had to replace model to:

      <model type='rtl8139'/>

And it worked. eth0 was discovered and Gnome environment has loaded.

I had problems with:

- e1000 didn't get through PXE boot (it was unable to read informations from DHCP server, altrough server was passing it by DHCPOFFER)

- ne2k_pci - hanged right after:
[ 173.281745] pan0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
                                                                                                                             [ OK ]
 * Starting GNOME Display Manager...

after that host stopped to answer (tcpdump reported only ARP whois for virtual machine from host server).

gcc (chris+ubuntu-qwirx) wrote :

For anyone who is trying to do this (for example to get a reproducible clean environment for testing purposes) and missing the essential steps, they are:

* set your DHCP server up to hand off to a TFTP server. For example, add the following lines to your subnet definition in /etc/dhcp3/dhcpd.conf:

        next-server 10.0.156.34;
        filename "pxelinux.0";

* get a copy of pxelinux.0 from the pxelinux package and put it in the tftproot of your TFTP server.

* copy the casper directory off the CD and put it into your tftproot as well.

* get an NFS server on your network to loopback-mount the Desktop ISO (e.g. ubuntu-8.04.2-desktop-i386.iso) and export the mount directory through NFS. Let's say your NFS server is 1.2.3.4 and the ISO is mounted at /var/nfs/ubuntu/live. Edit /etc/exports on the server and export the mount directory to the world by adding the following line:

/var/nfs/ubuntu/live *(ro,all_squash,no_subtree_check)

* put the following section into your tftproot/pxelinux.cfg/default file:

DEFAULT live-804
LABEL live-804
  kernel casper/vmlinuz
  append file=/cdrom/preseed/ubuntu.seed boot=casper initrd=ubuntu/ubuntu-8-04/casper/initrd.gz netboot=nfs nfsroot=1.2.3.4:/var/nfs/ubuntu/live quiet splash --

* test that the PXE client boots into the live CD environment

* if it doesn't, remove the "quiet splash" from the end of the "append" line and boot it again, to see where it gets stuck.

I hope this helps someone, and that NFS-booting a live environment will be properly documented one day.

Mass-Yas (massyas) wrote :

Same problem here with a Toshiba Satellite T130-15T (Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10))
The PXE live boot (Ubuntu 10.04 Lucid CD) worked on my eeePC 901 so the problem seems to be related to the material.

tags: added: netboot
Changed in casper (Ubuntu):
importance: Undecided → Medium
Ken Sharp (kennybobs) wrote :

This appears to be fixed in Oneiric

Fabio Marconi (fabiomarconi) wrote :

Hello
If someone still affected by this problem is pleased to reset the status to new.
Thanks
fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in casper (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers