Everything is unexplainedly slower from live CD than from hard disk

Bug #287599 reported by Matthew Paul Thomas on 2008-10-22
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Wishlist
Unassigned

Bug Description

Ubuntu Intrepid daily live, 20081022
Ubuntu Natty alpha 3

From the startup process onward, everything you do with an Ubuntu live CD is much slower than the same thing in Ubuntu installed on a hard disk.

People who have not used Ubuntu before may not realize that the slowness is because of the CD, and may think Ubuntu is just very slow in general and therefore not worth using.

One way of addressing this would be to add an explanatory sentence to the startup screen whenever Ubuntu is started from a CD. (Something like, "Ubuntu is slower when running from a CD.")

Another way would be to add an extra animation (perhaps a picture of a slowly spinning CD) to the startup screen when starting up from an optical disc.

Elias K Gardner (zorkerz) wrote :

I think this makes alot of sense. A particularly good place in my opinion would be the ubuntu loading screen just as startup begins. If a sentence was put under the loading bar say something like the ubuntu live cd is loading this will not write any data to your hardrive, however, it may be unusually slow due to the relatively slower read speed of a cd drive in comparison to your hardrive.

I will mark this confirmed.

Changed in usplash:
status: New → Confirmed
Kees Cook (kees) on 2009-02-07
Changed in usplash:
importance: Undecided → Wishlist
Evan Broder (broder) wrote :

Are applications on the CD actually slower? My experience is that using the Live CD is slow, but that's because the CD drive spins down very frequently, creating a multi-second delay whenever an application tries to access something on the CD.

Could this be solved by keeping the CD drive from ever spinning down?

Patrick (veinor) wrote :

How would never spinning down the CD affect battery life? And would that make that much of a performance difference in the first place?

tags: added: iso-testing
Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: Confirmed → Invalid
affects: usplash (Ubuntu) → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: Invalid → New
description: updated
Steve Langasek (vorlon) wrote :

This has nothing to do with plymouth anyway, plymouth is just an i/o system. If we want to display a message at boot time on the livecd, then some package that knows this *is* a liveCD needs to do this. Reassigning to casper.

affects: plymouth (Ubuntu) → casper (Ubuntu)
Changed in casper (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers