Ubuntu

[hardy] livecd: keyword "persistent" results in busybox and (initramfs)

Reported by Kenneth Mokkelbost on 2008-04-18
46
Affects Status Importance Assigned to Milestone
casper (Baltix)
Undecided
Unassigned
casper (Ubuntu)
Low
Unassigned
Hardy
High
Evan Dandrea
Intrepid
Low
Unassigned

Bug Description

When trying to boot a livecd with the persistent keyword the boot process fails and all I get is busybox. Booting without "persistent" works fine.

Has persistent mode been dropped as a feature on the livecd or is this a bug?

Tried on daily-live 17042008-image.

Kenneth Mokkelbost (kmokk) wrote :

Also affects rc build

Tobias Gruetzmacher (tobix) wrote :

Still in the final. The initrd tries to mount the casper-rw with mode=755, which fails when casper-rw is ext2/ext3. Removing mode=77 from the initrd makes it work again...

I can confirm that this bug exists, and I concur with Tobias Gruetzmacher that the cause is the 'mode=' mount option in the casper script.

The fix is to unpack the initrd.gz file, edit the file 'scipts/casper' (to remove the 'mode=755' from the mount cowdevice line for the persistent case - see below), and repack the initrd.gz.

It looks to me as if the 'mode=755' was added as a mount option for the default tmpfs case ('mode' is a valid mount parameter for tmpfs), without regard to its impact on the ext2/3 case (i.e. when mounting the persistent casper-rw partition). Obviously 'mode' is not a valid parameter for mounting ext2/3 filesystems.

I'm not sure why the 'mode=' option was added for the tmpfs case for live (non-persistent) boot, but if there is a good reason, I suggest that the permanent fix be something like this, so that both modes work as expected:

392 cowdevice="tmpfs"
393 cow_fstype="tmpfs"
394 cow_mountopt="rw,noatime,mode=755"
395
396 # Looking for "${root_persistence}" device or file
397 if [ -n "${PERSISTENT}" ]; then
398 cowprobe=$(find_cow_device "${root_persistence}")
399 if [ -b "${cowprobe}" ]; then
400 cowdevice=${cowprobe}
401 cow_fstype=$(get_fstype "${cowprobe}")
402 cow_mountopt="rw,noatime"
403 else
404 [ "$quiet" != "y" ] && log_warning_msg "Unable to find the persistent medium"
405 fi
406 fi
407
408 mount ${cowdevice} -t ${cow_fstype} -o ${cow_mountopt} /cow || panic "Can not mount $cowdevice on /cow"
409

This is a very straightforward fix without any side effects (so it seems to me there's no reason why it shouldn't be rolled into the point-release version of Hardy due in July IMHO).

I've implemented this fix for a persistent live USB flash thumb drive product which my company sells, and I can confirm that it works like a charm.

Mario Limonciello (superm1) wrote :

I can confirm that this proposed fix resolves the persistent issue.

Changed in casper:
status: New → Confirmed
Evan Dandrea (ev) wrote :

FWIW, I added mode=755 for the following reason. Sorry for the unfortunate side effect of that change.

  [ Evan Dandrea ]
  * Add mode=755 to the tmpfs mount that becomes / in the unionfs mount
    so that / in the live filesystem does not end up with 777 permissions
    (LP: #206030).

 -- Evan Dandrea <email address hidden> Wed, 26 Mar 2008 14:47:06 -0400

psypher (psypher246) wrote :

I am still having this issue on the proper hardy release. please can someone post the correct commands to unpack and pack the initrd.gz file AND a full copy or a working casper file for me to compare. simply removing the only reference to mode=755 in the file (i find only one) defenitely does not fix this. I have been trying for 3 days now to get this working. Also when i use gzip -dc initrd.gz | cpio -i to unpack and immediatly use find * | cpio -o -H newc | gzip -c9 > intrd.gz to repack I get different file size from the original initrd.gz. Am I using these commands correctly?

Thanks

Mario Limonciello (superm1) wrote :

psypher, you may consider taking casper-new-uuid out of the Hardy package, and using that to repack your file. It is normally used to re-generate UUIDs, but in this case may be adapted to instead swap out a file.

Changed in casper:
milestone: none → ubuntu-8.04.1
psypher (psypher246) wrote :

i'll give it a try. commands to repack??

psypher (psypher246) wrote :

ok just tried for the 100'th time to build and still i get busybox. As far as I can tell i followed the instructions above perfectly. Either way I thought that just deleting mode=755 should fix this? is there a way to tell why I am getting dropped into busybox. maybe this isn't the reason for my issues. Please help I am at wits end. I've tried google, the forums, the guys on IRC, nothing can get me to a really simple live hardy with persistence. Where am i going wrong???

psypher (psypher246) wrote :

ok I found my problem. now that I fixed the casper file I by accident left the original live cd connected in vmware while booting the custom live system from the virtual disks. Now the OS boots up AND persistence works. BUT i have to have the cd in? Why would this happen, somewhere casper is set to look for the squashfs file on the cd instead of the drive in the casper file, despite the fact that I setup grub properly and the menu.lst. Alternatively, can anyone point me to a really good live cd howto that would apply to hardy but which uses grub as a bootloader instead of syslinux?
Thanks!

FlipsideTech (ryan-flipside) wrote :

Attached is a new initrd.gz with the bug removed.

Vincent (vinnl) wrote :

Thanks Dafydd, your method solved the problem for me. For some reason though, I have to eject the floppy disk that contains GRUB for my normal installation when I want to boot from my USB flash drive. This never was an issue before.

Let's get this fix in as soon as possible :)

mikeXYZ (qmikeq) wrote :

psypher: “... can anyone point me to a really good live cd howto that would apply to hardy but which uses grub as a bootloader instead of syslinux?”

I use GRUB in building all my UFDs. Not an expert, but I do it and write up a how-to for others. I'm currently updating this for Hardy, but it's exactly what I used for HH 8.04 except I edited the file scripts/casper to delete the string
mode=755
from the one line it appears in, and it works (so far).
Here's my how-to (soon to be updated for 8.04 & this bug):
http://kubuntuforums.net/forums/index.php?topic=3089474.0
See Reply #7—persistence
(Please send questions to me through PM, not in the how-to; it keeps the how-to's cleaner and there's some discussion on that at K :) ).

more ...
http://t-skariah.blogspot.com/2008/04/ubuntu-804-hardy-heron-on-usb.html
(and his link to pendrivelinux for methods)

Vincent (vinnl) wrote :

Oh, psypher, you might also want to look at http://ubuntuforums.org/showpost.php?p=2893694&postcount=133 , which is a method to convert an existing persistent drive from syslinux to GRUB.

Vincent (vinnl) wrote :

By the way, for those looking to make Xubuntu persistent, I've attached the initrd.gz I'm using right now.

Truman (almacenextra2) wrote :

A newbie needs your help! I installed USB Ubuntu following these steps:

http://www.pendrivelinux.com/2008/05/08/usb-ubuntu-804-persistent-install-via-the-live-cd/

but I had this problem so I did everything again using FlipsideTech's initrd.gz (is this actually working?) and I had the same problem. Any ideas? If it's the initrd.gz, could somebody please upload one that works.
Thanks!

I tried to make a stick with the latest Hardy 64 version and I also copied the modified initrd.gz file saved at http://launchpadlibrarian.net/13998650/initrd.gz
to my stick. But the Busybox shows up again. This time saying: "Beginn. Starting to mount the root system..."

What is next?

I'm using the new initrd that was posted here and got it to work. But the problem is it only works when it wants to! Sometimes it just doesn't want to boot up and gives a hell of a lot of file error while starting up, or the persistency disappears. One of the directories that I'm suppose to be copying to my flash drive is the disctree directory. But I don't have that. It is not on the CD. Am I the only one with this problem?

Also, once this actually works, will I be able to put files on the flash drive home directory to use when I run Ubuntu from it?

Thanks.

mikeXYZ (qmikeq) wrote :

I don't know the extent this would help you guys, but ...

Short version: I (and others, but not everyone) found that to make this work best, and specifically to ensure persistence, it helps to use ext3 for the casper-rw partition (and I have used ext3 for both partitions this time with 8.04: the root partition kubuntu804 and casper-rw). (I first got the tip from K0LO @ Kubuntu forums.)

Here's the notes on that, as well as other workarounds:
https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/125702

(do this, in addition to fixing the bug we are talking about here with BusyBox)

Thanks Mike.

I used these commands to format the partitions:

sudo mkfs.vfat -F 32 -n ubuntu /dev/sdX1
sudo mkfs.ext2 -b 4096 -L casper-rw /dev/sdX2

What commands do I use to make it bouth ext3?

mikeXYZ (qmikeq) wrote :

I use GParted Live CD to partition and format everything :)
(haven't used CLI for such for a long time, but I'm sure someone here does)

Nick_C (nick-chadwick-it) wrote :

Vincent;

I can confirm that the initrc.gz file you submitted fixes this issue (at least for me) when using Xubuntu 8.04

Thankyou!

crakarjax (rjbrennn) wrote :

Vincent;

Your initrd.gz didn't work for me. I'm using the same USB stick I had used to get 7.10 persistant. How would one tell if persistance is working, besides rebooting?

~RjB

crakarjax (rjbrennn) wrote :

btw Vincent, you left a little surprise in your initrd.gz ;)

Vincent (vinnl) wrote :

Did I? Either I did it consciously but forgot about it, or it wasn't me :P

I suppose you can only tell if persistence works is by making a change and see if it is preserved after a reboot. The main problem that should be solved by the initrd.gz is that it won't boot up, as far as I can understand. I only created the initrd.gz with the instructions on this page, so don't consider me an expert ;-)

Steve Langasek (vorlon) on 2008-05-22
Changed in casper:
importance: Undecided → Low
status: New → Confirmed
importance: Undecided → Low
milestone: ubuntu-8.04.1 → none
crakarjax (rjbrennn) wrote :

...I followed the guide at pendrivelinux.com ... strangely, the syslinux.cfg DID NOT have all /cdrom tags removed, as I have seen in other guides. Perhaps this is where I was going wrong.

DEFAULT /casper/vmlinuz
GFXBOOT bootlogo
APPEND file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
LABEL persist
  menu label ^Run Xubuntu saving changes persistently
  kernel /casper/vmlinuz
  append file=/cdrom/preseed/xubuntu.seed boot=casper persistent initrd=/casper/initrd.gz quiet splash --
LABEL live
  menu label ^Try Xubuntu without any change to your computer
  kernel /casper/vmlinuz
  append file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.gz quiet splash --
LABEL live-install
  menu label ^Install Xubuntu
  kernel /casper/vmlinuz
  append file=/cdrom/preseed/xubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.gz quiet splash --
LABEL check
  menu label ^Check CD for defects
  kernel /casper/vmlinuz
  append boot=casper integrity-check initrd=/casper/initrd.gz quiet splash --
LABEL memtest
  menu label Test ^memory
  kernel /install/mt86plus
  append -
LABEL hd
  menu label ^Boot from first hard disk
  localboot 0x80
  append -
DISPLAY isolinux.txt
TIMEOUT 300
PROMPT 1
F1 f1.txt
F2 f2.txt
F3 f3.txt
F4 f4.txt
F5 f5.txt
F6 f6.txt
F7 f7.txt
F8 f8.txt
F9 f9.txt
F0 f10.txt

Changed in casper:
assignee: nobody → evand
importance: Low → High
ArafatMedini (arafato) wrote :

could somebody please take care of this bug..
Its a very useful feature and for me nearly essential as I must use different pcs.

Greg (gregory-ladret) wrote :

Oh yes please fix that bug.

It would be great.

Thanks a lot for the huge work you do everyday for Ubuntu...

Vincent (vinnl) wrote :

You guys do know that a workaround has been posted above, right?

jimmy smith (timmy-lea) wrote :

Does anybody know if this is definitely going to be fixed in the 8.04.1 install CD, due soon?

Devs -- can you confirm?

  • unnamed Edit (255 bytes, text/html; charset=ISO-8859-1)

that would be great!

I was reading through the thread yesterday.. I got lost..
There are at least 2 initrd.gz packs and a dozen of instructions..
I want simply to use the distro with a usb stick! Not to feel ashamed about
my ignorance ;)

Vincent (vinnl) wrote :

Arafat, it's quite simple actually. Just complete the steps you'd complete normally to run Ubuntu from a USB stick, and then replace the initrd.gz on your USB stick with the one posted above (one is for Ubuntu, the other for Xubuntu). That's it - bug solved/worked around :)

(The instructions were on how to create your own initrd.gz but since other people did that for you that's not necessary)

jimmy smith (timmy-lea) wrote :

Vincent: Arafat, it's quite simple actually. Just complete the steps you'd complete normally to run Ubuntu from a USB stick, and then replace the initrd.gz on your USB stick with the one posted above (one is for Ubuntu, the other for Xubuntu). That's it - bug solved/worked around :)

Actually, I tried swapping-in FlipsideTech's replacement and didn't get persistence. I also added the word "persistence" to the boot config file, but still didn't get it.

ArafatMedini (arafato) wrote :
  • unnamed Edit (168 bytes, text/html; charset=ISO-8859-1)

All the pcs I'm using can't boot directly from USB so I need to use the boot
CD.
I guess I need to unpack the ISO change the initrd and repack it again.

Craig Hewetson (craighewetson) wrote :

Evan, Can we assume that this bug will be fixed (in hardy)? I see that its assigned to you.
The workaround is nice and easy but shouldn't be considered as a fix.

ArafatMedini (arafato) wrote :

I tried the whole night to get a bootable iso. No no..
For me it's still a bug.
Anyway I didn't succeed, I am frustrated and this is not a workaround.
mounting an iso, unpacking a cpio file packing it again and trying to
figure out how to make a bootable iso with a buggy mkisofs.. WTH!! As
usual countless googling and boards to gather the information..
Lost one nights sleep for nothing :(

2008/6/22, Craig Hewetson <email address hidden>:
> Evan, Can we assume that this bug will be fixed (in hardy)? I see that its
> assigned to you.
> The workaround is nice and easy but shouldn't be considered as a fix.
>
> --
> [hardy] livecd: keyword "persistent" results in busybox and (initramfs)
> https://bugs.launchpad.net/bugs/219192
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Vincent (vinnl) wrote :

Arafat, why are you mounting an iso and stuff? Which procedure have you followed for previous versions of Ubuntu to get a persistent USB drive? If you followed the right procedure, you should just be able to follow it again and at the end overwrite the initrd.gz by FlipsideTech: http://launchpadlibrarian.net/13998650/initrd.gz

ArafatMedini (arafato) wrote :
  • unnamed Edit (183 bytes, text/html; charset=ISO-8859-1)

I simply put the Live CD, put the USB flash drive and wrote persistent on
the prompt.
And that was it!
Well I needed to put the Live CD every time put that was fine for me.

Vincent (vinnl) wrote :

Then it's quite obvious it didn't work. Has it ever worked for you with previous versions of Ubuntu (i.e. versions without this bug)? You need to partition the USB drive with a casper-rw partition and what not. I advise you to do a search for a tutorial on how to use Ubuntu persistently with a USB drive. Perhaps use 7.10 first to see if you can get it to work without this bug.

andibrox (andibrox) wrote :

Hi vincent,

i have been trying to get this to work with a loop back file, but am having the same issue with busy box even with using the new initrd, should the procedure still work with a casper-rw loopback file? I have formatted it as ext3 and it is in the root of the key

I have followed the instructions here

https://help.ubuntu.com/community/LiveCD/Persistence?action=show&redirect=LiveCDPersistence

My non persistent ubuntu boots with the new initrd (it did without this anyway as that was just a fix for the persistent problem) and still does with the new initrd,

I would prefer to use the loopback file as i do not need to partition my usb key then

Thanks Andi

ArafatMedini (arafato) wrote :
  • unnamed Edit (455 bytes, text/html; charset=ISO-8859-1)

I used the pendrivelinux
instructions<http://www.pendrivelinux.com/2008/05/08/usb-ubuntu-804-persistent-install-via-the-live-cd/>and
it worked.
Sure, I formatted with fdisk, setup my partitions etc. and it worked.
Let me repeat it again: before hardy came out, I was using persistent mode
with my usb stick and everything was fine.
The problem here is how to get the new initrd into the iso and keep the iso
bootable.

Vincent (vinnl) wrote :

@andi - sorry, I have no experience using loopback files...

@Arafat - ah, it looks like that tutorial already incorporates a workaround for this fix (i.e. steps 19-21 take care of replacing the initrd.gz). You should then just be able to insert a USB drive (no LiveCD needed at this point), boot it and it's supposed to work.

ArafatMedini (arafato) wrote :
  • unnamed Edit (874 bytes, text/html; charset=ISO-8859-1)

I used the tutorials on pendrivelinux with a tutorial on the ubuntu wiki
pages to get a live CD and a usb stick working together.

Because I cannot boot from USB sticks on the different pcs I am frequenting.

The point is, I am not a linux expert. I tried to use that tutorial only
because it easily explained to me at that time how to format my USB stick.

I inserted then the Live CD, inserted the USB stick, switched the PC, pushed
F6 on boot and wrote persistent at the prompt.
Then it was possible for me to use the feisty fawn live cd with persistent
mode.

I checked that feisty fawn works with persistent mode but hardy does not
work so I used feisty and did not follow the instructions on changing the
initrd.

Then I discovered the filed bug, tried to change the initrd and failed.

I hope this helps.

Vincent (vinnl) wrote :

Ah, OK, now I understand what you're trying to do.

I'm curious though: how did you get it to work with Feisty? There was a bug with Feisty, more difficult to work around than this one, that also didn't make persistence work.

Anyway, I'm afraid I don't know how to help. Even if you have the new initrd.gz, you cannot replace it on the CD, so I think you're stuck with this bug and unable to work around it. You'd have to do with Gutsy until this bug is fixed in, say, 8.04.1.

ArafatMedini (arafato) wrote :
  • unnamed Edit (175 bytes, text/html; charset=ISO-8859-1)

that I dont know.
I downloaded the iso and burned and it worked.
In any case would be nice if you could fix this, in the meantime Ill use my
BartPE Windows Live CD.

andibrox (andibrox) wrote :

Hi vincent,

Thanks anyway, I will have a play with some older versions and see what happens!

Thanks Andi

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.134

---------------
casper (1.134) intrepid; urgency=low

  [ Evan Dandrea ]
  * Do not use mode= when mounting /cow using persistent mode (LP: #219192).

  [ Colin Watson ]
  * Support ?= (set value but don't mark as seen) preseeding syntax for
    console-setup/* (LP: #64058).

 -- Colin Watson <email address hidden> Mon, 30 Jun 2008 23:52:41 +0100

Changed in casper:
status: Confirmed → Fix Released
Adam Porter (alphapapa) wrote :

If only that updated casper had been uploaded to Hardy and released with 8.04.1. :(

Well, in the meantime, here is an initrd.gz from 8.04.1 with Dafydd Walters' changes applied to scripts/casper.

Eugene Worley (meangenegjco) wrote :

Any chance of an 8.04.2 release with this bug fixed. It is that important.

Eugene Worley (meangenegjco) wrote :

Does anyone know where I can get an iso with the daffydd initrd.gz included. I just haven't been able to insert it into an iso that I can burn a CD from. I need this badly for anti virus protection. I know how to configure ubuntu to be 99% virus proof without a virus scanner if I can get a working hardy CD iso.

Vincent (vinnl) wrote :

The initrd.gz is updated for 8.10, however, I still have this problem with the fourth and fifth alpha (Xubuntu). Is this the same problem or should I file a new bugreport?

Tim Cutts (timc) wrote :

I think there's something else going on, too. I can't get persistence to work either, and I've built an initrd with the latest casper in it, but it still doesn't work. It never finds the casper-rw or home-rw devices. Having set -x in the casper script to get some debugging info, I see that when it looks for the cow device, scanning things in /sys/block, that the USB devices aren't there yet, so there seems to be some sort of race condition where the USB devices haven't been detected by the time it looks for the home-rw and casper-rw filesystems.

What should I do to fix this? I've tried putting usb-storage in the /conf/modules of the initrd to get it to be loaded earlier, but that hasn't been enough. I could do something nasty like put a deliberate sleep in somewhere, but that's just nasty. Any other ideas?

Tim Cutts (timc) wrote :

OK, so I've made a nasty hack change to my casper script, and that seems to solve the race condition problem. It just loops finding the casper-rw device 5 times, waiting 5 seconds before each try, before it gives up. It only does this if PERSISTENT is set.

This has fixed the problem for me, but I think it's a nasty solution. I guess it would work better if I built a custom kernel for the Live CD which has usb-storage statically compiled in rather than as a module.

Evan Dandrea (ev) wrote :

Tim,

Can you try the latest daily-live CD [1] and report back on whether or not the problem still persists for you?

Thanks

1: http://cdimage.ubuntu.com/daily-live

computer_freak_8 (j8t8b) wrote :

Hello,
I, too, am having issues with the "persistent" feature.

I have tried both of the initial ramdisk files posted here for Ubuntu (by FlipsideTech and Adam Porter), and I am still getting BusyBox. I want to also mention that when I used the file from Adam Porter, it gave me a Kubuntu splash screen (before going to BusyBox).

When I use either of these files, I have the same problem that Christian mentioned. It doesn't fail at the same spot, but it still fails (BusyBox). Right before that, the output is "Begin: Mounting root file system... ..." - following that, I get two blank lines folowed by BusyBox.

Vincent: What is the workaround you are referring to? If it is replacing the mentioned file with one of the ones posted, it didn't work for me. If it is the process in the post at the link below, I don't understand what I need to do to get it to work.
https://bugs.launchpad.net/ubuntu/+source/casper/+bug/219192/comments/3

Tim Cutts (timc) wrote :

On 21 Oct 2008, at 3:45 pm, Evan Dandrea wrote:

> Tim,
>
> Can you try the latest daily-live CD [1] and report back on whether or
> not the problem still persists for you?
>

I haven't tried the daily live CD, but I have tried the Xubuntu 8.10
release live CD, now that it's out, and I still have the same problem,
but the patch I included does still fix it (in its rather crude way)

Tim

Vincent (vinnl) wrote :

@computer_freak_8 - I believe that's the one, yes (it's a while ago though). If I'm right, it's included in the 8.10 ISO. I did get 8.10 to work, except for on one machine, where I also couldn't get previous released to work anymore, so I assume it was a problem at the machine's side.

computer_freak_8 (j8t8b) wrote :

@Vincent - Thanks for the fast response. I am unsure of what that poster referred to as "the casper script" - where is it? Do I replace it with what is posted, or do I append to it? Will a copy & paste work, or will I need to take out the numbers at the beginning of the lines? My guess is to append, and the numbers shown are line numbers, but I still don't know where to find the script. Where is it located?

Thanks so much,
computer_freak_8

Vincent (vinnl) wrote :

@computer_freak_8 - which version of *buntu are you using? It really shouldn't be needed for 8.10 :)

Anyway, I suppose "the casper script" refers to this:

 > The fix is to unpack the initrd.gz file, edit the file 'scipts/casper'
 > (to remove the 'mode=755' from the mount cowdevice line for
 > the persistent case - see below), and repack the initrd.gz.

The fix would be to search for "mode=755" in that file and then overwrite the appropriate lines with the fix over there.

Note that, for Ubuntu 8.04, you can also use FlipsideTech's initrd.gz [1] and I added a version for Xubuntu as well.

[1] https://bugs.launchpad.net/ubuntu/+source/casper/+bug/219192/comments/11

computer_freak_8 (j8t8b) wrote :

@Vincent - Thanks for that. I will try it soon.

I am using Ubuntu (Eee) 8.04.1. I have tried the initrd.gz file from FlipsideTech, as well as the one from Adam Porter - neither worked for me.

I will try this soon, and then report back.

Thanks again!

Colin Watson (cjwatson) on 2009-04-07
Changed in casper (Ubuntu Hardy):
milestone: none → ubuntu-8.04.3
vikjon0 (jonas-vikstrom) wrote :

OK.
I am pretty sure I have the same problem as Tim.
"It just loops finding the casper-rw device 5 times"

I spent quite some time testing both manual fixes and different version of initrd.gz.
I finally realized that I could read the casper.log with one of 5 unix commands I remember from University (more).
In the log I have 5 attempts to mount. Nothing else.

I not 100% sure but I think this was with the xubuntu initrd attached here. If that's correct the pendrive version went on about cannot find CD or something like that.

Does another bug report exists for this problem?

vikjon0 (jonas-vikstrom) wrote :

I tried Tim's fix and it did not work for me. I think I need to give up or go into the details.
I have tried to use the USB creator in Ubuntu 9.0.4 to create a xubuntu 8.0.4 USB. I think it does not hold together?

I could try the same procedure with ubuntu 8.0.4 and leave the x factor out for the moment. If that does not work I think the conclusion must be that USB boot should be created manally on the 8.0.4 level and maybe I should move to 9.0.4 instead. I prefere the LTS though.

Thank you.

Tim Cutts (timc) wrote :

On 7 May 2009, at 9:40 am, vikjon0 wrote:

> I tried Tim's fix and it did not work for me. I think I need to give
> up or go into the details.

It could be that your USB subsystem takes more than 25 seconds to come
up, which would explain why it works for me and not for you. But I
don't know. I did say it was a nasty hack. :-)

Regards,

Tim

--
Tim Cutts
GPG: 1024/D FC81E159 5BA6 8CD4 2C57 9824 6638 C066 16E2 F4F5 FC81 E159

Landmark (landmark) wrote :

Finally got around initrd.gz problem--thank you Flipside Tech for posting that. Still stopping dead every time at "Begin: Mounting root file system..." then dropping to BusyBox.

Info:
Ubuntu 8.04.2
older compaq with Intel Celeron 2.6GHz
768M RAM (16M shared to video)

Ubuntu 8.04 Works fine on this machine booting from hd.

Landmark (landmark) wrote :

To clarify, I am experiencing identical problem as computer_freak_8. Cannot find anything at all (elsewhere on the web) about this further complication after fixing initrd.gz. From my observation and other info I have found, it appears to be after the kernel finishes it's work, and boot scripts begin to run--purely a guess, I'm still pretty new to linux.

Martin Pitt (pitti) wrote :

Accepted casper into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in casper (Ubuntu Hardy):
status: Confirmed → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

I have reproduced the boot into busybox error with the persistent keyword with the hardy 8.04.2 livecd and can confirm that the daily livecd with build id 20090622.1 (from http://cdimages.ubuntu.com/hardy/daily-live/) containing casper 1.132ubuntu0.3 boots successfully with the persistent keyword and that the persistence feature works. I also completed a test install after having booted with the persistent keyword, and confirmed that installation continued to function as expected.

I should note that this testing was performed in a virtualbox environment and that the persistent casper-rw labeled partition existed as a partition on the disk image and not as a separate usb device, so I am unsure whether I have covered all of the relevant failure cases. Regardless, it seems that this update to casper improves the situation with respect to the persistence feature and doesn't appear to introduce regressions, thus I'm marking it verification-done. Thanks.

tags: added: verification-done
removed: verification-needed
vikjon0 (jonas-vikstrom) wrote :

Thank you!
I have now tested and it does fix my problem.

I have used the hardy daily live CD and created a bootable USB stick with the USB start-up disk creator in Ubuntu 9.0.4
I can now boot my work laptop from the USB and I get persistence.

Are the daily 8.0.4.3 builds included in the 8.0.4.2 updates or is that a separate track? I guess I should test.

//J

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.132ubuntu0.3

---------------
casper (1.132ubuntu0.3) hardy-proposed; urgency=low

  * Backports from trunk to fix persistence:
    - Do not use mode= when mounting /cow using persistent mode (LP: #219192).
    - Skip remounting read-only in try_mount as it's unnecessary and breaks
      persistence. Thanks James Westby (LP: #274076).

 -- Evan Dandrea <email address hidden> Wed, 17 Jun 2009 10:39:35 +0100

Changed in casper (Ubuntu Hardy):
status: Fix Committed → Fix Released
Landmark (landmark) wrote :

Thank you for committing the fix. Using the files from the daily live cd for 20090629, I am able to make bootable "pendrive" with persistence using instructions found at http://www.debuntu.org/how-to-install-ubuntu-linux-on-usb-bar.

Tim Cutts (timc) wrote :

I'm still having difficulty getting persistence to work on Xubuntu 9.04; casper version is now 1.173. I still have the same fundamental race condition problem - the casper scripts have completed by the time the USB subsystem has finished initialising itself and any USB storage devices have appeared.

Looks like I will have to continue using my gross hack from https://bugs.launchpad.net/baltix/+source/casper/+bug/219192/comments/53

I don't know what else I could do - perhaps rebuilding the kernel with usb-storage static might help, but I want to continue using standard kernel packages really.

Tim

tags: added: iso-testing
Mitch Towner (kermiac) on 2010-01-23
tags: removed: iso-testing
tags: added: iso-testing
Mitch Towner (kermiac) wrote :

sorry, linked to wrong bug report

tanaka (tanakayuri27) on 2010-07-10
Changed in casper (Ubuntu):
assignee: nobody → tanaka (tanakayuri27)
Steve Langasek (vorlon) on 2010-07-11
Changed in casper (Ubuntu):
assignee: tanaka (tanakayuri27) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers