[Hardy] casper should configure PolicyKit to avoid asking paswd for user ubuntu in live mode

Bug #201852 reported by mariodebian on 2008-03-13
2
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Medium
Martin Pitt

Bug Description

Reproducible:

1.- Start Ubuntu live
2.- Click on NetworkManager to configure network with static IP address (or open System -> Admin -> Network)

All options are grayed and if you click unlock button, PolicyKit ask for ubuntu user password (that is empty).

Solution:

In /usr/share/initramfs-tools/scripts/casper-bottom/ dir create a new script file with this content:

#!/bin/sh

PREREQ=""
DESCRIPTION="Disable PolicyKit for live user..."

. /scripts/casper-functions

prereqs()
{
       echo "$PREREQ"
}

case $1 in
# get pre-requisites
prereqs)
       prereqs
       exit 0
       ;;
esac

log_begin_msg "$DESCRIPTION"

# configure PolicyKit in live session
cat << EOF > /root/etc/PolicyKit/PolicyKit.conf

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
"http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

<!-- See the manual page PolicyKit.conf(5) for file format -->

<config version="0.1">
    <match user="root">
        <return result="yes"/>
    </match>
    <!-- MaX 4.0: don't ask password for user in live session -->
    <match user="$USERNAME">
        <return result="yes"/>
    </match>
    <define_admin_auth group="admin"/>
</config>
EOF

log_end_msg

Related branches

Koen Beek (koen-beek) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in casper.

Martin Pitt (pitti) on 2008-03-13
Changed in casper:
assignee: nobody → pitti
importance: Undecided → High
status: New → In Progress
Martin Pitt (pitti) wrote :

Not a beta blocker, since you can just press enter at the password prompt, but confusing anyway.

Changed in casper:
importance: High → Medium
Martin Pitt (pitti) on 2008-03-14
Changed in casper:
milestone: none → ubuntu-8.04-beta
Martin Pitt (pitti) on 2008-03-14
Changed in casper:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.123

---------------
casper (1.123) hardy; urgency=low

  * Add scripts/casper-bottom/44pk_allow_ubuntu: Allow PolicyKit privileges
    without password to the default live session user. This avoids the need to
    press Enter at the password prompt, which is quite confusing. Thanks to
    MarioDebian! (LP: #201852)

 -- Martin Pitt <email address hidden> Fri, 14 Mar 2008 17:26:37 +0100

Changed in casper:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers