Ubuntu

Support 256MB machines in Ubiquity.

Reported by John McCabe-Dansted on 2008-02-20
6
Affects Status Importance Assigned to Milestone
casper (Baltix)
Undecided
Unassigned
casper (Ubuntu)
Undecided
Unassigned
partman-base (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Ubuntu supports 256MB machines, but Ubiquity only supports machines with 384MB of ram or more. Fixing this is as simple as adding
   modprobe lzo_compress
   modprobe lzo_decompress
   insmod tlsf.ko
   insmod ccache.ko ccache_size_kbytes=128000
   swapon /dev/ccache
to the LiveCD init scripts. (assuming tlsf.ko and ccache.ko are in the current directory)
The source can be downloaded from
   http://ccache.googlecode.com/files/ccache-0.1.tar.bz2http://code.google.com/p/ccache/

This is a form of feature freeze exception request.
0 lines of code are added.
ccache.ko and tlsf.ko require 902 lines of new C code. See:
  http://ccache.googlecode.com/files/ccache-0.1.tar.bz2

I have tested the LiveCD and Ubiquity on a VM with 192MB of ram. Without ccache.ko it is unusable, with ccache.ko it gives good performance even in resource hungry applications like Firefox. For more information on my testing, and discussion of this module, see:
  https://lists.ubuntu.com/archives/sounder/2008-February/011089.html

See also
  bug 114599
  bug 193267
  http://lists.laptop.org/pipermail/linux-mm-cc/2008-February/000195.html
  http://code.google.com/p/ccache/

ProblemType: Bug
Architecture: i386
Date: Wed Feb 20 01:58:39 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ccache tlsf
Package: ubiquity 1.7.6
PackageArchitecture: i386
SourcePackage: ubiquity
Uname: Linux ubuntu 2.6.24-5-generic #1 SMP Thu Jan 24 19:45:21 UTC 2008 i686 GNU/Linux

Related branches

John McCabe-Dansted (gmatht) wrote :
Evan Dandrea (ev) wrote :

Unfortunately, we're past Feature Freeze, so there's just no way that this can go in Hardy. Marking as "later" to be evaluated for Intrepid.

Changed in ubiquity:
milestone: none → later
TerryG (tgalati4) wrote :

Marking as confirmed so I don't keep seeing it in the triage list. Good idea, a new user doesn't realize that you need a swap disk with an older machine with 256 MB of RAM to get a successful install. They only find out through trial-and-error, and searching the forums that the ubiquity installer really needs more than 256 MB of RAM, even though a standard Ubuntu install will run in 256 MB.

Changed in ubiquity:
status: New → Confirmed
John McCabe-Dansted (gmatht) wrote :

I have now packaged this. Note that accepting this freeze exception request will make no difference until request/bug 200765 is accepted. Most of the test data is included in bug 200765.

I have not changed any files that need recompiling and debuild -b succeeds. (I cannot use pbuilder atm due to bug 201496 and because
  hardy/main libatk1.0-0 1.21.92-0ubuntu1 libatk1.0-dev 1.21.92-0ubuntu1 hardy/main python-central 0.5.62ubuntu4
have been removed from
  http://archive.ubuntu.com
This affects the unmodified version as well. I see no reason why pbuilder should fail once this is corrected, but I will retest once the mirrors have sorted themselves out.)

I do not see why these changes should impact installs, upgrades or how it could break packages that depend on ubiquity. In any case, the package installs correctly on the Mar 08 Daily build liveCD (once we have updated libcairo2 to the current version in hardy). The install proceeds as expected.

 Makefile.in | 2
 configure.ac | 2
 d-i/source/partman-base/lib/base.sh | 4 +
 debian/changelog | 6 ++
 debian/init | 2
 ubiquity_compcache | 88 ++++++++++++++++++++++++++++++++++++
 6 files changed, 102 insertions(+), 2 deletions(-)

John McCabe-Dansted (gmatht) wrote :
Steve Langasek (vorlon) wrote :

kernel changes are declined for hardy, so this change is also implicitly declined. Unsubscribing ubuntu-release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 121ubuntu2

---------------
partman-base (121ubuntu2) intrepid; urgency=low

  * Don't disable /dev/ramzswap* swap devices (thanks, John McCabe-Dansted;
    LP: #193552).

 -- Colin Watson <email address hidden> Tue, 01 Jul 2008 12:49:48 +0100

Changed in partman-base:
status: New → Fix Released
John McCabe-Dansted (gmatht) wrote :

Version 0.4 of the kernel module has now been released.
http://compcache.googlecode.com/files/compcache-0.4.tar.gz

Colin Watson (cjwatson) wrote :

This has now been fixed in Intrepid, in a somewhat different way but partly as a result of your suggestions. Thanks!

initramfs-tools (0.92bubuntu4) intrepid; urgency=low

  * Add COMPCACHE_PREREQ varable (needs to be exported before running
    update-initramfs) to the compcache hook script, so that PREREQ can be
    filled by apps like casper. with that we are for example able to
    disable compcache dynamically if a certain amount of physical ram is
    present.
  * Add SKIP_COMPCACHE variable to init-top script (to be read from
    /tmp/compcache.opts which should be filled by a PREREQ script defined in
    COMPCACHE_PREREQ) to make it possible to let the script silently die

 -- Oliver Grawert <email address hidden> Wed, 09 Jul 2008 16:17:39 +0000

initramfs-tools (0.92bubuntu3) intrepid; urgency=low

  * Support loading compcache from the initramfs.
    - conf/initramfs.conf: Add and document the COMPCACHE_SIZE setting.
    - initramfs.conf.5: Document the COMPCACHE_SIZE setting.
    - hooks/compcache: Install the compcache module and a script to initialize
      the cache if COMPCACHE_SIZE contains a value.
    - mkinitramfs: export COMPCACHE_SIZE for the hook.

 -- Johan Kiviniemi <email address hidden> Wed, 09 Jul 2008 03:10:21 +0300

casper (1.139) intrepid; urgency=low

  * add compcache conf.d configuration for initramfs-tools

 -- Oliver Grawert <email address hidden> Thu, 14 Aug 2008 00:25:54 +0200

Changed in casper:
status: Confirmed → Fix Released
Przemysław Kulczycki (azrael) wrote :

Fixed in Intrepid = Fixed in Baltix 4.2 which is based on Jaunty.

Changed in casper (Baltix):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers