kubuntu install fails to boot giving initramfs prompt when floppy drive attached

Bug #191946 reported by Michael Jumper on 2008-02-14
4
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned

Bug Description

When trying to install kubuntu Gutsy (booting from CD), the boot splash and progress bar display, but then the floppy drive starts repeatedly seeking. The floppy drive seeks and the light flashes (with no disk in the drive) for a few minutes before the booting stops, giving an initramfs prompt in the minimal shell (ash).

Unplugging the floppy drive and booting with no floppy drive installed allows the install CD to boot fully, and the install from that point forward is functional.

The difference in the boot process between the two is that the CD is read instead of the floppy when the floppy is not installed, and the floppy drive is read instead of the CD when both are present, even with no disk in the floppy drive.

Michael Vezie (ubuntu-mlvezie) wrote :

I noticed this with kubuntu and Hardy Heron (both 32bit and 64bit). In my case, it wouldn't boot (go to the busybox) with no floppy in the drive. dmesg showed repeated errors trying to read the floppy (not a surprise, as there was no floppy). Eventually, tried putting a blank floppy in the drive, and it booted fine!

Ian Weisser (ian-weisser) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

I have the same problem, first I got this error when using the live CD of kubuntu 8.04.1 64 bit version bruned to a CD-R:

<some large integer here> Buffer I/O error on device fd0, logical block 0

So I burned another copy onto a second CD-R

Same error
tried whit the 32-bit verison same error.

Looked at the connections for the diskette drive and the power connector was not connected, so I connected it and the install booted fine. But It couldent find my SATA drive so I looked in to the box and found that I acidently unplugged the powercabel to my HDD when plugging in the floppy dirves powercabel.

Now everything is connected and the floppy-drive seems to work fine, but now I cant't boot the installation again only get to initramfs prompt in the minimal shell (ash).

Tried whit a floppy inserted and the installation went on fine, but very slow, until i get to the partiton step wich couldent find my HDD. ( all cabels correctly plugged in.

Tried disabeling the floppy drive via bios, no change.

Also tried disconnecting the floppydirve totaly from the motherboard and having it diabled in bios, no change still ash...

Tried having the floppy enabled in bios, but totaly unplugged no floppydrive cabel connected on the motherboard. now I get this error twice:

<some large integer here> Buffer I/O error on device fd0, logical block 0

But after awile the installation starts but can't find my harddrive.

Tried whit the alternative install cd but it stops for a long while and the only thing i se is a blinking _ and

"Kernel alive
kernel direct mapping tables up to 130000000 @ 8000-e000"

But after a while i get to the installation but it get's blank after identifying harddrives. And after jet a long while a dialog about not finding my floppy and it asks if I want to continue whitout it. I chose to do so but my harddrive is not found :(

The thing is I have 4 partitions on my drive,
1st is swap
2: my slamd64 system
3: emty ( for kubuntu )
4: /home for slamd64 and hopefully for kubuntu)

My boot loader is Lilo and it's installed in the MBR

This is my computers specs:

Motherboard, ECS KA3 MVP REV 1.0A
Memory: 2x2gb of DDR2 800mhz in dual chanel mode from Mushkin
Processor: AMD Athlon64 x2 5200+ (AM2)Harddrive Samsung SP2504C SATA2 250gb on IDE Channel 2 (SATA) ACHI
HL-DT-STDVD-ROM G master on IDE channel 0 (PATA)
_NEC DVD_RW ND-35 Slave on IDE channel 0 (PATA)
NVIDIA geforce 8500gt 256mb from gainward (PCI-e)

I'm sleepy now, hope someone can help me whit this :)

Changed in casper (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

Marking as Fix released as using a recent version of Ubuntu (12.04) I could reproduce your bug.

Here's how I tested it as I didn't quite have the hardware (legacy free only here :)):
 - Started a VM with: sudo kvm -cdrom data/vm/iso/testing/precise-desktop-amd64.iso -hda data/vm/ltsp.img -boot d -fda /dev/null
 - Switched to kvm's control console (ctrl-alt-2)
 - Ejected the floppy (to have the reader but nothing in it): "eject floppy0"
 - Switched back to the VM (ctrl-alt-1)
 - Booted the VM on the install media
 - When successfully booted, checked that fd0 indeed exists and is detected as a 1.44MB floppy (to make sure my trick worked)

Changed in casper (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers