file integrity check provides no feedback to the user

Bug #1918733 reported by ԜаӀtеr Ⅼарсһуnѕkі
This bug affects 4 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Won't Fix

Bug Description

As of 1.460, it seems the file integrity check is now running silently, which is great. It wasn't working correctly (bug 1917590) but that's now resolved. Unfortunately, a failed result provides no feedback at any time to the user.

Additionally, the installer can be run despite the bad media. That's probably a separate bug for the installer.

Either way, the software shouldn't let a user continue to waste their time on something that's broken.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: casper 1.460
ProcVersionSignature: Ubuntu 5.10.0-14.15-generic 5.10.11
Uname: Linux 5.10.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu60
Architecture: amd64
CasperMD5CheckMismatches: ./casper/filesystem.manifest
CasperMD5CheckResult: fail
CasperVersion: 1.460
CurrentDesktop: LXQt
Date: Thu Mar 11 21:10:01 2021
LiveMediaBuild: Lubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20210311)
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.casper.conf: 2021-03-11T21:09:00.584000

Revision history for this message
ԜаӀtеr Ⅼарсһуnѕkі (wxl) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

installers should parse and present the status information as generated in /run.

apport & subiquity use it. And ubiquity will store it in /var/log/installer with the next ubiquity upload.

even when it did show error, it didn't block boot and just delayed it a bit. So in practice everyone was still running off bad media.

Changed in casper (Ubuntu):
status: New → Won't Fix
Revision history for this message
Chris Guiver (guiverc) wrote :

I ran a Ubuntu hirsute (Desktop) test yesterday (I think) and just had a rotating loopy thing in the centre of the screen for a long while, no indication as to what the system was doing (I suspected media validation), so this isn't just impacting Lubuntu, but Ubuntu itself I suspect.

I only noted what I saw on
(install worked; but no squashfs errors were present as I `dmesg |grep squashfs` out of habit in testing)

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

loopy thing is just booting slowly. The media check is performed in the background, but should not be blocking boot per se.

Will double check things again, when doing iso testing in a bit.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Revision history for this message
Bob H (bobbicat) wrote :

This bug appears to be fixed in Kubuntu Focal 20.04.03
but not in dailies for Kubuntu Impish, at this time.

Revision history for this message
corrado venturini (corradoventu) wrote :

Problem NOT fixed also in Ubuntu 21.10 daily.

Revision history for this message
corrado venturini (corradoventu) wrote :

if a progress bar is not possible, put at least one message like 'checking install medium' so that the user does not worry

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.