There is no warning to remove install media when rebooting

Bug #1837934 reported by Len Ovens on 2019-07-25
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Unassigned
Eoan
High
Unassigned

Bug Description

After the OS installation from the ISO media, the user is asked to reboot. However, there is no message to remove the install media and the system reboots to the install media instead of the new install.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 5.2.0-8.9-lowlatency 5.2.0
Uname: Linux 5.2.0-8-lowlatency x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Jul 25 11:08:15 2019
InstallCmdLine: file=/cdrom/preseed/ubuntustudio.seed initrd=/casper/initrd quiet splash ---
InstallationDate: Installed on 2019-07-25 (0 days ago)
InstallationMedia: Ubuntu-Studio 19.10 "Eoan Ermine" - Alpha amd64 (20190724)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Len Ovens (len-ovenwerks) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1837934

tags: added: iso-testing
Len Ovens (len-ovenwerks) wrote :

Also tested with the kubuntu ISO, same thing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
FranksMCB (franksmcb) wrote :

Tested in Ubuntu MATE and experienced the same issue.

FranksMCB (franksmcb) wrote :

Tested on Ubuntu MATE 19.10 on current daily eoan 20190819 and same issue.

tags: added: rls-ee-incoming

Is this tested in VirtualBox or on hardware?

tags: removed: rls-ee-incoming
Len Ovens (len-ovenwerks) wrote :

The original bug was from a hardware install.

tags: added: id-5d5ebb844853ba062521e02c
Norbert (nrbrtx) wrote :

From my experience it depends on medium - with ISO written to USB-flash there is no such message.

But if ISO is inserted in virtual CDROM of VM, then the message is shown.

Len Ovens (len-ovenwerks) wrote :

"From my experience it depends on medium - with ISO written to USB-flash there is no such message." IN the past even with an iso written to a USB flash, a message has appeared. In any case this is still a bug and the message is _more_ important when using the USB ISO than in a VM because a VM is not a real install but the an install on hardware from a USB stick is the normal way of installing a Linux distro anymore.

Changed in ubiquity (Ubuntu Eoan):
importance: Undecided → High
FranksMCB (franksmcb) wrote :

I can confirm issue still exists on 20190827 on ISO written to UBS-flash and installed on bare metal.

Brian Murray (brian-murray) wrote :

I happened to be installing an Ubuntu 19.10 Beta image with serial 20191002.1 today and I did see a warning regarding removing the install media. I was testing with virt-manager on kvm.

Changed in ubiquity (Ubuntu Eoan):
status: Confirmed → Incomplete
FranksMCB (franksmcb) wrote :

Using Ubuntu MATE 20191007

On physical hardware there is no warning to remove media.

Using VirtualBox there is a warning to remove media.

Jane Atkinson (irihapeti) wrote :

Seeing the warning in Xubuntu 20191012

QEMU/KVM vm

FranksMCB (franksmcb) wrote :

Seeing this on bare metal installs of Ubuntu MATE 20191012

not seeing it on hw (dell inspiron 7472 + nvidia) with latest build.

Changed in ubiquity (Ubuntu Eoan):
status: Incomplete → Confirmed
Norbert (nrbrtx) wrote :

Tested Ubuntu MATE 19.10 20191012 ISO - do not show warning to remove installation media and pressing Enter. Bug exists.

Tested on Lenovo SL500 with LiveUSB as installation media.

feren (ferenos) wrote :

Alan Pope's stream seems to confirm that this also happens on Standard Ubuntu.
https://www.youtube.com/watch?v=h2XhccvmJCU

Erich Eickmeyer (eeickmeyer) wrote :

Could not duplicate on Ubuntu Studio 19.10 20191912. Warning showed, no error.

Erich Eickmeyer (eeickmeyer) wrote :

To be clear, I could not duplicate on Ubuntu Studio 19.10 20191012 when installed using actual hardware. The warning to remove installation media and press enter was definitely present as expected.

Chris Guiver (guiverc) wrote :

This is likely unhelpful, but Lubuntu doesn't use `ubiquity` (calamares instead) and has had this issue awhile too. I just tested with current 2019-10-12 (22:30) ISO
(following cut/paste from QA-test comments)

hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)
re-install with sole purpose of looking for https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1837934 so as to make comment. I have noted the behavior before (with xubuntu too), but when I asked if it was an issue on IRC, didn't get response (or told it'd been noted before [on xubuntu-devel I think]) so it was just noted in comments awhile in these QA tests & then ignored...

FranksMCB (franksmcb) wrote :

This is no longer occuring on 20191014 release on Ubuntu MATE

Chris Guiver (guiverc) wrote :

I just did an install 20191014 (20:02) using Lubuntu (BIOS, no-encryption, internet) and had message to eject & press enter... :)

FranksMCB (franksmcb) wrote :

Completed installs of Xubuntu 19.10 and Ubuntu 19.10 on bare metal and both prompted to have eject media.

Brian Murray (brian-murray) wrote :

This was fixed by the following upload of casper.

casper (1.425) eoan; urgency=medium

  * Ask for removing the block device when installing from a partition
    (LP: #1837934)

 -- Balint Reczey Mon, 14 Oct 2019 17:29:05 +0200

affects: ubiquity (Ubuntu Eoan) → casper (Ubuntu Eoan)
Changed in casper (Ubuntu Eoan):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers