Disco "check disc for defects" appears not to function

Bug #1824672 reported by Erick Brunzell on 2019-04-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Unassigned

Bug Description

Just testing the 20190413.2 image and after selecting "check disc for defects" the Ubuntu splash screen appears very briefly, no testing text is displayed, and a "no errors found" message appears in under one minute.

As recently as 20190326.2 the test ran as expected displaying "scrolling" text on screen before completing and reporting a pass or fail so I doubt this was an intentional change but I could be mistaken.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: syslinux 3:6.04~git20171011.af7e95c3+dfsg1-6
ProcVersionSignature: Ubuntu 5.0.0-11.12-generic 5.0.6
Uname: Linux 5.0.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CasperVersion: 1.403
CurrentDesktop: ubuntu:GNOME
Date: Sat Apr 13 23:43:46 2019
LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190413.2)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: syslinux
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1824672

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Indeed, the current experience is confusing, empty screen with a cursor in the top left for a while which looks like it's stuck/not working

Changed in syslinux (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

It's supposed to use plymouth to display that text. The script that's calling plymouth is in casper (casper-md5check). I'll reassign this bug there, but it may turn out to be elsewhere.

Trying to look but I'm not very familiar with this area so wouldn't decline any help.

affects: syslinux (Ubuntu) → casper (Ubuntu)
Adam Conrad (adconrad) on 2019-04-15
Changed in casper (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.404

---------------
casper (1.404) disco; urgency=medium

  * casper-md5check/casper-md5check.c: Modernize to make sure we can properly
    ready md5sums and check integrity of files on images. (LP: #1824672)
  * scripts/casper-bottom/01integrity_check: run casper-md5check on tty1.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 15 Apr 2019 19:02:31 -0400

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers