dmesg spammed with nvidia-nvlink messages during install

Bug #1824177 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2019-04-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Critical
Alberto Milone

Bug Description

I'm doing an install of Ubuntu 19.04 on an nVidia equipped laptop. I've selected the 3rd party driver option in ubiquity and now my dmesg is spammed 10x per second with this chunk. This appears to be slowing down the install.

[Wed Apr 10 16:30:12 2019] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[Wed Apr 10 16:30:12 2019] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
[Wed Apr 10 16:30:12 2019] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[Wed Apr 10 16:30:12 2019] NVRM: This can occur when a driver such as:
                           NVRM: nouveau, rivafb, nvidiafb or rivatv
                           NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[Wed Apr 10 16:30:12 2019] NVRM: Try unloading the conflicting kernel module (and/or
                           NVRM: reconfigure your kernel without the conflicting
                           NVRM: driver(s)), then try loading the NVIDIA kernel module
                           NVRM: again.
[Wed Apr 10 16:30:12 2019] NVRM: No NVIDIA graphics adapter probed!

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: ubiquity 19.04.9
ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
Uname: Linux 5.0.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.10-0ubuntu26
Architecture: amd64
CasperVersion: 1.402
CurrentDesktop: ubuntu:GNOME
Date: Wed Apr 10 16:29:38 2019
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd quiet splash --- keyboard-configuration/layoutcode=gb
LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190410)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Will Cooke (willcooke) on 2019-04-10
tags: added: rls-dd-incoming
Martin Wimpress (flexiondotorg) wrote :

I had the same issue when install Ubuntu MATE 19.04 daily with the 3rd party drivers install option selected in Ubiquity. The constant logging significantly slows down the install time. Performing the same install without the 3rd party driver install selected completes in a fraction of the time.

Steve Langasek (vorlon) wrote :

This looks like a problem with the integration in the nvidia drivers package, which should not be trying to load modules immediately after installation and prior to a reboot. Reassigning for investigation.

affects: ubiquity (Ubuntu) → nvidia-graphics-drivers-410 (Ubuntu)
Changed in nvidia-graphics-drivers-410 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

I looked into this, and we simply need a way to prevent the udev rule from trying to load the modules on the live installer.

Iain Lane suggested using an empty udev rule in /run/udev/rules.d/ to override the nvidia one, in casper. I am going to work on the relevant changes.

Changed in casper (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
importance: Undecided → Critical
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1824177

tags: added: iso-testing

I'm not sure changing anything is casper will address this. Aren't the nvidia drivers only installed towards the "end" of the installation process, since they wouldn't be available at boot time for the live image? AFAIK they aren't even shipped on the images.

Alberto Milone (albertomilone) wrote :

After testing on the live image, the above mentioned fix solved the problem. Regardless of when the nvidia driver is actually installed, having udev (repeatedly) trying to modprobe modules and to start daemons is a waste of resources on the live image.

Overriding the udev rule works really well, and nothing happens after the first attempt to modprobe the nvidia module.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.405

---------------
casper (1.405) disco; urgency=medium

  [ Dimitri John Ledkov ]
  * scripts/casper-bottom/25adduser:
    - Make boot non-degraded, by clearing the lock. As otherwise
      systemd-sysusers fails and boots the system degraded on multi-lower
      subiquity images.

  [ Alberto Milone ]
  * scripts/casper-bottom/56override_nvidia_udev_rule:
    - Prevent udev from repeatedly trying to modprobe the nvidia modules
      and to start the relevant daemons on the live image (LP: #1824177).

 -- Alberto Milone <email address hidden> Tue, 16 Apr 2019 15:13:07 +0200

Changed in casper (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-410 (Ubuntu):
status: Confirmed → Invalid
no longer affects: nvidia-graphics-drivers-410 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers