Kubuntu requires that the WiFi password be entered twice before WiFi can be used

Bug #1572244 reported by warren on 2016-04-19
This bug affects 13 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Status tracked in Bionic
Rik Mills
network-manager (Ubuntu)
Status tracked in Bionic
plasma-nm (Ubuntu)
Status tracked in Bionic

Bug Description

Kubuntu 16.04 ISO number 20160417.1 Xenial Final
Bug reported against network-manager
Every time I tried the live Kubuntu 16.04 image on a Lenovo t420 laptop it requires to enter the wifi password twice before I can use the wifi. Once from the network icon panel, then second time a prompt on the desktop to enter the wifi password.

I do not know if this is typical behavior of Kubuntu since I usually use GTK base desktops.
I guess network-manager is the right package to file this report against.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: network-manager 1.1.93-0ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.373
CurrentDesktop: KDE
Date: Tue Apr 19 16:48:02 2016
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
 default via dev wlp3s0 proto static metric 600 dev wlp3s0 scope link metric 1000 dev wlp3s0 proto kernel scope link src metric 600
LiveMediaBuild: Kubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160417.1)
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
 KNOPPIX adfb3f1c-39c2-4410-b1dc-ca553326da52 802-11-wireless 1461084315 Tue 19 Apr 2016 04:45:15 PM UTC yes 0 no /org/freedesktop/NetworkManager/Settings/1 yes wlp3s0 activated /org/freedesktop/NetworkManager/ActiveConnection/3
 Wired connection 1 4957fbd0-8ffa-4de8-aa18-275e6dfdcd9e 802-3-ethernet 1461077415 Tue 19 Apr 2016 02:50:15 PM UTC yes 4294966297 no /org/freedesktop/NetworkManager/Settings/0 no -- -- --
 wlp3s0 wifi connected /org/freedesktop/NetworkManager/Devices/0 KNOPPIX adfb3f1c-39c2-4410-b1dc-ca553326da52 /org/freedesktop/NetworkManager/ActiveConnection/3
 enp0s25 ethernet unavailable /org/freedesktop/NetworkManager/Devices/1 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/2 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

warren (wkclemmons) wrote :
Tyler Hicks (tyhicks) on 2016-04-21
information type: Private Security → Public
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Saurav (saurav1) wrote :

I am experiencing the same issue.

Mike E. (melkevizth) wrote :

Same here.

Changed in network-manager (Ubuntu):
importance: Undecided → Medium
Saurav (saurav1) wrote :

It asked for the password twice even on a freshly installed system, not just in a live session.

Flamewart (mojinopocoescozio) wrote :

Same issue here when running the live session, and also after a fresh install.

Rik Mills (rikmills) wrote :

Still occurring on a 17.04 live session.

Simon Quigley (tsimonq2) wrote :

This bug is extremely annoying, I want to do what I can to get it fixed.

Changed in network-manager (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) on 2017-09-16
Changed in network-manager (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
summary: - Kubuntu 16.04 requires that the wifi password be entered twice before
- wifi can be used
+ Kubuntu requires that the WiFi password be entered twice before WiFi can
+ be used

This was not happening in the 17.04 installed system, but now happens again in the 17.10 installed system (as well as in the live session). Bug #1715156.

Can we please have some information on this/how to make it work correctly? It is now about a year and a half since this bug was reported.

tags: added: artful kubuntu

Added plasma-nm as affected package. I think it may be more of an issue with KDE/Plasma than NetworkManager itself, since it only affects Kubuntu and not other *buntu editions which also use NetworkManager.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-nm (Ubuntu):
status: New → Confirmed
halluzman (halluzman) wrote :

Still happening on new and updated installs in both Kubuntu 17.04 and 17.10.

Waz (paviluf) wrote :

I was about to pass an exam, a powerpoint presentation, so the examiner spelled me the wifi password and after pressing ok an other windows ask for the wifi password! Quite embarrassing...

Is it a Kubuntu bug or Kde one ?

Søren Holm (sgh) wrote :

Happens to me as well.

Rik Mills (rikmills) wrote :
Jeremy Bicha (jbicha) on 2018-02-23
Changed in network-manager (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.10.4-1ubuntu2

network-manager (1.10.4-1ubuntu2) bionic; urgency=medium

  [ Bryan Quigley ]
  * debian/tests/urfkill-integration - don't stop/start network manager

  [ Jeremy Bicha ]
  * Cherry-pick patch from 1.10 branch to fix double prompt for wifi password
    on Kubuntu (LP: #1572244)

 -- Bryan Quigley <email address hidden> Fri, 23 Feb 2018 13:52:48 -0500

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Rik Mills (rikmills) wrote :

Seems there is still another aspect to this, resulting in it still being unfixed for the Kubuntu Live session.

casper runs in scripts/casper-bottom/34disable_kde_services

rm -f /root/usr/share/kde4/services/kwalletd.desktop
rm -f /root/usr/share/kservices5/kwalletd5.desktop
rm -f /root/usr/share/dbus-1/services/org.kde.kwalletd5.service
rm -f /root/usr/share/dbus-1/services/org.kde.kwalletd.service

which was done in 2015 to stop kwallet dunning in the live session completely.

This sadly now has the consequence that plasma-nm sees no actual written config disabling kwalllet, but maybe simply fails to access it thinking it should be available, then falls back to the password with network manager. Hence possibly the double password request.

Since 2016 releases of plasma 5.7.x the change "Store password into NetworkManager by default when KWallet is not enabled" enables fallback to network manager, but seemingly only when plasma-nm knows kwallet is disabled by config, not when it has been just broken by casper.

So one possible solution could be to leave kwallet's files in place, but write a temp config file 'kwalletrc' for just the live session disabling kwallet, so plasma-nm knows to not use it, hence using a working route first time.

Rik Mills (rikmills) wrote :

Made some changes to casper script and spun an iso incorporating the changes here using the Kubuntu CI package builds to test:



Attached is a debdiff with the changes I made.

tags: added: patch
Rik Mills (rikmills) on 2018-03-13
Changed in casper (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Marco Parillo (marco-parillo) wrote :

Fix verified (originally posted to: https://phabricator.kde.org/T7981#132629):

I zsynced kubuntu-ci-stable-bionic-amd64.iso.zsync
I dd'd the ISO to a usb thumb drive
I booted the thumb drive
I saw the WEP network, selected it, and entered the key all in Network Manager from the tray.
I did NOT get the pop-up to re-enter the WEP password.

Darin Miller (darinmiller) wrote :

Network connected without double password prompt via Ubiquity and from the live boot panel icon (rebooted to test both). All secure networks were correctly marked as "secure".

Rik Mills (rikmills) wrote :

Changes in #21 (debdiff) also fixed the issue in my live session tests.

Changed in casper (Ubuntu Bionic):
status: Confirmed → Fix Committed
assignee: nobody → LocutusOfBorg (costamagnagianfranco)
Rik Mills (rikmills) 8 hours ago
Changed in plasma-nm (Ubuntu Bionic):
status: Confirmed → Invalid
Changed in casper (Ubuntu Bionic):
assignee: LocutusOfBorg (costamagnagianfranco) → Rik Mills (rikmills)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.390

casper (1.390) bionic; urgency=medium

  * scripts/casper-bottom/34disable_kde_services:
    - stop disabling kwallet in Kubuntu live session by removing it's
      desktop and service files, and instead write a 'kwalletrc' config
      file disabling it. Allows plasma-nm to recognise it is disabled,
      and not try to use it initially. Fixes repeated wi-fi password
      prompt. (LP: #1572244)

 -- Rik Mills <email address hidden> Mon, 12 Mar 2018 11:45:09 +0000

Changed in casper (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.